R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 06-29-2008, 06:49 PM   #1
Tech Regular
 
MetalShield's Avatar
 
Join Date: Oct 2007
Location: Milton, ON. CA
Posts: 409
Default Product Support from Spectrum, need advice!

Recently at a race (1.spektrum SR3001rx (Pro) lost connection with my transmitter. Ive tried several times to re-bind the RX to my TX but doesn't seem to recognize my transmitter or anyone elses attempting to re-bind it also! the light comes on and flashes but doesn't find the TX...

just curious to see if anyone has some good experiences in regards to returning faulty products to Spektrum and by which means did you use!?
example: phone, email, shipped product in hopes of a return.... curious if this RX is garbage or will spektrum replace it? I don't have the original box or receipt!
__________________
Calvin Mercer - MSPvideos
HobbyHobby Racing Team / XXXmain Inc.
MetalShield is offline   Reply With Quote
Old 06-29-2008, 07:09 PM   #2
Tech Regular
 
lowey79's Avatar
 
Join Date: Dec 2007
Posts: 356
Default

I'm assuming that you are using the DX3R transmitter with that Rx?

The first run of DX3R's were plagued with binding issues due to a firmware fault in the Rx. Spectrum has recognised this and will update your Rx if you send the system in for repairs.

Read this article to find out if your system is indeed one of the affected units?
lowey79 is offline   Reply With Quote
Old 06-29-2008, 10:21 PM   #3
Tech Addict
 
Join Date: Jan 2005
Location: Miami
Posts: 524
Trader Rating: 4 (83%+)
Default

Metalshield you should return it to Spektrum for them to chack or replace you will not have a problem,they have excellent cust. support..
Roniel_R is offline   Reply With Quote
Old 06-29-2008, 11:00 PM   #4
Tech Regular
 
MetalShield's Avatar
 
Join Date: Oct 2007
Location: Milton, ON. CA
Posts: 409
Default

No not using the DX3R... my transmitter is the M8 with the Spektrum Mod. I own four of these receivers and have used Spektrum for over a year. This is the first time a problem like this has happened.
__________________
Calvin Mercer - MSPvideos
HobbyHobby Racing Team / XXXmain Inc.
MetalShield is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Losi product support; Leaves something to be desired. Larks Nitro Off-Road 90 08-20-2008 06:45 AM
Arcadia RC Support Thread + Product Announcements ArcadiaRC Australian Racing 79 04-02-2007 07:24 PM
Arcadia RC Support Thread + Product Information ArcadiaRC Singapore R/C Racers 18 09-30-2006 07:42 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 09:53 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net