R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 06-16-2008, 08:39 PM   #1
Tech Rookie
 
Join Date: Jun 2008
Posts: 5
Default PLEASE HELP!!!!!!!

What the hell is wrong with these damn glow plugs, OK the stock one on my RC8 was crap out the box. So i got 3 of the MC8 plugs and out of those 3 only one worked now it doesn't. still cant break-in this friggin car. I swear I'm getting ready to give up on this thing. I work on real cars for a living and never have this bad of a headache. well only sometimes but please help. Are these things suppose to glow bright red instantly or what. is the glow plug igniter possibly bad? Am I just cursed. at 7.49 a glow plug I cant afford to keep wasting money on these damn things everyday.
tonywing_64 is offline   Reply With Quote
Old 06-16-2008, 08:47 PM   #2
Tech Elite
 
imaxx21's Avatar
 
Join Date: Nov 2007
Location: FL
Posts: 2,725
Trader Rating: 1 (100%+)
Send a message via AIM to imaxx21
Default

what kind of ignitor?

im sure it charged right...
__________________
-Crash
Upgrade RC www.upgrade-rc.com
imaxx21 is offline   Reply With Quote
Old 06-16-2008, 08:50 PM   #3
Tech Addict
 
Powerlink's Avatar
R/C Tech Elite Subscriber
 
Join Date: Dec 2007
Location: so Cal.
Posts: 603
Send a message via AIM to Powerlink
Default

Quote:
Originally Posted by tonywing_64 View Post
What the hell is wrong with these damn glow plugs, OK the stock one on my RC8 was crap out the box. So i got 3 of the MC8 plugs and out of those 3 only one worked now it doesn't. still cant break-in this friggin car. I swear I'm getting ready to give up on this thing. I work on real cars for a living and never have this bad of a headache. well only sometimes but please help. Are these things suppose to glow bright red instantly or what. is the glow plug igniter possibly bad? Am I just cursed. at 7.49 a glow plug I cant afford to keep wasting money on these damn things everyday.
I don't know your experience with nitro motors , but yea make sure your glow igniter is working right. charge it or replace the batt. .If you know somebody that has one you can barrow ,try it before throwing out good plugs. They should glow pretty fast when installed in the igniter.Take one and hold it in the igniter and check it before installing it in the motor. ..good luck
__________________
Karl Rolf
Powerlink is offline   Reply With Quote
Old 06-16-2008, 08:56 PM   #4
Tech Rookie
 
Join Date: Jun 2008
Posts: 5
Default

2 out of the 3 where just warm not even glowing red, I changed the D battery in the igniter still the same. I opened the 3rd glow plug put the igniter on it and it glowed. I was confused as to why the other 2 BRAND NEW ones did not glow. so I put it in started the car up and Bam! it worked. I then cut the fuel shut it off and tried again and nothing. pulled the glow plug, checked it and no glow. It is warm to the touch but no glow. Any ideas? Some guy at work also has a RC8 so I will bring it and have him take a look. But kinda disappointed right now. Thanks for your replies
tonywing_64 is offline   Reply With Quote
Old 06-16-2008, 09:02 PM   #5
Tech Addict
 
Powerlink's Avatar
R/C Tech Elite Subscriber
 
Join Date: Dec 2007
Location: so Cal.
Posts: 603
Send a message via AIM to Powerlink
Default

To me it sounds like that igniter is bunk ,try your friends igniter bet it will fire up no prob. ..
__________________
Karl Rolf
Powerlink is offline   Reply With Quote
Old 06-16-2008, 09:35 PM   #6
Tech Regular
 
jgtruggy's Avatar
 
Join Date: Nov 2007
Location: Portland,OR
Posts: 450
Default

Buy a rechargable ignitor and leave it plugged in at al times. Those D battery ignitors SUCK! I have the losi and it works great. Those plugs should all be good.
__________________
Losi SCTE
Tekin RX8/Tekin Pro-4 4000kv
Topgearhobbies.com
jgtruggy is offline   Reply With Quote
Old 06-16-2008, 09:43 PM   #7
Tech Regular
 
Join Date: Apr 2008
Posts: 334
Trader Rating: 1 (100%+)
Default

Quote:
Originally Posted by jgtruggy View Post
Buy a rechargable ignitor and leave it plugged in at al times. Those D battery ignitors SUCK! I have the losi and it works great. Those plugs should all be good.
damn, yeah its gotta be your igniter if its a D cell one.

get one of these, you dont want any normal batteries on your car, make every battery rechargeable, remote/transmitter, receiver box battery, starter box/ roto start, glow igniter. its worth it.

https://www.carolinasrc.com/webstore...idproduct=3030
new to rc cars is offline   Reply With Quote
Old 06-16-2008, 11:42 PM   #8
Tech Addict
 
wes95_z28's Avatar
 
Join Date: Nov 2006
Location: Norman, Ok
Posts: 747
Trader Rating: 3 (100%+)
Default

Ive been in this hobby for 5 years and of all the glow plugs that I have bought I have never had one that didnt work outta the box/bag whatever. Im not saying that one outta three may be bad, but for 2 outta 3 to be bad, thats almost impossible. Pretty sure it is your glow ignitor, get a good rechargable one, either the hot-shot, the losi. Im sure there are other good ones but those are the only two I have experience with.
__________________
Wes

Kyosho 777 WC w/ big bores, RB S5, ACE 1313 s., Air 357 t., JP-3
HPI Savage X SS, Axial .28, Hitec 5645 Steering servo
Nitro TC3, O.S. .18 CV-R
Associated RC18T, Brushless, Lipo
wes95_z28 is offline   Reply With Quote
Old 06-17-2008, 06:02 PM   #9
Tech Addict
 
superdave2's Avatar
 
Join Date: Feb 2008
Location: mars
Posts: 699
Trader Rating: 3 (100%+)
Default

wow i had a hpi savage 25 that i ran the original plug since day one for 3.5 years i didnt even change it after the break in but yes buy a hot shot 2 i found out they are the best ignitors that i have found ive got 4 diffrent ones and i bought the hot shot new about 6 years and and it still has the same battery in it its just great
__________________
Team Terribles~ARCS Hobbies~Have Fun Hobbies~Answer-RC~Torco Fuel~Fastlane Graphix~ Caster Racing Products~Maxamps~Clockwork Racing Engines~BCG Industries
losi 8t dps .28 jr z9100s jr z9000t
spektrum dx3
superdave2 is offline   Reply With Quote
Old 06-17-2008, 06:11 PM   #10
Tech Elite
 
crazy4wdracer's Avatar
 
Join Date: Aug 2007
Location: Way Out Here
Posts: 3,142
Trader Rating: 25 (100%+)
Send a message via AIM to crazy4wdracer
Default

I've had a Traxxass plug that didn't work that was brand new. I tried a bunch of different glow ignitors on it and still nothing. I never bought traxxass plugs again.
crazy4wdracer is offline   Reply With Quote
Old 06-17-2008, 06:40 PM   #11
Tech Lord
 
wingracer's Avatar
 
Join Date: Nov 2007
Posts: 12,781
Trader Rating: 23 (100%+)
Default

In over ten years of nitro racing I have only ever had one new plug that didn't work and one new plug that leaked. Not around the seal to the head but up through the center pin. Weird I know but only one. Get a good igniter and I would suggest a fast charger for it such as the one from GloBee.

On another note, I have one of the nice looking little OS igniters that uses a rechargeable AA. It works great on hot plugs but a #7 or 8 it will not get to glow. I guess a AA just doesn't have the ass for a cold plug. Stick with the sub C rechargeables.
__________________
Sean. Certified speed crazed mowron.
Team Shepherd USA
www.ashfordhobby.com
wingracer is offline   Reply With Quote
Old 06-26-2008, 04:34 PM   #12
Tech Rookie
 
Join Date: Jun 2008
Posts: 5
Default

Hey guys I did get myself a new igniter. tested all the glow plugs at the lobby hobby shop and they fired right up. I somehow thought thought they needed to be grounded out by the engine or something. I since have finished the break-in period. and love this thing.
tonywing_64 is offline   Reply With Quote
Old 06-26-2008, 04:42 PM   #13
Tech Fanatic
 
Join Date: Jan 2008
Location: All Over So. Fla.
Posts: 985
Trader Rating: 1 (100%+)
Default

Tony, don't you love it when things work out. Now get out there and burn fuel and have fun.
The Working Man is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 04:47 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net