R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 05-29-2008, 06:28 PM   #16
Tech Champion
 
tony montana's Avatar
 
Join Date: Aug 2002
Location: Leonardtown Md.
Posts: 6,115
Trader Rating: 65 (100%+)
Default

man that sucks, Just asking but you didnt over rev it did you? Looks like the rod gave out to me
__________________
K.C. Guy. Team Xray - rc america
tony montana is offline   Reply With Quote
Old 05-29-2008, 06:47 PM   #17
Tech Adept
 
Join Date: Jul 2007
Posts: 224
Send a message via AIM to playboy Send a message via Skype™ to playboy
Default

well i was reving it just keep it on and then it just gave out
playboy is offline   Reply With Quote
Old 05-29-2008, 06:54 PM   #18
Tech Adept
 
Join Date: Jul 2007
Posts: 224
Send a message via AIM to playboy Send a message via Skype™ to playboy
Default

Quote:
Originally Posted by C Branch View Post
Posting online won't get it fixed. If you say you did nothing wrong, then talk to Jammin about it. I am sure they will listen to what you say, and if you seen reasonable and honest, they will probably help you out.
Coming onto a forum and flaming a product will get you nowhere.


Colin
shut up you stupid retard i am not flaming a product i am just asking what i did wrong if anything!!!

also i am putting this up so before people buy this motor they know what there getting into. you get what you pay for. this motor is not bad, its just not very strong is all i am saying

If you dont have anything helpful to say dont say anything!!! GOD!!!
playboy is offline   Reply With Quote
Old 05-29-2008, 06:56 PM   #19
Tech Regular
 
Join Date: Apr 2008
Location: OC, So Cal
Posts: 364
Trader Rating: 4 (100%+)
Default

Yea, that looks to be broken from overrevving.

Are you sure the flywheel didn't loosen up or anything? The motor has to be revving high to do that kind of damage.

Hope they repair it for you.
largeorangefont is offline   Reply With Quote
Old 05-29-2008, 07:01 PM   #20
Tech Elite
 
Join Date: May 2003
Location: Portlandia
Posts: 3,341
Trader Rating: 21 (100%+)
Default

Quote:
Originally Posted by playboy View Post
shut up you stupid retard i am not flaming a product i am just asking what i did wrong if anything!!!

also i am putting this up so before people buy this motor they know what there getting into. you get what you pay for. this motor is not bad, its just not very strong is all i am saying

If you dont have anything helpful to say dont say anything!!! GOD!!!
The Jammin(Picco) engine is great. Just because you had one fail does not mean that they are weak. I have seen every brand of engine have failures like this. Does that mean that they are weak as well?
Sometimes you get a bad one. The manufacturer does not need nor appreciate the bad press from posts like this.

I would contact them about this before they see this thread and deny you warranty.

Sorry for trying to help.
__________________
Time Zone Raceways www.Timezonehobbies.com
www.ColinBranch.com
C Branch is offline   Reply With Quote
Old 05-29-2008, 08:53 PM   #21
Tech Addict
 
wes95_z28's Avatar
 
Join Date: Nov 2006
Location: Norman, Ok
Posts: 747
Trader Rating: 3 (100%+)
Default

Quote:
Originally Posted by playboy View Post
this is my piston
Not so sure they will warranty that, looks like over-rev damage to me. Its always worth a shot to give ofna a call and see if they will warranty it.

Chances are you are out a motor but you make get lucky and have them replace it, I have seen it happen before.

just my .02
__________________
Wes

Kyosho 777 WC w/ big bores, RB S5, ACE 1313 s., Air 357 t., JP-3
HPI Savage X SS, Axial .28, Hitec 5645 Steering servo
Nitro TC3, O.S. .18 CV-R
Associated RC18T, Brushless, Lipo
wes95_z28 is offline   Reply With Quote
Old 05-29-2008, 09:02 PM   #22
Tech Adept
 
Join Date: Jul 2007
Posts: 224
Send a message via AIM to playboy Send a message via Skype™ to playboy
Default

ok guy thanks again for all your quick input.

i called them and they said send it in and we will replace it if you have the reciept and its under 30 days and i do have the reciept and it is only 3 days over warrenty buy the guy said they could do it

hopefuly they can replace it

thanks
playboy is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
my V-Spec blew up Nik Nitro Off-Road 65 03-11-2008 01:45 PM
help! aps dynocharge blew! GAMMACRUSH Radio and Electronics 3 12-25-2007 01:16 AM
engine blew out! rob3412 Rookie Zone 4 04-05-2007 07:04 PM
Blew up new o.s. motor CorallyBQuiK Electric Off-Road 11 03-21-2006 02:10 PM
GT7 Blew up ratter Electric On-Road 9 02-11-2005 11:09 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 10:04 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net