R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 04-29-2008, 12:04 AM   #1
Tech Rookie
 
Join Date: Aug 2007
Posts: 12
Questions?? AXE ROSSI COBRA X1 EVO ENGINE

Hello.I bought this axe rossi engine a month ago.When I started the break in process(official axe rossi guide) I noticed that the front bearing was leeking.Just after the first tank.So I bought a new and I changed it.WHEN I STRIPPED DOWN THE ENGINE I NOTICED THREE THINGS:1)THERE WASN’T SIX SCREWS IN THE COOLING HEAD,I FOUND ONLY FIVE.ONE WAS MISSING,2)THERE WASN’T ANY COPPER GASKET HEAD SHIM UNDER THE GLOW PLUG HEAD,3)THE PISTON HAD SOME VERTICAL HAIR LINES ON THE SURFACE WHICH CONTACTS WITH THE SLEEVE(VERY STRANGE FOR AN ENGINE WHICH HAS RUN ONLY ONE TANK).AND OF COURSE IF YOU CONSIDER THE LEAK OF FRONT BEARING IS THERE A CHANCE THAT THIS MOTOR IS A FAULTY ONE?

WHAT DO YOU THINK?HAS ANYONE THE SAME ENGINE?
deeph is offline   Reply With Quote
Old 04-29-2008, 04:10 AM   #2
Tech Elite
 
DPowers's Avatar
 
Join Date: Jun 2007
Location: Where the fast guys are
Posts: 3,528
Trader Rating: 79 (100%+)
Default

when you say it has a leaking front bearing i know when you are breaking in a motor and you idle it at a rich setting some times the fuel will go out the front bearing, and isnt that motor a turbo plug i dont think it uses a copper gasket and i know the AXE Rossui engine line is very tight so you need to heat the motor up before you even run it. i would for the first 10-15 tanks.
DPowers is offline   Reply With Quote
Old 04-29-2008, 04:59 AM   #3
Tech Regular
 
blwn06's Avatar
 
Join Date: Feb 2007
Location: OOHHH YEAH!!!
Posts: 377
Trader Rating: 3 (100%+)
Send a message via MSN to blwn06
Talking turbo

i think the evo is turbo head only, But definetly heat the motor up befor starting for the first few tanks! they are mega tight from the begining!!
__________________
Kyosho MP9/MP9E/RB6/ZX5FSSP2
SP ESC's and Motors
Futaba 4pl, Expert Servo's
OS/Sworks engines
blwn06 is offline   Reply With Quote
Old 04-29-2008, 08:34 AM   #4
Tech Rookie
 
Join Date: Aug 2007
Posts: 12
Questions??

IT IS TURBO HEAD.IT HAS A COPPER GASKET UNDER THE TURBO HEAD JUST BEFORE THE SLEEVE.IT IS IN THE EXPOSO DRAWING(No9).I DIDN'T HEAT UP THE ENGINE.NOBODY TOLD ME.AFTER THE FIRST TANK I NOTICED SOME OIL DROPS ON THE FLYWHEEL AND ON THE STARTER BOX.BUT AFTER 8 TANKS I FINISHED FOR THAT DAY AND I PUT SOME AFTER RUN OIL.THE NEXT DAY THE OIL HAD RUN OUT OF THE ENGINE ALL OVER THE CHASSIS.THAT'S WHY I CHANGED FRONT BEARING.
WHAT DO YOU THINK ABOUT THE PISTON?
deeph is offline   Reply With Quote
Old 04-29-2008, 09:21 AM   #5
Tech Adept
 
Join Date: Jan 2008
Posts: 208
Send a message via AIM to JustinD
Default

Sad to pay for a messed up engine should have a manufactures warranty on it.
__________________
EB MODS


Mugen MBX6 -EB MOD OS V-Spec / EB MODS FUEL
JustinD is offline   Reply With Quote
Old 04-29-2008, 09:27 AM   #6
Tech Rookie
 
Join Date: Aug 2007
Posts: 12
Default

IT HAS 3 YEARS.BUT TO WHOM SHOULD I CONTACT?
I CONTACTED THE SHOP WHICH I BOUGHT THE ENGINE AND SEND ME A FRONT BEARING.SHOULD I CONTACT TO AXE ROSSI?
SO YOU THINK IT IS A FAULTY ENGINE?
deeph is offline   Reply With Quote
Old 04-29-2008, 09:51 AM   #7
Tech Adept
 
Join Date: Jan 2008
Posts: 208
Send a message via AIM to JustinD
Default

If the engine was new sealed and the front bearing was leaking and it was missing headbolts I would have sent it back.
__________________
EB MODS


Mugen MBX6 -EB MOD OS V-Spec / EB MODS FUEL
JustinD is offline   Reply With Quote
Old 04-29-2008, 09:52 AM   #8
Tech Adept
 
Join Date: Jan 2008
Posts: 208
Send a message via AIM to JustinD
Default

You contact the person you bought it from get a receipt and find the distributor of the engine from where ever your from.
__________________
EB MODS


Mugen MBX6 -EB MOD OS V-Spec / EB MODS FUEL
JustinD is offline   Reply With Quote
Old 04-29-2008, 11:14 AM   #9
Tech Elite
 
ezveedub's Avatar
 
Join Date: Aug 2004
Location: Fort Lauderdale, FL
Posts: 2,411
Trader Rating: 14 (100%+)
Send a message via AIM to ezveedub Send a message via Yahoo to ezveedub
Default

I would say send that engine back. Who ever had that engine must have messed with it. If its missing an head bolt, something is wrong. How many shims did it have? It should had two .20mm shims between the head button and the sleeve. If not, someone opened up that engine.
__________________
Kyosho, Mugen Seiki, Maxy's Fuel, KO Propo
O.S., Ninja JX, Novarossi, RMV
ezveedub is offline   Reply With Quote
Old 04-29-2008, 11:56 AM   #10
Tech Adept
 
Mister-E's Avatar
 
Join Date: Dec 2005
Location: Amsterdam/Jakarta/Dubai
Posts: 142
Trader Rating: 1 (100%+)
Default

I'm very happy with Axe Rossi engine's performance and their service.
I had to fix my engine which was still under manufacturers warranty.
After sending the engine to Italy, they fixed it for free (new engine except the cooling head and carb).

Just contact your supplier or the distributor:

http://shop.vendio.com/RossiEnginesUSA/home.html

Good luck!!
Mister-E is offline   Reply With Quote
Old 04-29-2008, 12:17 PM   #11
Tech Rookie
 
Join Date: Aug 2007
Posts: 12
Default

ezveedub it had no shims.nothing.Just the head touching the sleeve.
How will I send it back.I finished the break in process.And I have changed the front bearing.I don't know what to do.I just sent an email to axe rossi italy explaining all these.I 'll wait.Thank you all
deeph is offline   Reply With Quote
Old 04-29-2008, 01:04 PM   #12
Tech Elite
 
ezveedub's Avatar
 
Join Date: Aug 2004
Location: Fort Lauderdale, FL
Posts: 2,411
Trader Rating: 14 (100%+)
Send a message via AIM to ezveedub Send a message via Yahoo to ezveedub
Default

Was this supposed to be new? Who did you get it from? If I'm not mistaken, it will have to go back to Italy, as I think the US vendor doesn't handle any repairs.
__________________
Kyosho, Mugen Seiki, Maxy's Fuel, KO Propo
O.S., Ninja JX, Novarossi, RMV
ezveedub is offline   Reply With Quote
Old 04-29-2008, 01:28 PM   #13
Tech Rookie
 
Join Date: Aug 2007
Posts: 12
Default

It was new but no seal on the box.Another friend of mine who bought the same engine it had no seal on the box too.It seemed new but I didn't open the engine so I didn't realise all these things from the beginning.I am waiting an answer from Italy.But if I sent the motor there they will see that I've changed the bearing,won't they?
I don't know what to do.Maybe I'll buy a new one.I like this engine

Last edited by deeph; 05-18-2008 at 11:51 AM.
deeph is offline   Reply With Quote
Old 04-29-2008, 02:34 PM   #14
Tech Elite
 
ezveedub's Avatar
 
Join Date: Aug 2004
Location: Fort Lauderdale, FL
Posts: 2,411
Trader Rating: 14 (100%+)
Send a message via AIM to ezveedub Send a message via Yahoo to ezveedub
Default

I would explain to them what you found and who it was purchased from. It is supposed to have shims, and it appears someone took them out and also left out the bolt. Also, I never seen a seal on the box of any of my Axe Rossi engines, but I always take all my new engines apart for inspection. Also, was the original front bearing double sealed or one seal only on the front of the engine? The newer engines come double sealed and also the carb is 2 screw, not 3 screw mixture adjustment.
__________________
Kyosho, Mugen Seiki, Maxy's Fuel, KO Propo
O.S., Ninja JX, Novarossi, RMV
ezveedub is offline   Reply With Quote
Old 04-29-2008, 04:17 PM   #15
Tech Regular
 
FrankBlack's Avatar
 
Join Date: Nov 2006
Location: Bundaberg Qld Australia
Posts: 450
Default

Quote:
Originally Posted by deeph View Post
Hello.I bought this axe rossi engine a month ago.When I started the break in process(official axe rossi guide) I noticed that the front bearing was leeking.Just after the first tank.So I bought a new and I changed it.WHEN I STRIPPED DOWN THE ENGINE I NOTICED THREE THINGS:1)THERE WASN’T SIX SCREWS IN THE COOLING HEAD,I FOUND ONLY FIVE.ONE WAS MISSING,2)THERE WASN’T ANY COPPER GASKET HEAD SHIM UNDER THE GLOW PLUG HEAD,3)THE PISTON HAD SOME VERTICAL HAIR LINES ON THE SURFACE WHICH CONTACTS WITH THE SLEEVE(VERY STRANGE FOR AN ENGINE WHICH HAS RUN ONLY ONE TANK).AND OF COURSE IF YOU CONSIDER THE LEAK OF FRONT BEARING IS THERE A CHANCE THAT THIS MOTOR IS A FAULTY ONE?

WHAT DO YOU THINK?HAS ANYONE THE SAME ENGINE?
Take it back, get a replacement, your not the only one to have this happen. I bought this engine and had the exact same thing happen, verticle gouging on the piston and liner after only a litre. The guy i got it off new im maticulas with my engines and just replaced it straight up, then i heard that he wasnt goin to get warranty for that engine cause the distributor was saying that somethign got into the engine and it was my fault, I DONT THINK SO BUD!!!!! Axe have some serious QC issues with the evo i think
FrankBlack is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Axe-Rossi Cobra Steve Walters R/C Items: For Sale/Trade 8 07-11-2008 06:18 PM
Axe Rossi Cobra Evolution X1 & Axe Rossi 2050 pipe & Manifold FrankBlack Australia For Sale/Trade 0 03-09-2008 12:25 AM
BRAND NEW Axe Rossi Cobra Engine Off Road Competition Mpowerz R/C Items: For Sale/Trade 42 01-23-2008 12:13 AM
Axe Rossi Cobra Marz Australia For Sale/Trade 0 11-15-2007 05:45 PM
AXE Rossi Cobra 21 Jarred King Electric Off-Road 6 03-02-2007 11:51 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 03:45 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net