R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 12-31-2007, 06:10 PM   #1
Tech Regular
 
josher2468's Avatar
 
Join Date: Jul 2007
Location: Carrollton ,TX
Posts: 422
Trader Rating: 11 (100%+)
Default NEED HELP WITH CHAOS!! ENGINE WON'T START!!!RAWR!

ok i already primed the engine but it won't start. the glow igniter is fully charged. everything is aokay but it just won't start. im thinking its a flooded engine. plz help this is my firrst nitro
josher2468 is offline   Reply With Quote
Old 12-31-2007, 06:50 PM   #2
Tech Elite
 
xsxracing's Avatar
 
Join Date: Jun 2007
Location: Wichita, KS
Posts: 4,651
Trader Rating: 33 (100%+)
Send a message via Yahoo to xsxracing
Default

Quote:
Originally Posted by josher2468 View Post
ok i already primed the engine but it won't start. the glow igniter is fully charged. everything is aokay but it just won't start. im thinking its a flooded engine. plz help this is my firrst nitro
Unflood the engine and thene prime it and make sure glow igniter is fully charged and thene see if she will start.
__________________
MrDave3D
xsxracing is offline   Reply With Quote
Old 12-31-2007, 07:02 PM   #3
Tech Regular
 
josher2468's Avatar
 
Join Date: Jul 2007
Location: Carrollton ,TX
Posts: 422
Trader Rating: 11 (100%+)
Default

How do you unflood the engine?
I'm a noob with nitro! I just got it today.
josher2468 is offline   Reply With Quote
Old 12-31-2007, 07:02 PM   #4
Tech Regular
 
cm367700's Avatar
 
Join Date: Jul 2007
Location: carrollton, TX
Posts: 487
Trader Rating: 12 (100%+)
Send a message via AIM to cm367700
Default

sorry double post (were dealing with the same problems)
__________________
(\__/)
(='.'=) This is Bunny. Copy and paste bunny into
("')_("') your signature to help him gain world domination!!!!!!!
JUST DO IT!
cm367700 is offline   Reply With Quote
Old 12-31-2007, 07:06 PM   #5
Tech Regular
 
josher2468's Avatar
 
Join Date: Jul 2007
Location: Carrollton ,TX
Posts: 422
Trader Rating: 11 (100%+)
Default

LOL
josher2468 is offline   Reply With Quote
Old 12-31-2007, 07:49 PM   #6
Tech Elite
 
xsxracing's Avatar
 
Join Date: Jun 2007
Location: Wichita, KS
Posts: 4,651
Trader Rating: 33 (100%+)
Send a message via Yahoo to xsxracing
Default

Get the Mini,Take out the Glow Plug,Dont lose the little ring around glow plug,After takeing out the glow plug,Get a Paper towel fold it in a square like figure.Put over head on motor thene turn the buggy over and pull the pull start 4-5 times and the fuel in the motor will shoot out and onto the paper towl,After you did all of that put the glow plug back in remeber make sure the ring is on the glow plug and thene there you go.
__________________
MrDave3D
xsxracing is offline   Reply With Quote
Old 01-01-2008, 10:49 AM   #7
Tech Regular
 
cm367700's Avatar
 
Join Date: Jul 2007
Location: carrollton, TX
Posts: 487
Trader Rating: 12 (100%+)
Send a message via AIM to cm367700
Default

it not flooded i checked
__________________
(\__/)
(='.'=) This is Bunny. Copy and paste bunny into
("')_("') your signature to help him gain world domination!!!!!!!
JUST DO IT!
cm367700 is offline   Reply With Quote
Old 01-01-2008, 01:44 PM   #8
Tech Elite
 
xsxracing's Avatar
 
Join Date: Jun 2007
Location: Wichita, KS
Posts: 4,651
Trader Rating: 33 (100%+)
Send a message via Yahoo to xsxracing
Default

Quote:
Originally Posted by cm367700 View Post
it not flooded i checked

Hmmm,Check your glow Plug.
__________________
MrDave3D
xsxracing is offline   Reply With Quote
Old 01-01-2008, 02:06 PM   #9
Tech Regular
 
cm367700's Avatar
 
Join Date: Jul 2007
Location: carrollton, TX
Posts: 487
Trader Rating: 12 (100%+)
Send a message via AIM to cm367700
Default

glow plugs fine but i read that AFO(after run oil) helps the engine start cause the sportewerks hasnt gotten ran i a while.(i got it used)
__________________
(\__/)
(='.'=) This is Bunny. Copy and paste bunny into
("')_("') your signature to help him gain world domination!!!!!!!
JUST DO IT!
cm367700 is offline   Reply With Quote
Old 01-01-2008, 03:43 PM   #10
Tech Elite
 
xsxracing's Avatar
 
Join Date: Jun 2007
Location: Wichita, KS
Posts: 4,651
Trader Rating: 33 (100%+)
Send a message via Yahoo to xsxracing
Default

Quote:
Originally Posted by cm367700 View Post
glow plugs fine but i read that AFO(after run oil) helps the engine start cause the sportewerks hasnt gotten ran i a while.(i got it used)
Hmm,Well i dont know what else it could be,I could probly figure it out in person,But not like i live by you etc.....
__________________
MrDave3D
xsxracing is offline   Reply With Quote
Old 01-01-2008, 07:52 PM   #11
Tech Fanatic
 
huskerfreak's Avatar
 
Join Date: Feb 2004
Location: HuskerNation
Posts: 956
Trader Rating: 5 (100%+)
Default

This is why they where sold so cheap. The engine is junk. Sorry but that is the problem with them. Our local hobbyTown sold some of these an nearly everyone sold had something wrong with them.
huskerfreak is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine does not start iphong Electric Off-Road 0 12-27-2006 10:53 PM
new engine...cant get it to start indy_rc Nitro On-Road 13 04-18-2006 06:29 AM
engine start up (non-pull start) racer Nitro On-Road 1 04-10-2004 11:22 PM
engine won't start!!! jughead Rookie Zone 4 12-17-2002 08:48 AM
wheels start spinning right after engine start ( on idle ) slavka Nitro On-Road 2 06-24-2002 11:48 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 03:20 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net