R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 12-09-2007, 08:22 PM   #1
Tech Master
 
chris c's Avatar
 
Join Date: Nov 2006
Location: So Cal Westminster
Posts: 1,155
Trader Rating: 60 (100%+)
Default mugen clutch spring problem

anyone else having a problem with mugen clutch springs breaking???

1.1 this week and a 1.0 2 weeks ago.....


and yes my bell is shimmed right....
wondering if they have a bad lot?
chris c is offline   Reply With Quote
Old 12-09-2007, 08:25 PM   #2
Tech Elite
 
Jason Halvorson's Avatar
 
Join Date: Apr 2007
Location: Grand Forks ND
Posts: 3,955
Trader Rating: 22 (100%+)
Send a message via AIM to Jason Halvorson Send a message via MSN to Jason Halvorson
Default

i have been running mugen clutch spring for years, and have never broke one, but that doent mean it cant happen...i wish i could help you out, but i cant , so good luck buddy...
__________________
08 Sponsors Thank you for all your support!!!!

TEAM OCM USA
TEAM GO TECH
TEAM PRO TWISTER MODS
TEAM VP PRO TIRES

OCM RACING DT-19 EVO, GO TECH ENGINES PTM'ED

OCM RACING DT-19T PRO, GO TECH ENGINES PTM'ED
Jason Halvorson is offline   Reply With Quote
Old 12-09-2007, 08:36 PM   #3
Tech Regular
 
Join Date: Jul 2007
Posts: 385
Default

I had one 1.0 break after a day of racing, and the rest were soft, so I replaced them and one of the replacements broke after 10 min. and after that I was told that Mugen had a Bad batch. This was about 1.5 months ago too and it seems like it is still happening, I was just wondering if they resolved it too and it seems they have not yet. And I had just bought 3 sets to find out they had a bad batch
Nitro syco is offline   Reply With Quote
Old 12-09-2007, 08:39 PM   #4
Tech Master
 
chris c's Avatar
 
Join Date: Nov 2006
Location: So Cal Westminster
Posts: 1,155
Trader Rating: 60 (100%+)
Default

Well i might have to run some ofna ones until mugen gets it figured out

chris c is offline   Reply With Quote
Old 12-09-2007, 08:57 PM   #5
Tech Adept
 
OBMIT's Avatar
 
Join Date: Nov 2007
Location: Darwin, NT, Australia
Posts: 174
Default

I didnt break a spring last race meet and my buggy is new! Touch wood.

I inspected the clutch and all looked good. Just removed the burs and put new bearings in.

Cheers

Tim
OBMIT is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
I need a clutch spring how to salteen Nitro Off-Road 3 11-10-2007 04:00 AM
werks clutch spring dotan23 Nitro Off-Road 3 08-23-2007 01:10 AM
Mbx5r clutch spring help newbie2006 Nitro Off-Road 3 07-22-2007 12:24 AM
Clutch spring tool kahuna2793 Electric Off-Road 6 04-29-2006 06:12 PM
kfactory ntc3 30mm push clutch bell to mugen centax clutch set mugen_kid Nitro On-Road 1 03-04-2003 04:01 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 10:49 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net