R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Nitro Off-Road

Reply
 
Thread Tools Search this Thread
Old 07-24-2007, 10:44 AM   #1
Tech Rookie
 
Join Date: Jun 2007
Posts: 5
Default tick over problems

hi another problem with this engine, i can start the engine but it revs very high and then cuts out the mixture screw is 2.5 turns out from closed which is the manufacturers setting. the only way i can get it to tick over is if i hold the accelerater lever back, as soon as i release it to the centre the engine cuts out. can anyone help.
mhearn is offline   Reply With Quote
Old 07-24-2007, 10:49 AM   #2
Tech Apprentice
 
Join Date: Jul 2007
Posts: 87
Trader Rating: 5 (100%+)
Default

try changing out the glow plugs.. It seemed like everytime this happens to my truggy the glow plud is usually bad.
r6ryder is offline   Reply With Quote
Old 07-24-2007, 10:59 AM   #3
Tech Rookie
 
Join Date: Jun 2007
Posts: 5
Default

thanks i`ll try that i have a new glow plug on its way
mhearn is offline   Reply With Quote
Old 07-24-2007, 11:02 AM   #4
Tech Apprentice
 
Join Date: Jul 2007
Posts: 87
Trader Rating: 5 (100%+)
Default

let me know how it works out for you and good luck
r6ryder is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
C-Tick & Radios! Bundy_Bear Australian Racing 16 08-27-2005 01:06 AM
3PK problems ctardi Electric Off-Road 3 07-03-2004 07:40 PM
GT-7//JR problems... dasgruvn Electric On-Road 2 09-19-2003 11:56 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 03:23 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net