R/C Tech Forums

Go Back   R/C Tech Forums > Members List

FangsCPO FangsCPO is offline

Tech Master

Visitor Messages

Showing Visitor Messages 1 to 2 of 2
  1. Fitox
    03-09-2013 07:24 PM - permalink
    Fitox
    Hello FangsCPO, Do you have a Losi Ten Scte with Rx8 an 4600kv Tekin in your truck?. I have one, the same Tekin combo, and I have some problems. I'm from Chile and I speak little english, I appreciate if you can help me. I have the following problem. When I was running the truck in the first battey, between 3 and 5 minutes the truck stop for a 1 or 2 seconds and then start running again. I'm using 13 tooth pinion. Pleae tell if you know which could be the problem. I have this problem every battery. regards Fito-Chile.
  2. Acill
    03-16-2011 10:05 PM - permalink
    Acill
    I post here all the time. I've heard a lot of people having issues like yours with the new losi 4x4. It's a really heavy truck and will take some time to get it all figured out I'm sure. I plan to stick with my scrt10. I got a new chassis that makes the layout a lot like the losi. You should see it. It's awesom.

About Me

  • About FangsCPO
    Biography
    Retired U.S. Navy (26yrs), I've been playing with R/C Car for about 8 yrs. I should grow up!
    Location
    Chula Vista, CA
    Interests
    R/C, PC Games ( NFS, L4D, Blur) Moutain Biking, Physical Fitness, Digital Photo, Paintball, Softball
    Occupation
    Healthcare Administration - Clinic Services Manager
  • Signature
    Losi 5ive-T - OBR G320RC "Reed" 31.5cc Full Mod
    Losi 5ive-T - "2WD PRO2" OBR G290RC 30.5cc Full Mod
    Losi 5ive-B - OBR G320RC 31.5cc Full Mod
    OBR/TR Core Team Driver
    TLR Team Driver

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 10-16-2017 01:33 PM
  • Join Date: 07-23-2010
  • Referrals: 0

All times are GMT -7. It is currently 03:26 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net