R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 10-13-2016, 05:46 PM   #1
Tech Initiate
 
Join Date: Apr 2012
Posts: 24
Default Exceed madpulse problem

Hello My name is Luis and I am new to Rc cars. I just purchased my first drifter rc car to learn with and its an Exceed 1/18 Madpulse drifter. Figured I could buy this and mess with it before I purchased by first RWD drifter. Well I started playing with the car and it suddenly stopped accelerating forward, now it just vibrates on the ground and it will intermitently go forward again and then stopping and vibrating again, it does this repeatedley and if i let it sit for a while it works fine again for a couple minutes and it does the same thing again. Kinda bummed as I was having a blast with it in the garage but now I'm bummed its not working. Can anyone give me any advice on this problem and also would love to know if there is somewhere I can read about common rc problems and diagnosis. THANKS!!
luisyfz is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 08:42 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net