R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Thread Tools Search this Thread
Old 10-26-2005, 08:58 PM   #1
Tech Fanatic
factory racer's Avatar
Join Date: Aug 2004
Posts: 949
Default is a 10amp discharge rate fine??

i just purchased a intellipeak ice charger and noticed it only has a max. of 10 amp discharge....is this fine or do i have to do them at 30 amps?????is their any way to get the ice to discharge at a higher rate


factory racer is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Discharge Rate Question. wade7575 Electric Off-Road 18 02-29-2008 03:44 PM
Discharge Rate Compensation? avrcguy Electric Off-Road 2 11-21-2007 09:54 AM
Discharge rate ?'s jrxsracer Electric On-Road 19 03-04-2006 07:35 PM
Discharge rate for 19T micros_rock Electric On-Road 1 04-23-2005 01:23 AM
Discharge rate differences/questions.. lee82gx Electric On-Road 3 02-14-2003 09:29 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 09:25 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0