R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 11-02-2014, 05:37 PM   #586
Tech Elite
 
metalnut's Avatar
R/C Tech Elite Subscriber
 
Join Date: Feb 2013
Location: Seattle
Posts: 2,726
Trader Rating: 36 (100%+)
Default

Quote:
Originally Posted by Skiddins View Post
Are you running ARS or not?

If not, then you'll need 1* at the front and 0.0 at the rear.
No ARS for now, no, going to start from a "standard" setup. Ok, so that's basically what I did, thanks!
__________________
Team Nervous | Team Scruffy | Team Orange

"If you ain't first, you're last!"
- Ricky Bobby
metalnut is offline   Reply With Quote
Old 11-02-2014, 10:53 PM   #587
Tech Elite
 
metalnut's Avatar
R/C Tech Elite Subscriber
 
Join Date: Feb 2013
Location: Seattle
Posts: 2,726
Trader Rating: 36 (100%+)
Default

Any of you have parts missing in your 2015 kits? Looks like my came with one missing shock cap. I'll e-mail Xray of course, but that seems like a fairly big miss.
__________________
Team Nervous | Team Scruffy | Team Orange

"If you ain't first, you're last!"
- Ricky Bobby
metalnut is offline   Reply With Quote
Old 11-03-2014, 12:40 AM   #588
Tech Elite
 
R3VoLuTiOn's Avatar
 
Join Date: Jan 2004
Location: Vancouver, Canada
Posts: 2,194
Trader Rating: 24 (100%+)
Default

That is a pretty bad missing piece.

Hope it gets sorted quick for ya!
__________________
John Tsang 🏁 VBC Racing USA 🚗 ORCA RC 🚗 GripworksRC 🚗 MotivRC 🚗 GravityRC 🚗 RC America

http://www.facebook.com/VancouverRRR 🏁 http://www.facebook.com/OvergearedRacing
R3VoLuTiOn is offline   Reply With Quote
Old 11-03-2014, 01:13 AM   #589
Tech Elite
 
metalnut's Avatar
R/C Tech Elite Subscriber
 
Join Date: Feb 2013
Location: Seattle
Posts: 2,726
Trader Rating: 36 (100%+)
Default

Quote:
Originally Posted by R3VoLuTiOn View Post
That is a pretty bad missing piece.

Hope it gets sorted quick for ya!
I got a canned response, basically saying it shouldn't have happened and to get in touch with the retailer I bought it from (AMain). I'm not going to waste people's time for $12, so I just ordered a spare set and I'll have it Wednesday
__________________
Team Nervous | Team Scruffy | Team Orange

"If you ain't first, you're last!"
- Ricky Bobby
metalnut is offline   Reply With Quote
Old 11-03-2014, 02:21 AM   #590
Tech Elite
 
Bishop's Avatar
 
Join Date: May 2004
Location: Brisbane
Posts: 2,208
Trader Rating: 5 (100%+)
Default

Quote:
Originally Posted by metalnut View Post
Any of you have parts missing in your 2015 kits? Looks like my came with one missing shock cap. I'll e-mail Xray of course, but that seems like a fairly big miss.
From memory something fairly minor was missing from my T414 kit, but I think it was like something I had already so I never even bothered to chase it up.

Thats not to pick on Xray either, I have had missing bits from several brands, it's common, as is the odd part that is a dud or reject.
__________________
QRCCRA
www.qrccra.org.au
www.facebook.com/englandparkraceway
www.myrcm.ch/main?pLa=en&hId[1]=org&dId[O]=4331
Bishop is offline   Reply With Quote
Old 11-03-2014, 05:27 PM   #591
Tech Fanatic
 
Join Date: Jan 2004
Location: Elyria, Oh
Posts: 845
Trader Rating: 4 (100%+)
Default

Ran my T4/15 at The Halloween Classic this last weekend in USGT. I used the stock carpet setup and the car was very good right out of the box. I used a Team Scream motor geared at 52/96 with 30 degrees of timing and it came off the track at 129 degrees. Very pleased with the car. just missed the A with it.

chuck
mackin is offline   Reply With Quote
Old 11-03-2014, 05:38 PM   #592
Tech Elite
 
metalnut's Avatar
R/C Tech Elite Subscriber
 
Join Date: Feb 2013
Location: Seattle
Posts: 2,726
Trader Rating: 36 (100%+)
Default

Quote:
Originally Posted by mackin View Post
Ran my T4/15 at The Halloween Classic this last weekend in USGT. I used the stock carpet setup and the car was very good right out of the box. I used a Team Scream motor geared at 52/96 with 30 degrees of timing and it came off the track at 129 degrees. Very pleased with the car. just missed the A with it.

chuck
You were running kit droop? The car didn't feel lazy? What tires, X-Patterns?
__________________
Team Nervous | Team Scruffy | Team Orange

"If you ain't first, you're last!"
- Ricky Bobby
metalnut is offline   Reply With Quote
Old 11-03-2014, 05:43 PM   #593
Tech Fanatic
 
Join Date: Jan 2004
Location: Elyria, Oh
Posts: 845
Trader Rating: 4 (100%+)
Default

Everything was stock. Ride USGT spec tires. Had a gear diff for the front, but didn't try it.
mackin is offline   Reply With Quote
Old 11-03-2014, 05:48 PM   #594
Tech Master
 
locked's Avatar
 
Join Date: Mar 2010
Location: Toronto
Posts: 1,758
Trader Rating: 1 (100%+)
Default

Quote:
Originally Posted by metalnut View Post
Any of you have parts missing in your 2015 kits? Looks like my came with one missing shock cap. I'll e-mail Xray of course, but that seems like a fairly big miss.
Yep, first time in 7 xray kits I've built that I was missing parts. Was missing one of the aluminum shock collar pre-load ring thingies and one of the 3 hole pistons must have broken off the tree before going into the bag. So 2 parts missing from the same bag. Was very surprising. Seems like someone was probably extremely tired or ill while doing the packing of shock parts. I have 3 T4s and a 4th set of T4 shocks, so it didn't really bother me, but if it was my first kit I would have been very annoyed. I did get 5 wheel hexes though, so that was nice. lol
__________________
Dave Locke
Team PerformanceHobbies.ca | ORCA RC | Bodies by Brandon | Team Meeting
XRAY T4'15 x2 | XRAY XB4 | XRAY XB8E | XRAY XB8
locked is offline   Reply With Quote
Old 11-03-2014, 06:00 PM   #595
Tech Elite
 
Odin544's Avatar
 
Join Date: Apr 2011
Location: Kennewick, Washington
Posts: 3,166
Trader Rating: 93 (100%+)
Default

Will the 51mm ecs's from Roche or RSD work in the rear without binding? Or do I need to get a set of 50mm?
__________________
Xray - ORCA - Avid RC - MaxFX Paint
TriCitiesRC.com
Odin544 is offline   Reply With Quote
Old 11-03-2014, 07:12 PM   #596
Tech Elite
 
metalnut's Avatar
R/C Tech Elite Subscriber
 
Join Date: Feb 2013
Location: Seattle
Posts: 2,726
Trader Rating: 36 (100%+)
Default

Quote:
Originally Posted by locked View Post
Yep, first time in 7 xray kits I've built that I was missing parts. Was missing one of the aluminum shock collar pre-load ring thingies and one of the 3 hole pistons must have broken off the tree before going into the bag. So 2 parts missing from the same bag. Was very surprising. Seems like someone was probably extremely tired or ill while doing the packing of shock parts. I have 3 T4s and a 4th set of T4 shocks, so it didn't really bother me, but if it was my first kit I would have been very annoyed. I did get 5 wheel hexes though, so that was nice. lol
That's an interesting data point. Perhaps the "shock" person for the day was indeed not quite on the ball that day. Oh well, a small price to pay for the rest of this quality kit
__________________
Team Nervous | Team Scruffy | Team Orange

"If you ain't first, you're last!"
- Ricky Bobby
metalnut is offline   Reply With Quote
Old 11-03-2014, 07:12 PM   #597
Tech Fanatic
 
swimbikerun's Avatar
 
Join Date: Feb 2006
Location: Cincinnati, OH
Posts: 886
Trader Rating: 100 (100%+)
Default

Quote:
Originally Posted by metalnut View Post
Any of you have parts missing in your 2015 kits? Looks like my came with one missing shock cap. I'll e-mail Xray of course, but that seems like a fairly big miss.
Your shock cap was probably in my kit as I ended up with an extra one.
__________________
-Xray T4 '16/Xray X12 '16
-2010 Cincinnati Beer Mile Champion
swimbikerun is offline   Reply With Quote
Old 11-03-2014, 07:51 PM   #598
Tech Elite
 
R3VoLuTiOn's Avatar
 
Join Date: Jan 2004
Location: Vancouver, Canada
Posts: 2,194
Trader Rating: 24 (100%+)
Default

I was all for defending the QC in the kits, but this is getting a bit much.
__________________
John Tsang 🏁 VBC Racing USA 🚗 ORCA RC 🚗 GripworksRC 🚗 MotivRC 🚗 GravityRC 🚗 RC America

http://www.facebook.com/VancouverRRR 🏁 http://www.facebook.com/OvergearedRacing
R3VoLuTiOn is offline   Reply With Quote
Old 11-03-2014, 08:16 PM   #599
Tech Elite
 
metalnut's Avatar
R/C Tech Elite Subscriber
 
Join Date: Feb 2013
Location: Seattle
Posts: 2,726
Trader Rating: 36 (100%+)
Default

Quote:
Originally Posted by swimbikerun View Post
Your shock cap was probably in my kit as I ended up with an extra one.
That's kinda funny, actually

It does sound like something happened to the shock parts bag QA, I'm going to assume that they were rushing to get the 2015s out the door. Anyone want to start a parts exchange? I'll have an extra cap on wednesday I can mail to whomever is missing one
__________________
Team Nervous | Team Scruffy | Team Orange

"If you ain't first, you're last!"
- Ricky Bobby
metalnut is offline   Reply With Quote
Old 11-03-2014, 09:46 PM   #600
Tech Master
 
Danny-b23's Avatar
 
Join Date: Feb 2009
Location: Saskatoon, SK, Canada
Posts: 1,212
Trader Rating: 3 (100%+)
Default

Ran the car in modified this last weekend at a trophy race in Edmonton, AB. Qualified 2nd and won. Good car.
__________________
RC America|EA Motorsports|ORCA
Danny Buck
WCICS Rep - Round 1, Saskatoon, SK
Danny-b23 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 03:15 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0