R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Thread Tools Search this Thread
Old 06-03-2014, 04:19 PM   #1
Tech Rookie
Join Date: Jun 2014
Posts: 1
Default problems with sukura d3, please help!

hey guys,
new here and pretty new to rc drift.
me and a freind recently bought 2 x sakura d3 and built them. they are countersteer rc drift cars\. we are having some troubles with my freinds d3, it keeps wearing out the front belt and its little front pulley in a matter of minutes. as you steer full lock, the front wheels just lock up. this started happening and before we realized what was actually going on we burnt the belt and pulley out so i replaced the parts for him and dissassembled then reassembled alot of the front end. the problem seemed to have been fixed, then it just happend again. the belt and pulley where burnt out again before my freind realized.
anyone have any idea what this could be? i was told the belt could be to loose so we made it tighter but it just happend again. both our d3's are setup the same and there has been no prolems with mine. i should also mention the front wheels do not rub on anything.
thanks heaps.
jdmrcdrift is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 05:27 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0