R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Thread Tools Search this Thread
Old 02-26-2014, 04:14 PM   #1
Tech Rookie
DancewithMedusa's Avatar
Join Date: Jan 2014
Posts: 13
Default Sway bars

Hi all,

I have an ARC R10 2013, all built and Ive run it a couple of times but I noticed the other day that my sway bars arent even. My other car doesn't have them so im unsure how to adjust them so that they're even.
Help would be much appreciated.

DancewithMedusa is offline   Reply With Quote
Old 02-26-2014, 04:25 PM   #2
Tech Elite
Odin544's Avatar
Join Date: Apr 2011
Location: Kennewick, Washington
Posts: 3,166
Trader Rating: 93 (100%+)

Team Titan ARC R10 190mm EP Touring Car
Xray - ORCA - Avid RC - MaxFX Paint
Odin544 is offline   Reply With Quote
Old 02-26-2014, 07:31 PM   #3
Tech Master
Josh-n-ya's Avatar
Join Date: May 2011
Location: Alameda, CA
Posts: 1,976
Trader Rating: 70 (100%+)

Explain to me how your sway bars are uneven? Side to side? Need more info. Yes you can take this to the ARC forum as well.
Josh-n-ya is offline   Reply With Quote

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 04:50 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0