R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 02-02-2014, 11:14 PM   #226
Tech Elite
 
klaymon's Avatar
 
Join Date: Nov 2009
Location: Columbus, OH
Posts: 2,330
Trader Rating: 71 (100%+)
Default

I've looked into this a bit and I think xray ends will fit. Ordered a set of those.
klaymon is offline   Reply With Quote
Old 02-03-2014, 04:44 PM   #227
Tech Rookie
 
Join Date: Feb 2014
Posts: 1
Default

I just finished building my Xi sport and have run into a problem. The setup requires the ride height to be 5mm in the front and 5.5mm in the rear. Mine is 9.5mm in front and rear. Shock collars are in highest position so shocks can't be adjusted to lower the chassis any further. I ended up lowering the car by adjusting the droop screws. Is this okay?
cccha2 is offline   Reply With Quote
Old 02-04-2014, 12:52 AM   #228
Tech Apprentice
 
Miholc's Avatar
 
Join Date: Oct 2011
Location: Slovenija, Europe
Posts: 66
Default

Impossible to have 9.5mm ride height with all the electronics installed. I have shorty setup (look above), now also aluminum screws , below 1250g RTR weight, with LRP CPX tires which are quite low profile I got no problem with collars all the way up to come @ 5mm ride height.
Miholc is offline   Reply With Quote
Old 02-04-2014, 11:04 AM   #229
Tech Master
 
SCUBA STEVE's Avatar
 
Join Date: Aug 2004
Location: Ohio
Posts: 1,821
Trader Rating: 84 (99%+)
Default

don't use your droop screws for ride height... what tires? Diameter?
SCUBA STEVE is offline   Reply With Quote
Old 02-06-2014, 12:30 AM   #230
Tech Fanatic
 
(0000000000)'s Avatar
 
Join Date: Apr 2012
Posts: 970
Trader Rating: 2 (100%+)
Default

If your collars are up and you are still able to hit 9mm ride height, something is wrong. Did you use the correct ball end?
__________________
My Original USER ID was 0000000000. But now it doesn't seem to work.
(0000000000) is offline   Reply With Quote
Old 02-06-2014, 10:51 AM   #231
Tech Apprentice
 
Miholc's Avatar
 
Join Date: Oct 2011
Location: Slovenija, Europe
Posts: 66
Default

Here is another info for all you Sakura XI Sport modders:

Sakura XI towers + 50 mm Yeah Racing dampers / compared to stock:
(5 mm lower)







Parts used:

SAK-X10/WO
SAK-X11/WO
3RAC-BS48H5/PK
Yeah Racing #DSG-0050BU

Maybe Sakura new upcoming Big Bore shocks can perform better? http://www.3racing.hk/manuals/SAK-U314(jp).jpg
__________________
https://www.facebook.com/mholctuning
www.lipo.si
Miholc is offline   Reply With Quote
Old 02-06-2014, 01:18 PM   #232
Tech Fanatic
 
(0000000000)'s Avatar
 
Join Date: Apr 2012
Posts: 970
Trader Rating: 2 (100%+)
Default

I practiced on the track for 5 hours yesterday. Tried the graphite 4' c hubs. Big mistake. 4 left c hubs broke last night, and 3 knuckles also broke as a result of being attached.

I'm gonna try Xray T4 c hubs and see how they hold up.
__________________
My Original USER ID was 0000000000. But now it doesn't seem to work.
(0000000000) is offline   Reply With Quote
Old 02-07-2014, 10:22 AM   #233
Tech Master
 
kamlooper's Avatar
 
Join Date: Jan 2005
Location: kamloops
Posts: 1,850
Trader Rating: 7 (100%+)
Default

I boiled all the common breakage parts. We'll see if that helps.
__________________
barking from the sidelines
kamlooper is offline   Reply With Quote
Old 02-07-2014, 11:43 PM   #234
Tech Apprentice
 
Join Date: Dec 2013
Posts: 82
Trader Rating: 19 (100%+)
Default

How's everyone liking this car? I am deciding between this and the spec-r s1?
bluem6 is offline   Reply With Quote
Old 02-10-2014, 01:23 PM   #235
Tech Fanatic
 
(0000000000)'s Avatar
 
Join Date: Apr 2012
Posts: 970
Trader Rating: 2 (100%+)
Default

The swap to 4' Xray hubs went well. Didn't break a single thing at the moose jaw wcics. Was second in VTA a-main until I clipped a board and finished 4th.

In my 17.5 stock main, I participated in the dance that usually occurs at the first corner and never recovered. The rest of the main however, the car felt very good and carried a lot of speed through the turns.

Feels good when you tell a guy with an Xray T4 '14, that they got beat by a 90 dollar car
__________________
My Original USER ID was 0000000000. But now it doesn't seem to work.
(0000000000) is offline   Reply With Quote
Old 02-11-2014, 07:32 PM   #236
Tech Fanatic
 
Join Date: Feb 2009
Location: Norcal
Posts: 877
Trader Rating: 88 (100%+)
Default

Can someone help with me with gearing for a 13.5 motor? Thanks.
__________________
Life moves pretty fast. If you don't stop and look around once in a while, you could miss it. -- F. Bueller
eddiemoney13 is offline   Reply With Quote
Old 02-11-2014, 09:51 PM   #237
Tech Adept
 
Join Date: Feb 2013
Posts: 117
Default

Quote:
Originally Posted by eddiemoney13 View Post
Can someone help with me with gearing for a 13.5 motor? Thanks.
I run fdr 3.5 with a ready 21.5, 3.7 with a speed-passion 13.5, 3.1 with a trinity 21.5. it all comes down to the motor and track.

start around 4.0 give it a couple of laps then check.
Yogi- is offline   Reply With Quote
Old 02-11-2014, 10:10 PM   #238
Tech Fanatic
 
Join Date: Feb 2009
Location: Norcal
Posts: 877
Trader Rating: 88 (100%+)
Default

Quote:
Originally Posted by Yogi- View Post
I run fdr 3.5 with a ready 21.5, 3.7 with a speed-passion 13.5, 3.1 with a trinity 21.5. it all comes down to the motor and track.

start around 4.0 give it a couple of laps then check.
Thanks. That's what I was thinking too. I'll try that.
__________________
Life moves pretty fast. If you don't stop and look around once in a while, you could miss it. -- F. Bueller
eddiemoney13 is offline   Reply With Quote
Old 02-18-2014, 10:38 PM   #239
Tech Addict
 
Join Date: Oct 2012
Posts: 510
Default

what set ups are you guys using? (looking for carpet)could a few of you guys post your setups?plz
still the box gear oil? or 80wgt? for the dif

do you guys run this chassis box stock?
or do you use diff springs?

does this come with a servo saver?

would any suspension mounts work from zero?
any big mods need to be done?

thanks tt

Last edited by TeamThibault; 02-18-2014 at 10:56 PM.
TeamThibault is offline   Reply With Quote
Old 02-18-2014, 10:54 PM   #240
Tech Elite
 
klaymon's Avatar
 
Join Date: Nov 2009
Location: Columbus, OH
Posts: 2,330
Trader Rating: 71 (100%+)
Default

I use 30W Losi in the front and 27.5W Losi in the rear. 2K AE diff oil. Stock springs on the front and 5.75 rear. All camber links, shocks, etc. are stock locations. 1.3 mm roll bar in front and 1.2 in rear.

No servo saver is included.
klaymon is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 05:36 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0