R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 11-30-2013, 01:04 PM   #286
Tech Master
 
Jerz616's Avatar
 
Join Date: Oct 2011
Location: Dallas,TX
Posts: 1,045
Trader Rating: 49 (100%+)
Default

Quote:
Originally Posted by rc car guy View Post
so how does this motor in 17.5 racing compare to another 17.5 say the d3.5? or another motor
There isn't much that compares to the D3.5. But that's why it's going to be done with as of March next year. If your club allows them then that's prob the motor to run. I have a Killshot and an Orca and like them both.
__________________
Ryan Gracey

XRAY T4'14/ORCA VXX/ORCA TX 5.0
XRAY XB8'14
Jerz616 is offline   Reply With Quote
Old 11-30-2013, 03:12 PM   #287
Tech Addict
 
rc car guy's Avatar
 
Join Date: Sep 2013
Posts: 647
Default

Quote:
Originally Posted by Jerz616 View Post
There isn't much that compares to the D3.5. But that's why it's going to be done with as of March next year. If your club allows them then that's prob the motor to run. I have a Killshot and an Orca and like them both.
No I dont gave a d3.5 but I was just wondering in comparison I was looking to get an awesome motor for my tc
rc car guy is offline   Reply With Quote
Old 11-30-2013, 03:53 PM   #288
Tech Master
 
Jerz616's Avatar
 
Join Date: Oct 2011
Location: Dallas,TX
Posts: 1,045
Trader Rating: 49 (100%+)
Default

Quote:
Originally Posted by rc car guy View Post
No I dont gave a d3.5 but I was just wondering in comparison I was looking to get an awesome motor for my tc
I would try the Orca if you can find one. The come with a 12.5 mm rotor and are about as smooth as you can get. The HT killshot with a HT rotor is also a good motor. You can gear it pretty tall and it still has a lot of low end and runs cool.
__________________
Ryan Gracey

XRAY T4'14/ORCA VXX/ORCA TX 5.0
XRAY XB8'14
Jerz616 is offline   Reply With Quote
Old 11-30-2013, 05:52 PM   #289
Tech Addict
 
rc car guy's Avatar
 
Join Date: Sep 2013
Posts: 647
Default

Quote:
Originally Posted by Jerz616 View Post
I would try the Orca if you can find one. The come with a 12.5 mm rotor and are about as smooth as you can get. The HT killshot with a HT rotor is also a good motor. You can gear it pretty tall and it still has a lot of low end and runs cool.
Ya I know a guy for the orca stuff and thanks for the info ill look into it
rc car guy is offline   Reply With Quote
Old 12-01-2013, 11:50 AM   #290
Tech Regular
 
Join Date: Oct 2012
Posts: 321
Trader Rating: 18 (100%+)
Default burnt motor

Quote:
Originally Posted by Tommy R View Post
Well, with the advice provided here I was able to increase the timing on my RPM/RPM 17.5 Killshot. I didn't go far. I think it was just from 57* to about 60*. All during my practice sessions (upwards of 5 minutes runtime each time) the motor only got up to about 155*F and the car was very quick/fast so I was very pleased.

Unfortunately, in the first race about half way through, the car abruptly coasted to a stop, let out a big flume of smoke, and died. Looks like the motor let go, but the really bad part is it took out my ESC in the process.

It was only then that I started hearing from numerous people that this is pretty common with the Killshot motors. I'm playing it safe and going elsewhere for my next motor.
I just had this same thing happen to me last night. Killshot high RPM/HT rotor Running 17.5 blinky in a awesomatix A700L geared at 3.7 and 57* timing. I ran a couple practice runs for about 4 min, the motor temps were 155-160 and in the first qual I was in 2 min and the car came to a stop and started smoking, luckily it didn't kill my new speedo.

Maybe there was a bad batch of motors. I had the same problem when the nemesis motors came out. this is starting to make me lose confidence in trinity, im going to contact them and see if they will help me out with another motor.
Donny Banks is offline   Reply With Quote
Old 12-01-2013, 12:18 PM   #291
Tech Master
 
LonnyJ1950's Avatar
 
Join Date: Aug 2009
Location: Tucson, AZ. USA
Posts: 1,140
Default

Bet I know the answer to that question.
__________________
Lonny
LonnyJ1950 is offline   Reply With Quote
Old 12-01-2013, 12:37 PM   #292
Tech Master
 
Jerz616's Avatar
 
Join Date: Oct 2011
Location: Dallas,TX
Posts: 1,045
Trader Rating: 49 (100%+)
Default

Quote:
Originally Posted by Donny Banks View Post
I just had this same thing happen to me last night. Killshot high RPM/HT rotor Running 17.5 blinky in a awesomatix A700L geared at 3.7 and 57* timing. I ran a couple practice runs for about 4 min, the motor temps were 155-160 and in the first qual I was in 2 min and the car came to a stop and started smoking, luckily it didn't kill my new speedo.

Maybe there was a bad batch of motors. I had the same problem when the nemesis motors came out. this is starting to make me lose confidence in trinity, im going to contact them and see if they will help me out with another motor.
I've heard that happening several times when using the HT rotor in the RPM stator. Not sure why. Haven't heard it happening yet with the HT stators.
__________________
Ryan Gracey

XRAY T4'14/ORCA VXX/ORCA TX 5.0
XRAY XB8'14
Jerz616 is offline   Reply With Quote
Old 12-03-2013, 07:01 PM   #293
Tech Addict
 
rc car guy's Avatar
 
Join Date: Sep 2013
Posts: 647
Default

So to get a high torque stator they measure the resistant in the stator and select a higher resistant one?

Last edited by rc car guy; 12-03-2013 at 07:16 PM.
rc car guy is offline   Reply With Quote
Old 12-03-2013, 07:45 PM   #294
Tech Elite
 
JimmyMac's Avatar
 
Join Date: Oct 2001
Location: NC
Posts: 4,343
Default

Quote:
Originally Posted by Donny Banks View Post
I just had this same thing happen to me last night. Killshot high RPM/HT rotor Running 17.5 blinky in a awesomatix A700L geared at 3.7 and 57* timing. I ran a couple practice runs for about 4 min, the motor temps were 155-160 and in the first qual I was in 2 min and the car came to a stop and started smoking, luckily it didn't kill my new speedo.

Maybe there was a bad batch of motors. I had the same problem when the nemesis motors came out. this is starting to make me lose confidence in trinity, im going to contact them and see if they will help me out with another motor.
Same thing happened to me 2 weeks ago. I have a good running Killshot rpm/ht and decided to buy a second one for my other car. I ran a pack through it and motor temp was around 150ish. Started to run another pack and my car stopped on the track during practice. Motor temp was 150ish. It took out the esc. Luckily it was just a Justock and not my V3.1. Pulled the motor and spinning to rotor had a gooey feeling but the rotor wasn't touching/rubbing anything. Swapped the rotor and ends, still the same. Something up with the stator. I just hope my "good" Killshot remains good...
__________________
M.J. McIntyre

R1Wurks
Yokomo YRX12
Ho-B Max
JimmyMac is offline   Reply With Quote
Old 12-29-2013, 10:52 AM   #295
Tech Master
 
edhchoe's Avatar
 
Join Date: Jul 2004
Location: vancouver, wa, usa
Posts: 1,509
Trader Rating: 41 (100%+)
Default

My killshot 17.5t went up in smoke last night as well in Seattle.
I have had it for less than a month and used it for three previous race days (9 heats).
Yesterday, it ran fine for two qualifying heats and during the main it came to a stop and smoke came out of the car. I thought it was the speedo but it was the motor.
Car is VBC d06.
FDR: 3.7
Timing: 57
ESC: Novak edge
edhchoe is offline   Reply With Quote
Old 12-29-2013, 11:34 AM   #296
Tech Master
 
Join Date: Jan 2010
Posts: 1,238
Trader Rating: 20 (100%+)
Default

Quote:
Originally Posted by edhchoe View Post
My killshot 17.5t went up in smoke last night as well in Seattle.
I have had it for less than a month and used it for three previous race days (9 heats).
Yesterday, it ran fine for two qualifying heats and during the main it came to a stop and smoke came out of the car. I thought it was the speedo but it was the motor.
Car is VBC d06.
FDR: 3.7
Timing: 57
ESC: Novak edge
How big is the track and how was the motor setup?
goots is offline   Reply With Quote
Old 12-29-2013, 05:18 PM   #297
Tech Master
 
edhchoe's Avatar
 
Join Date: Jul 2004
Location: vancouver, wa, usa
Posts: 1,509
Trader Rating: 41 (100%+)
Default

Quote:
Originally Posted by goots View Post
How big is the track and how was the motor setup?
This is the track I ran two weeks ago, where the car performed just fine.

I just rechecked the FDR. in the video I had 3.7 and last night I was running 3.8 with the same 57 timing.

I am just glad my ESC survived.

+ YouTube Video
ERROR: If you can see this, then YouTube is down or you don't have Flash installed.
edhchoe is offline   Reply With Quote
Old 12-29-2013, 07:25 PM   #298
Tech Master
 
Jerz616's Avatar
 
Join Date: Oct 2011
Location: Dallas,TX
Posts: 1,045
Trader Rating: 49 (100%+)
Default

Quote:
Originally Posted by edhchoe View Post
This is the track I ran two weeks ago, where the car performed just fine.

I just rechecked the FDR. in the video I had 3.7 and last night I was running 3.8 with the same 57 timing.

I am just glad my ESC survived.

+ YouTube Video
ERROR: If you can see this, then YouTube is down or you don't have Flash installed.
What motor were you running. The torque or rpm version, and what rotor? I have heard of people running the rpm stator with the HT rotor and it did the same thing. What was the temp like when it let go.
__________________
Ryan Gracey

XRAY T4'14/ORCA VXX/ORCA TX 5.0
XRAY XB8'14
Jerz616 is offline   Reply With Quote
Old 12-29-2013, 07:26 PM   #299
Tech Elite
 
JimmyMac's Avatar
 
Join Date: Oct 2001
Location: NC
Posts: 4,343
Default

Which Killshot was it? Torque? RPM? Hybrid?
__________________
M.J. McIntyre

R1Wurks
Yokomo YRX12
Ho-B Max
JimmyMac is offline   Reply With Quote
Old 12-29-2013, 07:26 PM   #300
Tech Master
 
edhchoe's Avatar
 
Join Date: Jul 2004
Location: vancouver, wa, usa
Posts: 1,509
Trader Rating: 41 (100%+)
Default

Edit: it is purple broad power band rotor motor as it came in the box.

Last edited by edhchoe; 12-31-2013 at 11:57 PM.
edhchoe is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 09:28 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0