R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 06-07-2013, 12:36 AM   #556
Super Moderator
 
Cpt.America's Avatar
R/C Tech Elite Subscriber
 
Join Date: Mar 2009
Location: Washington State
Posts: 11,065
Trader Rating: 52 (100%+)
Default

Dang... running the new trinity killshot, and the dang thing doesn't mount into the MI5. No two holes line up no matter how you orient the endbell. Anybody else seeing this?
__________________
A big thanks to my sponsors:
- Fantom Racing - www.fantomracing.com -
- Fusion Graphix- www.fusiongraphix.com -
- RCSpecialties -
Cpt.America is offline   Reply With Quote
Old 06-07-2013, 12:54 AM   #557
Tech Champion
 
Join Date: Sep 2001
Location: Mongville
Posts: 6,970
Trader Rating: 9 (100%+)
Default

Quote:
Originally Posted by Ozasis View Post
You should really seek some assistance for your Photos Putters, pretty ordinary
__________________
12th Scale - The premier class (if you can make runtime)
Besercoe is offline   Reply With Quote
Old 06-07-2013, 12:57 AM   #558
Tech Elite
 
Join Date: Nov 2009
Location: Woodinville, WA
Posts: 2,512
Trader Rating: 8 (100%+)
Default

Quote:
Originally Posted by Cpt.America View Post
Dang... running the new trinity killshot, and the dang thing doesn't mount into the MI5. No two holes line up no matter how you orient the endbell. Anybody else seeing this?
Some T4 owners have had a problem with incorrectly-drilled end-bells. Maybe the same thing?

-Mike
grippgoat is offline   Reply With Quote
Old 06-07-2013, 01:22 AM   #559
Tech Addict
 
Join Date: Jun 2002
Posts: 515
Default

Quote:
Originally Posted by Cpt.America View Post
Dang... running the new trinity killshot, and the dang thing doesn't mount into the MI5. No two holes line up no matter how you orient the endbell. Anybody else seeing this?
the T-4 owners have had to replace the endbells with 3.5 endbells
gdcopbdcop is offline   Reply With Quote
Old 06-07-2013, 02:13 AM   #560
Tech Champion
 
TryHard's Avatar
 
Join Date: Jun 2004
Location: Sydney, NSW
Posts: 5,173
Trader Rating: 4 (100%+)
Default

Quote:
Originally Posted by Xpress View Post
I was thinking it was just because the plate is mounted on an angle. Moving the link mount from hole to hole would result in a height change as well as a link lenth change?
Dont forget as well, because the ball is mounted up side down, if you had a plate with more material on the outside for more holes, you'll get interference as the suspension moved... link could touch the outside of the carbon plates during travel. Really doesn't seem like such a big deal to change plates, and give's a finer amount of adjustment than just holes.
__________________
| THard.co.uk | Xray | Hobbywing |
TryHard is online now   Reply With Quote
Old 06-07-2013, 02:33 AM   #561
Tech Elite
 
Dusttt's Avatar
 
Join Date: Dec 2009
Location: Lake Forest
Posts: 2,151
Trader Rating: 114 (100%+)
Default

Quote:
Originally Posted by Cpt.America View Post
Dang... running the new trinity killshot, and the dang thing doesn't mount into the MI5. No two holes line up no matter how you orient the endbell. Anybody else seeing this?
yep I just tried mine. I haven't built my car yet but as soon as I saw you post this I broke out the mount and tried to hook it up too my new $150 full works fantom kill shot and isn't gonna happen. Im bumming! let me know what you figure out.
__________________
"Whiskey Tango Foxtrot"
Dusttt is offline   Reply With Quote
Old 06-07-2013, 02:39 AM   #562
Tech Elite
 
Skiddins's Avatar
 
Join Date: Feb 2006
Location: Windsor, UK
Posts: 4,526
Default

Quote:
Originally Posted by Cpt.America View Post
Dang... running the new trinity killshot, and the dang thing doesn't mount into the MI5. No two holes line up no matter how you orient the endbell. Anybody else seeing this?
CHange the endbell for the option item.

Page 10;
Trinity kill shot motors
__________________
Xray T4'16, T4'14 (Wet Car)
Xray X12 2016
Xray X1'16
wlrc.co.uk (West London Racing Centre)
RD Disco
Skiddins is offline   Reply With Quote
Old 06-07-2013, 08:49 AM   #563
Super Moderator
 
Cpt.America's Avatar
R/C Tech Elite Subscriber
 
Join Date: Mar 2009
Location: Washington State
Posts: 11,065
Trader Rating: 52 (100%+)
Default

Quote:
Originally Posted by grippgoat View Post
Some T4 owners have had a problem with incorrectly-drilled end-bells. Maybe the same thing?
nope... not even close. They changed the overall orientation of the holes. It's not like its off by a mm or two... it's nowhere even in the ballpark. Doesn't work in my Mi5, or my 417x

Quote:
Originally Posted by Dusttt View Post
yep I just tried mine. I haven't built my car yet but as soon as I saw you post this I broke out the mount and tried to hook it up too my new $150 full works fantom kill shot and isn't gonna happen. Im bumming! let me know what you figure out.
I just got my works edition motor as well (the one im trying to mount up). It's going to require a different end bell plate. The problem, is I cannot for the LIFE OF ME, get a normal steel bearing out of my other lightweight end bells... I paid for my abec7 bearings, and im going to freakin use them, by golly!

Quote:
Originally Posted by Skiddins View Post
CHange the endbell for the option item.

Page 10;
Trinity kill shot motors
Thanks Skiddins, you're always a great help. I have a few of the original light weight end bells, but I can't get the bearings out of them. Tried everything I could think of last night, short of drilling them out. But honestly, I don't think I should have to buy something extra just to get the motor to mount up to 50% of the cars we run. Ridiculous

Thanks again, amigo!
__________________
A big thanks to my sponsors:
- Fantom Racing - www.fantomracing.com -
- Fusion Graphix- www.fusiongraphix.com -
- RCSpecialties -

Last edited by Cpt.America; 06-07-2013 at 10:37 AM.
Cpt.America is offline   Reply With Quote
Old 06-07-2013, 10:39 AM   #564
Tech Champion
 
AdrianM's Avatar
 
Join Date: Aug 2001
Location: Tampa, FL
Posts: 5,914
Trader Rating: 4 (100%+)
Default

Quote:
Originally Posted by Cpt.America View Post
Thanks Skiddins, you're always a great help. I have a few of the original light weight end bells, but I can't get the bearings out them. Tried everything I could think of last night, short of drilling them out.
I think trinity puts a bit of loctite on the bearing when they insert them. To get them out heat the face plate with a heat gun or put it in your oven at 350 deg for 10 min or so. Wear some gloves to handle the hot part and just push the bearing out.
__________________
Adrian Martinez
What I run: Schumacher Mi5/Associated RC10R5.1/Associated RC12R5.2/Futaba/HobbyWing/Team EA Motorsports/BSR Racing
Where I run: Florida Indoor R/C Complex/Thunder Racing/Florida On Road State Series
AdrianM is offline   Reply With Quote
Old 06-07-2013, 11:18 AM   #565
Tech Elite
 
Dusttt's Avatar
 
Join Date: Dec 2009
Location: Lake Forest
Posts: 2,151
Trader Rating: 114 (100%+)
Default

Cpt. Was it looking like the revtech end bell will work? And do you have the option one?
__________________
"Whiskey Tango Foxtrot"
Dusttt is offline   Reply With Quote
Old 06-07-2013, 11:55 AM   #566
Super Moderator
 
Cpt.America's Avatar
R/C Tech Elite Subscriber
 
Join Date: Mar 2009
Location: Washington State
Posts: 11,065
Trader Rating: 52 (100%+)
Default

Quote:
Originally Posted by AdrianM View Post
I think trinity puts a bit of loctite on the bearing when they insert them. To get them out heat the face plate with a heat gun or put it in your oven at 350 deg for 10 min or so. Wear some gloves to handle the hot part and just push the bearing out.
aahhh!! nice and easy! Thanks... I will try that tonight.

Quote:
Originally Posted by Dusttt View Post
Cpt. Was it looking like the revtech end bell will work? And do you have the option one?
yes, the normal revtech (and d3.5) endbells work perfectly fine, both the original heavy ones with no holes, and the light weight ones.
__________________
A big thanks to my sponsors:
- Fantom Racing - www.fantomracing.com -
- Fusion Graphix- www.fusiongraphix.com -
- RCSpecialties -
Cpt.America is offline   Reply With Quote
Old 06-07-2013, 12:04 PM   #567
Tech Champion
 
AdrianM's Avatar
 
Join Date: Aug 2001
Location: Tampa, FL
Posts: 5,914
Trader Rating: 4 (100%+)
Default

I ran into the kill shot problem last night too. Just email Trinity through their "shop" website, not their info website (that contact form appears to be broken). They will send you out a Revtech faceplate. They said they are working on a better solution so if you have a faceplate that works for now (old Revtech, light Revtech or D3.5) sit tight and see what they come up with.
__________________
Adrian Martinez
What I run: Schumacher Mi5/Associated RC10R5.1/Associated RC12R5.2/Futaba/HobbyWing/Team EA Motorsports/BSR Racing
Where I run: Florida Indoor R/C Complex/Thunder Racing/Florida On Road State Series
AdrianM is offline   Reply With Quote
Old 06-07-2013, 12:05 PM   #568
Tech Master
 
Xpress's Avatar
 
Join Date: Nov 2001
Location: Dirt sucks!
Posts: 1,585
Trader Rating: 3 (100%+)
Default

Quote:
Originally Posted by Dusttt View Post
yep I just tried mine. I haven't built my car yet but as soon as I saw you post this I broke out the mount and tried to hook it up too my new $150 full works fantom kill shot and isn't gonna happen. Im bumming! let me know what you figure out.
$150 on a stock motor?
__________________
"Desire is the key to motivation, but it's the determination and commitment to an unrelenting pursuit of laying it down - a commitment to excellence - that will enable you to attain the success you seek to beat ass."

-Espo
Xpress is offline   Reply With Quote
Old 06-07-2013, 12:23 PM   #569
Super Moderator
 
Cpt.America's Avatar
R/C Tech Elite Subscriber
 
Join Date: Mar 2009
Location: Washington State
Posts: 11,065
Trader Rating: 52 (100%+)
Default

Quote:
Originally Posted by Xpress View Post
$150 on a stock motor?
define "stock"? I don't think there is anybody running any stock motors any more.
__________________
A big thanks to my sponsors:
- Fantom Racing - www.fantomracing.com -
- Fusion Graphix- www.fusiongraphix.com -
- RCSpecialties -
Cpt.America is offline   Reply With Quote
Old 06-07-2013, 12:54 PM   #570
Tech Adept
 
machocave's Avatar
 
Join Date: Feb 2012
Posts: 179
Default

Wow! I just added the Express Motor Sports version of the Killshot motor in my shopping cart on Amain Hobbies and I think this may have the endbell problem also:
http://www.amainhobbies.com/product_...ess-Motor-175T

Just wondering if this part would work?
http://www.amainhobbies.com/product_...eramic-Bearing
__________________
MachoCave.TV
Because Everything Matters!
https://www.facebook.com/machocave
machocave is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 01:29 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0