R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 08-20-2006, 10:46 PM   #5056
Suspended
 
Join Date: Jun 2006
Posts: 72
Default

Quote:
Originally Posted by L.Fairtrace
Drove the Proto BMI cyclone today, its awesome and its still getting better. I was already looking into one.
can u post a pic
a-1fire is offline   Reply With Quote
Old 08-20-2006, 10:56 PM   #5057
JCB
Tech Addict
 
JCB's Avatar
 
Join Date: Nov 2003
Location: New Jersey
Posts: 741
Default

Larry, where can we get one...
JCB is offline   Reply With Quote
Old 08-20-2006, 11:24 PM   #5058
Tech Elite
 
F. Alonso's Avatar
 
Join Date: Jan 2004
Location: Melbourne, Australia
Posts: 2,141
Trader Rating: 10 (100%+)
Send a message via AIM to F. Alonso Send a message via Yahoo to F. Alonso
Default

Out of curiousity, what is wrong with the spool that comes with the Surikarn/Hara edition cars?? I am using that and I've found it to work great.
__________________
Simon Feigl
RCRacer.com.au - Dedicated Australian Forum and Website

XRAY | HPI | Hotbodies | Hobbies Australia | LRP Electronics | Futaba
F. Alonso is offline   Reply With Quote
Old 08-21-2006, 12:41 AM   #5059
Tech Elite
 
2-Bad's Avatar
 
Join Date: Jan 2003
Location: Australia
Posts: 2,725
Trader Rating: 24 (100%+)
Default

Quote:
Originally Posted by F. Alonso
Out of curiousity, what is wrong with the spool that comes with the Surikarn/Hara edition cars?? I am using that and I've found it to work great.
On my car there are signs of wear (on outdrive) as well. This has been with Mod motors and constantly using the Tamiya anti-wear grease on the drive pins. So if you've had no sign of wear... what's the fix?
__________________
Yokomo * G Force * Sanwa * SMC * ProSpec
2-Bad is offline   Reply With Quote
Old 08-21-2006, 02:13 AM   #5060
Tech Addict
 
Skill's Avatar
 
Join Date: Apr 2003
Location: Doncaster, England
Posts: 537
Default

I know at least 3 people who have seen signs of wear on their Hara/Surikarn kit spools even after 1 or 2 meetings, running indoors in stock. Sounds like the Tamiya anti-wear grease does work really well then...
Skill is offline   Reply With Quote
Old 08-21-2006, 02:32 AM   #5061
Tech Elite
 
F. Alonso's Avatar
 
Join Date: Jan 2004
Location: Melbourne, Australia
Posts: 2,141
Trader Rating: 10 (100%+)
Send a message via AIM to F. Alonso Send a message via Yahoo to F. Alonso
Default

Really?? That's interesting. I've been using mine for 3 club meets so far and I've only really had minimal wear, just enough really to knock some of the anodized colouring off. I'm not using any grease or anything on that particular part of the universal, so I'm not quite sure whats up there. Just using the Ver2 steel unis. I guess we'll see what happens after some more running but I'll be reporting to let you guys know if and when I do have issues.

All spools will wear, just part and parcel or running them.
__________________
Simon Feigl
RCRacer.com.au - Dedicated Australian Forum and Website

XRAY | HPI | Hotbodies | Hobbies Australia | LRP Electronics | Futaba
F. Alonso is offline   Reply With Quote
Old 08-21-2006, 03:44 AM   #5062
Tech Fanatic
 
Join Date: Jun 2002
Location: Gold Coast Australia
Posts: 800
Trader Rating: 1 (100%+)
Default

I run stock and did not use any lubricant at first an have warn rear diff outdrives and spool to the extent I had to file the Hara spool to get the bearings off.I now use Tamyia antiwear grease and I does make a big difference.
Barger is offline   Reply With Quote
Old 08-21-2006, 04:08 AM   #5063
Tech Master
 
DirtyDog3375's Avatar
 
Join Date: May 2005
Location: Queenslander
Posts: 1,873
Trader Rating: 37 (100%+)
Send a message via MSN to DirtyDog3375
Default

Quote:
Originally Posted by F. Alonso
Out of curiousity, what is wrong with the spool that comes with the Surikarn/Hara edition cars?? I am using that and I've found it to work great.

The reason why I am after another spool is that I have completely worn my original one out after 2 full months of racing mod on asphalt. I do not want to be replacing spools every couple of months. That is why I am asking around. Also, I have tried 3 different lubricants on the outdrives (tamiya anti-wear grease, Muchmore Joint grease and also the stuff that comes with the car -Z152.) along with using no grease at all. So far, it seems that the MuchMore stuff is the way to go.

Hopefully as soon as Jason from BMI finish off their new spool for the HB cyclone (allows for the use of the blades) that will solve my only real issue with the car.

My 2 cents worth.
__________________
:::RCMaker.com.au:::Speedy RC.com.au:::
==========================================================
DirtyDog3375 is offline   Reply With Quote
Old 08-21-2006, 04:14 AM   #5064
Tech Addict
 
Skill's Avatar
 
Join Date: Apr 2003
Location: Doncaster, England
Posts: 537
Default

Yes I know a couple of people who had problems getting the bearings off their spools. I must also say that I don't think this is just down to purely crashing as one of these people is my dad and he doesn't really crash badly very often as he is usually quite a safe driver.

I'm using the TIR spool with the delrin outdrives, the delrin outdrives do break every now and then, but I've heard that the aluminium ones wear at a horrific rate. I've just been trying to modify a stainless industrial fixing to fit but am having a bit of trouble cutting the slots for the drive shafts but I'm sure once I get this sorted this will be the way to go for me.
Skill is offline   Reply With Quote
Old 08-21-2006, 04:33 AM   #5065
Tech Master
 
DirtyDog3375's Avatar
 
Join Date: May 2005
Location: Queenslander
Posts: 1,873
Trader Rating: 37 (100%+)
Send a message via MSN to DirtyDog3375
Default

Skill: How does the Tir spool fit with your driveshafts??? Do they bind??? I assuming you are using the spool with a v2 driveshaft?
__________________
:::RCMaker.com.au:::Speedy RC.com.au:::
==========================================================
DirtyDog3375 is offline   Reply With Quote
Old 08-21-2006, 05:11 AM   #5066
Tech Addict
 
Skill's Avatar
 
Join Date: Apr 2003
Location: Doncaster, England
Posts: 537
Default

Hi, no I am running the ver.1 driveshafts as I have the original Cyclone, there is not binding whatsoever.

From what I understand the balls on the ver.2 driveshafts are bigger? If this is the case then I can see why there would be binding as with the ver.1 driveshafts and delrin outdrives the driveshaft fits quite snugly but moves smoothly.
Skill is offline   Reply With Quote
Old 08-21-2006, 06:27 AM   #5067
Super Moderator
 
Marcos.J's Avatar
R/C Tech Elite Subscriber
 
Join Date: Sep 2003
Location: Semper Fi
Posts: 25,181
Trader Rating: 140 (100%+)
Default

Quote:
Originally Posted by DirtyDog3375
The reason why I am after another spool is that I have completely worn my original one out after 2 full months of racing mod on asphalt. I do not want to be replacing spools every couple of months. That is why I am asking around. Also, I have tried 3 different lubricants on the outdrives (tamiya anti-wear grease, Muchmore Joint grease and also the stuff that comes with the car -Z152.) along with using no grease at all. So far, it seems that the MuchMore stuff is the way to go.

Hopefully as soon as Jason from BMI finish off their new spool for the HB cyclone (allows for the use of the blades) that will solve my only real issue with the car.

My 2 cents worth.
I have BMI spools on both of my Cyclones with no wear! and all I run is mod.
Marcos.J is offline   Reply With Quote
Old 08-21-2006, 06:45 AM   #5068
Tech Elite
 
DavidAlford's Avatar
 
Join Date: Oct 2001
Location: Oklahoma
Posts: 4,151
Trader Rating: 31 (100%+)
Send a message via AIM to DavidAlford
Default

Quote:
Originally Posted by Marcos.J
I have BMI spools on both of my Cyclones with no wear! and all I run is mod.

Thats great, know what about the rest of us who can't get them? I blew my spool in two weekends. Gotta be something better.
__________________
Hot Bodies/HPI | Jconcepts | Viper RC | Xpert | Sippel Speed Shop | Lawton RC Raceway | SXT
DavidAlford is offline   Reply With Quote
Old 08-21-2006, 06:51 AM   #5069
Super Moderator
 
Marcos.J's Avatar
R/C Tech Elite Subscriber
 
Join Date: Sep 2003
Location: Semper Fi
Posts: 25,181
Trader Rating: 140 (100%+)
Default

Quote:
Originally Posted by DavidAlford
Thats great, know what about the rest of us who can't get them? I blew my spool in two weekends. Gotta be something better.
I beleive that he was revising them to work with the blades from the Hara edition, but shot him a email Im sure that he can hook you up
Marcos.J is offline   Reply With Quote
Old 08-21-2006, 08:41 AM   #5070
Tech Elite
 
BillyCaldwell's Avatar
 
Join Date: Aug 2003
Location: OKC, Oklahoma
Posts: 4,005
Trader Rating: 32 (100%+)
Send a message via AIM to BillyCaldwell
Default

I would definitely like to have the bmi spool before regionals in Oct. Make the call Dave!
__________________
Maclin | VP-Pro USA
BillyCaldwell is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hot Bodies Cyclone S wardyl Electric On-Road 4 10-01-2008 08:01 AM
Hot bodies Cyclone 12 k7king R/C Items: For Sale/Trade 1 09-04-2008 08:09 AM
WTB Hot Bodies Cyclone/ cyclone Parts tenpins77 R/C Items: Wanted to Buy 0 07-29-2008 08:48 AM
Hot Bodies Cyclone sdt1 Australia For Sale/Trade 6 07-13-2008 03:05 AM
WTB: Cyclone S/Cyclone Painted bodies vazzo Australia Wanted to Buy 0 02-05-2008 06:15 AM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 05:28 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0