R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Thread Tools Search this Thread
Old 02-12-2012, 10:47 PM   #1
Tech Initiate
Yamaha911's Avatar
Join Date: Feb 2012
Location: Lancaster, CA
Posts: 25
Default Esc no power???

*Ok last night my Novak gtb quit working in my Losi 22. Not a big deal I thought. I have a hobby wing xerun at home in a b4, i will just swap them for now. Well swaped the esc and still no power to the esc. I have power to the rx though, servo is working great. Plan b, motor is bad swapped motors reconnected, same thing. Plan c, swapped the rx for another, still nothing. Plan d, tried 2 other batteries, still nothing. Plan e, maybe it's the transmitter itself, switched models to my Losi 4x4 worked like a charm, switched over to my kyosho, worked like a charm, switched back to the 22, nothing still only the servo is working. Plan f, maybe the servo is drawing too much power so I unplugged it, same result. I checked the tabs and I have clean connections, sensor wire is brand new. I'm completely lost on what to do next. Can someone help???
Yamaha911 is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
for sale motors esc charger power supply servo john stu R/C Items: For Sale/Trade 15 12-14-2011 04:05 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 06:51 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0