R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Thread Tools Search this Thread
Old 03-28-2005, 06:31 PM   #16
Tech Addict
onebeatuptc3's Avatar
Join Date: Mar 2004
Location: Outside Peachtree city in GA
Posts: 552
Trader Rating: 3 (100%+)
Send a message via AIM to onebeatuptc3

i hate reviving these old threads, but id rather do this then a senseless new post. Anyway, im looking at buying a pulsar with this static problem, and luckily the one i own now, doesnt have this problem.

So has anyone else had this problem lately, and sent thiers in and gotten theirs repaired free?
onebeatuptc3 is offline   Reply With Quote
Old 03-29-2005, 07:49 AM   #17
Tech Regular
drsfly's Avatar
Join Date: Feb 2005
Location: NE. Ill
Posts: 441
Default pulsar static problem

I thought it was my fault when I got zapped. Had been outside & was taking my coat off when I leaned over to stop the beep.
Problem is I didn't check the settings after I dis/re connected the charger to p-supply. Unfortunatly it had locked into flex mode with huge amp rate. So fried a new battery on the next charge.
Anyway sent to AE -- they called said board fried/ not repairable but-- would replace whole unit for like $40.
I had not seen this thread before but even so I think that is a pretty fair deal as I never bothered to fill in warranty card etc!
Now I am just waiting for the replacement.

And yes I do know I shouldn't leave new batt's charging w/o watching so I paid for my slacker attitude--- luckily I was close so it only vented & not worse.
drsfly is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
lrp pulsar competition 2, lrp pulsar sport, turbocharger/matcher CHEAP billjacobs R/C Items: For Sale/Trade 6 08-21-2006 08:57 AM
LRP Pulsar compeition charger Problem! anyone else? dynasty Electric On-Road 5 07-02-2006 07:42 PM
LRP Pulsar Competition Charger Problem! 190mph Electric On-Road 5 11-10-2005 06:58 AM
LRP pulsar competition problem raceblast Electric On-Road 12 12-28-2004 09:11 AM
LRP Pulsar Comp - Question / Problem? rctoyguy Electric On-Road 6 09-14-2004 01:06 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 02:43 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0