R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Thread Tools Search this Thread
Old 12-21-2004, 08:10 PM   #1
Tech Adept
Join Date: Jul 2003
Location: Palomar Raceway
Posts: 158
Send a message via AIM to waterblast02
Default Smoked Pro-max Activator - Resistor Burned?

Today my Activator smoked up and from what seems like a bad wire on my part of my batteries. I just noticed now my plugs were wired backwards and so they have a reverse polarity. When we plugged it in it smoked up and smelled bad. We believe that it was probably the resistor. Im gonna be checking on that tomorow and be calling their customer service as to possibly getting it repaired.

My question is if I could just resolder on a new resistor if thats what burned out. Thanks
waterblast02 is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Integy Indi Activator-X Tray $5 Tag R/C Items: For Sale/Trade 0 09-30-2004 11:00 PM
Integy indi activator x John_S Electric On-Road 1 02-14-2004 10:21 AM
Resistor question racinZrooky Electric On-Road 3 12-08-2002 07:23 AM
Resistor question racinZrooky Electric On-Road 2 11-29-2002 02:05 PM
Integy Indi Activator X MX3 Electric On-Road 0 01-11-2002 05:29 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 04:28 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0