R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Thread Tools Search this Thread
Old 12-05-2011, 01:43 PM   #1
Tech Rookie
Join Date: Dec 2011
Posts: 2
Default ESC problems

Hi I am new here.
I have an RC labs 7-6.0PRO and am currently running it on nimhs on an ezrun s10 RTR and a 5700 hpi warp flux (the black motor) All was fine but as I wanted to get an ESC for the tamiya TA03F car I also have I thought I would swap this one one and buy a nice new esc to run my yet to be used lipo battery. Having fitted it and calibrated it I am currently at a loss as to why it free revs fine on the deck, it spurts forward as I would expect, but then the esc cuts out flashing the green leds before allowing my to use the throttle again. the batteries i'm using are an Orion rocket pack 5000 and a pair of plasma 3000s and it happens with each in turn even with the voltage cut off disabled using the program card.
Can anyone help me with this?
TeaC is offline   Reply With Quote
Old 12-05-2011, 03:25 PM   #2
Tech Rookie
Join Date: Dec 2011
Posts: 2

I'm sorry I neglected to state the spec of the new ESC. It's a Hobbywing SC8 120A (SL565) and its this that stops on full throttle and a green LED flashed twice and sometimes lets me go again if I ease off. I turned the voltage cut off off to see if it was this causing it and have recallibrated the esc a nuber of times. I can't seem to find anything that this could be. Does anyone have any ideas? I haven't bought a fake esc (if there are such things) have I?
TeaC is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Novak Havoc pro esc problems webster420 Radio and Electronics 7 06-26-2011 03:55 AM
ESC PROBLEMS firereds Electric On-Road 10 05-28-2010 07:33 AM
eZRun ESC problems Flatty Radio and Electronics 7 11-13-2008 09:00 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 01:12 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0