R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Thread Tools Search this Thread
Old 06-22-2011, 06:08 PM   #1
Tech Master
Join Date: Dec 2009
Location: Sarasota FL
Posts: 1,869
Trader Rating: 43 (94%+)
Default setup help.. please.

Guys im looking for a bit of setup help here. car is cyclone tc w/ exotek conversion. im having a issue geting rear bite. im running the car in vta class on very low bite asphalt. That is bumpy. i was running no rear droop becase every one was telling me i wanted the car to roll. i had on gold 1.2mm front sway bar no rear. tamiya floresent red springs rear and tamiya white fronts. all ready running 3deg rear toe in. rear shocks in middle hole on arm and 4holes up from the bottom of the rear tower. running 3 hole pistions. im just really in need of help..
tcb22185 is offline   Reply With Quote
Old 06-22-2011, 07:15 PM   #2
Tech Master
pejota's Avatar
Join Date: Apr 2008
Location: Vero Beach, FL
Posts: 1,018
Trader Rating: 11 (100%+)

I'd start here...


With some minor changes--
30w oil front and rear
Use the softest springs you own front and rear
Eliminate droop and raise ride height to 8mm so the chassis rolls
Inner camber link height, set both to 2mm

One thing to consider, where are you losing grip? Entering a corner or exiting a corner? Springs control weight transfer. Figure out where and when you are losing grip and adjust your springs accordingly.
pejota is offline   Reply With Quote
Old 06-23-2011, 07:30 PM   #3
Tech Master
Join Date: Dec 2009
Location: Sarasota FL
Posts: 1,869
Trader Rating: 43 (94%+)

Car Is Normaly Loose From The Center Out. Im Going to Get AE Springs And Put Green Rears and Silver Fronts. i got to find out what Shock Pistions Fit These Shocks. Looks Like Tamiya ones do. but not 100% on that. I ended up Striping the Car Clear Down after i Found out there was some HUGE TWEEK in it. Working on Geting it Put Back Togather..

Thanks again..
tcb22185 is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Setup Help Please... R9-R on T2 007 t4tx Electric On-Road 7 08-22-2009 06:38 AM
B4 setup help please SteveJa Electric Off-Road 22 06-13-2007 05:42 PM
MTX-3 Revelations setup help please. racenut123 Nitro On-Road 8 05-01-2003 08:55 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 06:47 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0