R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Thread Tools Search this Thread
Old 06-22-2011, 10:07 AM   #1
Tech Rookie
Join Date: Jun 2011
Posts: 5
Default Problem with losi esc 9500

i purchase the combo with a motor and the esc over a year or 2 ago ago. it was working perfectly, never upgraded or setup the esc. its still on firmware D.11.01.23 but the program is upgraded to 3.0. so yesterday, i decided to used the quick program card to set to full throttle. i power it off and turn it back on, then the receiver, there is no throttle. the steering turns but no throttle. i went on the pc and reset to factory settings but still, it didn't work. i try changing the the throttle limit, but still no success. the battery is set to lipo with 2c, 7.5, which is wat i used. the only lights that are on is the blue light thats all.

rudeboyface is offline   Reply With Quote
Old 02-05-2012, 06:15 AM   #2
Tech Rookie
Join Date: Feb 2012
Posts: 2
Default losi 22rtr stock esc problem

I just recently bought a new 22rtr and yesterday I was out running it and lost throttle. steering works fine. Walked over to the car to check it out and it took off in reverse on its own, then went forward,, I picked the car up and the tires kept going in reverse/forward erratically. I noticed the heat sink on the esc was super hot as well as the motor leads where they solder on to the motor. I ohmed out all connectors including receiver, sensor lead, battery leads and motor leads, all check fine. Im wondering if anyone else has had this problem or did I just get a bad one out of the box.. I tried going in to setup mode but it wouldnt even turn on, so now last night I was without any LED's,,, I checked it this morning, turned on power switch and now I have both the red and green LED on but have not taken it out to see what it is going to do. Im thinking the esc has an internal short... any ideas?
tippettender is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ask Frank Root...Losi, Xcelorin, Losi Racing Tires... Frank Root Electric Off-Road 717 11-23-2012 03:04 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 07:03 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0