R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Thread Tools Search this Thread
Old 09-09-2004, 05:31 AM   #16
Tech Master
Super Steve's Avatar
Join Date: Oct 2003
Location: Toronto, Ontario, Canada
Posts: 1,177
Trader Rating: 9 (100%+)
Send a message via AIM to Super Steve

maybe your pivotblock is bent?

Also with more space between the pivotmounts, when you put any degree of toe block, both sides should read slightly less of this number...
Super Steve is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Faulty Lipo pack? leigh18 Electric Off-Road 7 05-15-2008 02:20 AM
Is My Micro Receiver Faulty? How to bind? stickman310 Rookie Zone 4 08-31-2007 02:59 AM
Faulty armature in new motor? Tral Electric On-Road 7 05-08-2006 12:53 AM
Faulty Personal Transponder MikeR Electric On-Road 17 03-04-2005 12:30 PM
Sirio Engine needle question, is it faulty? no1stunna Nitro On-Road 10 04-14-2003 03:18 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 01:55 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0