R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Thread Tools Search this Thread
Old 12-17-2010, 10:53 PM   #1
Join Date: Dec 2010
Posts: 73
Default tb-03

i have a tamiya tb-03d, and use it all the time for drifting on carpet, brushless set up. the front out drives starting making a clicking noise, and then the ball diff broke, replaced it with a spool, and now has cvds, loud clicking noise still when turning left to right. also the ball diff had shimms, i didnt put back with spool.. i also tried the fuel line method in out drives as spacers, what do i do to get rid of the annoying clicking noise..?
mgriffin is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Tamiya TB-03 gtypecanare Electric On-Road 2294 06-22-2016 07:36 PM
FS: Tamiya Hopped Up TB-03 Hebiki R/C Items: For Sale/Trade 30 10-21-2010 05:05 PM
Tamiya TRF Evolution V MS & Parts Lot for Evo 5/TB-03 swimbikerun R/C Items: For Sale/Trade 10 11-12-2009 12:35 PM
TB-03 or TA-05 for club racer gbasile77 Electric On-Road 21 12-22-2008 12:13 PM
TB-03 IFS Drifting101 Electric On-Road 37 06-10-2008 07:37 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 07:33 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0