Tamiya TRF417

You're on Page 304 of 435
Go to
  • You running stock??

    Use the white springs up front and blue or yellow rear(both Tamiya).
    Run 2.5 camber rear and 1.5 front
    Go for Tamiya 900 shock oil in your rear gear diff and 400 in the shocks.
    Toe out bring it back to 1 max
    Check your suspensionshafts on binding or being bent.
    Then try again.

    regards Roy


    Quote: Currently have this issue suddenly on my 417x.

    My car tends to loose off power. Running on a low traction asphalt.
    Box set up with minimum changes. just out of sudden it's so loose.

    following set up is what i did to make the car handle well.

    box set up for WB except front upper camber link 2mm spacer, rear upper camber link 4mm. toe out 2.5 degree. Ackerman 1mm spacer. droop front 4 and rear 5.

    I find that howcome the car handles so differently hence I revert back to box set up but the car handles the same.

    Currently car set up is "box set up", what i only change is front inner block 1b, front upper camber link with 3mm spacer. Front toe out 1degree. camber 1degree front and rear 1degree. droop front 6 rear 5

    Spool in front and 1000wt for the rear. Running on ride spring front yellow and rear white

    The car is still very loose off power compared to last time


    Wonder for RCA is it ok to run such a difference on the upper camber link. and ackerman. Or I shld as long as the car handles well, differences doesn't matter.
  • Quote: Currently have this issue suddenly on my 417x.

    My car tends to loose off power. Running on a low traction asphalt.
    Box set up with minimum changes. just out of sudden it's so loose.

    following set up is what i did to make the car handle well.

    box set up for WB except front upper camber link 2mm spacer, rear upper camber link 4mm. toe out 2.5 degree. Ackerman 1mm spacer. droop front 4 and rear 5.

    I find that howcome the car handles so differently hence I revert back to box set up but the car handles the same.

    Currently car set up is "box set up", what i only change is front inner block 1b, front upper camber link with 3mm spacer. Front toe out 1degree. camber 1degree front and rear 1degree. droop front 6 rear 5

    Spool in front and 1000wt for the rear. Running on ride spring front yellow and rear white

    The car is still very loose off power compared to last time


    Wonder for RCA is it ok to run such a difference on the upper camber link. and ackerman. Or I shld as long as the car handles well, differences doesn't matter.
    Have you tried a different set of tires?
  • Quote: You running stock??

    Use the white springs up front and blue or yellow rear(both Tamiya).
    Run 2.5 camber rear and 1.5 front
    Go for Tamiya 900 shock oil in your rear gear diff and 400 in the shocks.
    Toe out bring it back to 1 max
    Check your suspensionshafts on binding or being bent.
    Then try again.

    regards Roy
    Noted.. running 13.5 boosted. FDR 6.75

    Will try the springs. toe currently running 1 degree. just rebuild my shocks but found nothing wrong. Change orings etc. using prospect 450wt.
  • Quote: Have you tried a different set of tires?
    use a new set of tires to set my car.
  • Running Tamiya 400 in my shocks and with your camber link setup i tend to understeer then and the rear is planted like a concreed brick
    Check if the tires are glued perfectly all around.
    This could also cause that problem.
    Had it before with LRP tires but since i am running Sorex and Ride, no problems at all.

    regards Roy
    Ps 350WT is almost 400 Tamiya(bit higher)


    Quote: using prospect 450wt.
  • Quote: Currently have this issue suddenly on my 417x.

    My car tends to loose off power. Running on a low traction asphalt.
    Box set up with minimum changes. just out of sudden it's so loose.

    following set up is what i did to make the car handle well.

    box set up for WB except front upper camber link 2mm spacer, rear upper camber link 4mm. toe out 2.5 degree. Ackerman 1mm spacer. droop front 4 and rear 5.

    I find that howcome the car handles so differently hence I revert back to box set up but the car handles the same.

    Currently car set up is "box set up", what i only change is front inner block 1b, front upper camber link with 3mm spacer. Front toe out 1degree. camber 1degree front and rear 1degree. droop front 6 rear 5

    Spool in front and 1000wt for the rear. Running on ride spring front yellow and rear white

    The car is still very loose off power compared to last time


    Wonder for RCA is it ok to run such a difference on the upper camber link. and ackerman. Or I shld as long as the car handles well, differences doesn't matter.
    Your camber links are very wrong. Assuming you have the 0.5mm spacer on the c-hub and 3mm on the rear upright, then you should run 3.5-4mm front and 3-3.5mm rear - the lower the link the more grip that end of the car will have, so yes your car will be loose with a low front camber link and a high rear one.

    Run 2mm ackerman and try a stiffer spring like ride red front/rear.
  • Quote: Your camber links are very wrong. Assuming you have the 0.5mm spacer on the c-hub and 3mm on the rear upright, then you should run 3.5-4mm front and 3-3.5mm rear - the lower the link the more grip that end of the car will have, so yes your car will be loose with a low front camber link and a high rear one.

    Run 2mm ackerman and try a stiffer spring like ride red front/rear.
    Yes i have 0.5mm on the c-hub and 3mm on my rear upright. I did tried to run 4mm spacer on the front and 3mm on the rear upper inner link. the car is very loose once i off throttle and turn, the car will be loose.

    So which means if i need to tackle this problem, firstly, i will change my front upper inner link back to 4mm, then lower my rear inner liner spacer to 2.5mm instead? if car still loose, then try to down ackerman to 2mm and try again

    noted on the spring and will try out siffer springs.

    Will report back.. Thank you CraigM!!!!
  • Quote: Running Tamiya 400 in my shocks and with your camber link setup i tend to understeer then and the rear is planted like a concreed brick
    Check if the tires are glued perfectly all around.
    This could also cause that problem.
    Had it before with LRP tires but since i am running Sorex and Ride, no problems at all.

    regards Roy
    Ps 350WT is almost 400 Tamiya(bit higher)


    hmmm, checked the tires, all are prefectly glued. Running on ride tires
    running on the same set up but your rear is planted and mine is loose... ???????

    i have another 417, it's box set up and the drive is awesome.. just did some minor changes and the rear is planted...
  • If both cars running box setup(like you said a few post back) and one is planted and the other is loose, then you need to check the car out inch by inch as there is something wrong with it.
    Run them both in the same setup(the best you got) and compare.
    The 417X should have more grip due to the fact that it has a chassis with more flex.
    If it is the other wat around, take the car apart and check all parts for damage or binding.

    Regards Roy

    Quote: i have another 417, it's box set up and the drive is awesome.. just did some minor changes and the rear is planted...
  • Quote: If both cars running box setup(like you said a few post back) and one is planted and the other is loose, then you need to check the car out inch by inch as there is something wrong with it.
    Run them both in the same setup(the best you got) and compare.
    The 417X should have more grip due to the fact that it has a chassis with more flex.
    If it is the other wat around, take the car apart and check all parts for damage or binding.

    Regards Roy
    Noted and will do that.

    However, if were to compare with the 2 cars, my 417x is running on spool and 417 is running on geardiff with putty. 417x more steering angle. If set up kit to be use 24degree both side 417 is running 21degree.

    However, i will take my 417x apart and check for damage and binding.
  • Quote: The TRF one (42186) is for buggy adjusters.
    The 53858 is for your TC adjusters.
    Excellent tool!
    Ok, got 53858 in my Cart now. Is this the Turnbuckle wrench I need too? http://www.tamiyausa.com/product/ite...oduct-id=42236 Doesn't actually say what size - just aluminium.

    Cheers
  • Yes, 5mm Ball Cup wrench and 4mm Turnbuckle wrench...
  • Sorry, Im sure this has been covered before but is the box stock setup suitable for fairly low traction asphalt?
    Im pretty new to on-road and Ill be running 13.5 boosted and was looking for a starting point where I wouldnt have to go out and buy springs, suspension blocks etc.
    I have a full set of tamiya springs already and plenty of different weight oils from off-road.
  • Quote: Sorry, Im sure this has been covered before but is the box stock setup suitable for fairly low traction asphalt?
    Im pretty new to on-road and Ill be running 13.5 boosted and was looking for a starting point where I wouldnt have to go out and buy springs, suspension blocks etc.
    I have a full set of tamiya springs already and plenty of different weight oils from off-road.
    Kit setup is a good starting point for low grip asphalt, but you are better off with HPI or Ride springs
  • Quote: Sorry, Im sure this has been covered before but is the box stock setup suitable for fairly low traction asphalt?
    Im pretty new to on-road and Ill be running 13.5 boosted and was looking for a starting point where I wouldnt have to go out and buy springs, suspension blocks etc.
    I have a full set of tamiya springs already and plenty of different weight oils from off-road.
    For what car? I haven't driven the new V5 but to answer your question..no, the stock setup is pretty bad for low traction.

    This setup is for the original 417 but works for the 417x as well. It works really good, easy to drive and is very close to what I run. It works almost everywhere on asphalt and carpet with only spring and oil changes necessary. I use the stock toe blocks in the rear as opposed to the ones listed on the setup sheet.

    http://www.petitrc.com/reglages/tami...tion201112.pdf

Similar Threads