R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Thread Tools Search this Thread
Old 05-22-2010, 08:45 AM   #1
Tech Rookie
Join Date: May 2010
Posts: 1
Questions?? GM genius 90 (2010)


looking for a bit of help with my gm 90, i run stock (10.5 and 13.5) and have tried each of the stock standard profiles that come as standard in the speedo with the 11.1 firmware update. the main problem i have is that using modes 6 or 7 the car lasts the 5 minutes fine but is rather slow in terms of straight line speed and laptime regardless of gearing up or down, then when using modes 8 or 9 the car is quicker but regardless of what i do gearing wise it will not run any longer than 3-3 and a half minute (thermal cut off kicks in)

can someone also tell me if the gm 10.5 with the 1600 gauss rotor is timed at 0 as standard or at 30 as has been suggested in various other forums?

sookitaff is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
GM Brushless stuartb Electric On-Road 2933 08-15-2016 12:10 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 03:00 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0