R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Thread Tools Search this Thread
Old 05-20-2010, 11:20 PM   #1
Tech Adept
Join Date: Apr 2008
Posts: 199
Trader Rating: 20 (100%+)
Default VCS2 shock upgrade problem?

I just got a VCS2 upgrade kit for a set of TC3 shocks and the caps aren't threading on? I have another set of the same shocks that I put a VCS2 upgrade kit on about a year ago and they were perfect but these caps go on about 1 turn maybe and then the threads bind. I tired all the caps on all the shocks with the same result but no dice. Anyone else have a similar problem?
pbr allstar is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Team Associated TC4 Kenshin Electric On-Road 14930 10-18-2016 05:57 AM
SmacTrac...St.Louis Indoor Off Road smac Kansas/Missouri Racing 24520 04-01-2015 03:02 PM
SC10 Thread JDCrow Electric Off-Road 12123 05-29-2012 04:40 PM
TC4 Shock help butrflynlambie Electric On-Road 14 08-01-2006 11:48 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 03:21 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0