R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 05-28-2011, 06:28 PM   #1801
Tech Lord
 
protc3's Avatar
 
Join Date: Jun 2003
Location: Spring Hill,Florida
Posts: 10,829
Trader Rating: 13 (100%+)
Default

Free shipping is inside the US only
__________________
Jason Breiner
BMI Racing
Team Associated
J Concepts
protc3 is offline   Reply With Quote
Old 05-28-2011, 06:29 PM   #1802
Tech Lord
 
protc3's Avatar
 
Join Date: Jun 2003
Location: Spring Hill,Florida
Posts: 10,829
Trader Rating: 13 (100%+)
Default

Quote:
Originally Posted by Ray k View Post
Does this part ( DB1030R )top pod plate, fit both the BD12RR and the Copperhead ?
That part is the same on both cars.
__________________
Jason Breiner
BMI Racing
Team Associated
J Concepts
protc3 is offline   Reply With Quote
Old 05-31-2011, 01:19 AM   #1803
Tech Champion
 
Join Date: Nov 2001
Location: Hawaii, USA
Posts: 7,176
Default

I think I came up with a good way to keep the ride height screws on the NFE from losing their setting. I tried Loctite and CA glue and both slipped on me. I don't have another race day until Sunday 6/12 so I won't be able to report if it worked until after then. But until then here's a pic.



I tried the black Tamiya o-rings but they just wouldn't stretch enough. The clear Tamiya o-rings seem to stretch enough. Now just to see if the settings hold
InspGadgt is offline   Reply With Quote
Old 06-01-2011, 09:05 AM   #1804
Tech Elite
 
Ray k's Avatar
 
Join Date: Feb 2007
Posts: 2,983
Trader Rating: 46 (98%+)
Default

Quote:
Originally Posted by protc3 View Post
That part is the same on both cars.
Awesome it appears to be instock and I need one! Doesn't make sense to order a $10 part and pay $10 to ship it! I thought I would stock up on tires to take advantage of the free shipping .

Looks like you only have one front tire ,Double Pink and it is out of stock! When will they be back instock ? You don't stock any other front compounds?
Ray k is offline   Reply With Quote
Old 06-01-2011, 09:08 AM   #1805
Tech Lord
 
20 SMOKE's Avatar
 
Join Date: Dec 2003
Location: HVR_ WEEKI WACHEE FL
Posts: 10,276
Trader Rating: 101 (100%+)
Default

yes they have other compounds,the site may not have been updated if you can call so karen can see what is in stock
__________________
Jamie W
*Team Tekin*TLR Racing*DE Racing*92 Zero Design*AKA*DDHRC*
20 SMOKE is offline   Reply With Quote
Old 06-01-2011, 09:20 AM   #1806
Tech Elite
 
Ray k's Avatar
 
Join Date: Feb 2007
Posts: 2,983
Trader Rating: 46 (98%+)
Default

Thanks !
Ray k is offline   Reply With Quote
Old 06-01-2011, 02:12 PM   #1807
Tech Lord
 
protc3's Avatar
 
Join Date: Jun 2003
Location: Spring Hill,Florida
Posts: 10,829
Trader Rating: 13 (100%+)
Default

Quote:
Originally Posted by Ray k View Post
Awesome it appears to be instock and I need one! Doesn't make sense to order a $10 part and pay $10 to ship it! I thought I would stock up on tires to take advantage of the free shipping .

Looks like you only have one front tire ,Double Pink and it is out of stock! When will they be back instock ? You don't stock any other front compounds?
Sorry about that. We do have tires in stock. I will update that 1st thing in the morning as i am getting ready to leave shortly.
__________________
Jason Breiner
BMI Racing
Team Associated
J Concepts
protc3 is offline   Reply With Quote
Old 06-06-2011, 06:18 AM   #1808
Tech Lord
 
20 SMOKE's Avatar
 
Join Date: Dec 2003
Location: HVR_ WEEKI WACHEE FL
Posts: 10,276
Trader Rating: 101 (100%+)
Default

letting my CH12 go
__________________
Jamie W
*Team Tekin*TLR Racing*DE Racing*92 Zero Design*AKA*DDHRC*
20 SMOKE is offline   Reply With Quote
Old 06-13-2011, 12:14 AM   #1809
Tech Regular
 
IIICJACKIII's Avatar
 
Join Date: Jan 2009
Posts: 288
Trader Rating: 8 (100%+)
Default

Got a question for you guys, I noticed that one side of the pod sits lower then the chassis and the other side is higher. The pod has a slight tweak, is there a way to fix that? A lot of the other cars can just adjust the side springs but with the flex plates would I have to shim it? I am having a problem with the back of my car wanting to loop out on me. It dose it more one way then the other, that's why I was thinking the pod being tweaked might have something to do with it.
__________________
Team Psycho Cells
IIICJACKIII is offline   Reply With Quote
Old 06-13-2011, 12:24 AM   #1810
Tech Master
 
HarryLeach's Avatar
 
Join Date: Feb 2009
Location: Hampton, VA, USA
Posts: 1,596
Send a message via AIM to HarryLeach
Default

I've had that happen.

Loosen the cross brace and the upper pod plate, square everything up and then carefully re-tighten.

Also need to check the ride height adjusters and bearings for any damage, and sometimes I've had a tweak indication due to a slightly cracked body/damper tube mounting plate.

Between those things, I've always been able to get the car back square without shimming the flex plates.
__________________
Privateer racing lots of stuff.
Remember kids, racing isn't fair!
HarryLeach is offline   Reply With Quote
Old 06-13-2011, 12:36 AM   #1811
Tech Regular
 
IIICJACKIII's Avatar
 
Join Date: Jan 2009
Posts: 288
Trader Rating: 8 (100%+)
Default

Thank you, I will give that a try.
__________________
Team Psycho Cells
IIICJACKIII is offline   Reply With Quote
Old 06-14-2011, 09:06 PM   #1812
Tech Regular
 
IIICJACKIII's Avatar
 
Join Date: Jan 2009
Posts: 288
Trader Rating: 8 (100%+)
Default

The cross brace on my car is off( broke it) but I did find that when I loosened up the upper pod plate that it fixed the tweak. I finally found a order to tighten down the screws so it didn't come back.
Thakns for the help.
__________________
Team Psycho Cells
IIICJACKIII is offline   Reply With Quote
Old 06-14-2011, 11:56 PM   #1813
Tech Master
 
LonnyJ1950's Avatar
 
Join Date: Aug 2009
Location: Tucson, AZ. USA
Posts: 1,161
Default

OK, a few pages back, I complained about the design of the pivots on the CH 12 and got mildly flamed for it. I still would prefer a design that allowed me to adjust the tension and free play. But, I raced the car for the first time on Sunday and was very pleased. It was quick with a basic set up and responded nicely to some adjustments. Missed TQ by 0.2 seconds and was leading the main when I got hammered back to second at the finish. Now all I need is to figure out why I have no speed on the straight. Got run over 3 times at the end of the back chute. Felt like I had the fastest car in the infield.
__________________
Lonny
LonnyJ1950 is offline   Reply With Quote
Old 06-15-2011, 02:36 AM   #1814
Tech Champion
 
Join Date: Nov 2001
Location: Hawaii, USA
Posts: 7,176
Default

Grats man...get your power issue sorted out and they'll be chasin ya instead of running you over
InspGadgt is offline   Reply With Quote
Old 06-15-2011, 07:06 AM   #1815
Tech Lord
 
20 SMOKE's Avatar
 
Join Date: Dec 2003
Location: HVR_ WEEKI WACHEE FL
Posts: 10,276
Trader Rating: 101 (100%+)
Default

i have the NFE if anyone is interested (cheap)i sold my car
__________________
Jamie W
*Team Tekin*TLR Racing*DE Racing*92 Zero Design*AKA*DDHRC*
20 SMOKE is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 02:00 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net