R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Thread Tools Search this Thread
Old 04-03-2004, 11:58 PM   #1
Tech Rookie
Join Date: Jan 2004
Location: Oahu, Hawaii
Posts: 9
Default GT7 ESC question

I finished setting up my car today and I turned it on when my Novak GT7 started to smoke. I was able to disconnected in time, I think but im left scraching my head as to why it went up in smoke...

Im running a XXX-S G+ and the ESC is sitting behind the motor. The wires are all connected using deans connectors that I put on a long time ago and I have never had a problem with... The one thing I did notice is that the circuit board on the GT7 was touching the graphite chassis. Could this cause my ESC to smoke like that?
Thanks for any info you can give me...
Nthegame is offline   Reply With Quote
Old 04-04-2004, 12:28 AM   #2
Tech Master
Speedie's Avatar
Join Date: Feb 2003
Location: Wisconsin
Posts: 1,844

it can short out through the chassis as the battery leads are right there. Check it over real well inside and out and look for burnt or discolored components before trying to use it again. the only good thing I got to say is that Novak has the best customer service in the industry. Good luck.
www.victoryhobbies.com Greenbay, Wisconsin
Speedie is offline   Reply With Quote
Old 04-04-2004, 12:36 AM   #3
Tech Rookie
Join Date: Jan 2004
Location: Oahu, Hawaii
Posts: 9

Thanks.. It seems to be working okay but its late here and I want to see how it does under load. I will be keeping a much better eye on what my speedo touches from now on!
Nthegame is offline   Reply With Quote
Old 04-04-2004, 01:41 AM   #4
Tech Elite
Join Date: Sep 2001
Location: Norman AR.
Posts: 1,954
Send a message via AIM to ZER01

Ntheame, if it smoked it's GONE! no questions asked period!
ZER01 is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
engine question and radio question alucard13 Nitro On-Road 12 09-12-2008 08:21 AM
Bolink TF drag car question and BL question parnelli97 Electric On-Road 2 08-20-2007 05:32 AM
This is gonna sound stupid question but I have a battery Question. Smoke21 Electric On-Road 7 04-25-2004 08:10 PM
indi charger question/3300mhz battery question TT_Vert Electric Off-Road 4 12-27-2003 11:46 AM
Nitro engine question - newbie question. BloodClod Singapore R/C Racers 6 09-11-2002 09:33 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 11:47 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0