R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Thread Tools Search this Thread
Old 04-21-2009, 10:01 AM   #1
Tech Elite
niznai's Avatar
Join Date: Feb 2009
Location: All over the place
Posts: 2,678
Default Lipo battery problems?

I have noticed recently that one of my two Orion 3800mA 30C batteries charges above what the equaliser thinks it's normal. The charger is a Supernova competition, the equaliser is a Trakpower (has a led bar that displays charge level and a number of other leds that flash when the pack is balanced). I bought the batteries about three-four months ago and they shared the duties for two heats and two finals every week with top-up between use on the night and charging the night before the club day.

On the track, the battery charging higher seems to deliver better current.

Any thoughts? Anyone with similar experience?
Team Greasy Weasel

The best upgrade to any car is some driver skill.
niznai is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ask Steve "The Evicerator" Weiss TeamButter Electric On-Road 7088 07-16-2011 05:01 PM
Another begginer/returning question mark in wi Electric Off-Road 21 08-12-2009 07:51 PM
xtm mammoth sale or trade hpipro321 R/C Items: For Sale/Trade 16 01-21-2005 11:46 AM
Mini T steering hop ups/ servo ideas clayrace24 Electric Off-Road 13 03-25-2004 02:34 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 08:54 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0