R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 04-02-2004, 08:50 AM   #8191
Tech Champion
 
rayhuang's Avatar
 
Join Date: Dec 2001
Location: Cleveland Heights, Ohio
Posts: 6,511
Trader Rating: 5 (100%+)
Send a message via AIM to rayhuang
Default

dizzy-yup!!! e-mail Jason at: probrein@cs.com or all him (better) at 352-544-0463
rayhuang is offline   Reply With Quote
Old 04-02-2004, 08:51 AM   #8192
Tech Elite
 
Join Date: Nov 2002
Location: Pasadena, CA
Posts: 2,504
Trader Rating: 5 (100%+)
Default

Quote:
Originally posted by mikejr718
I just purchased an integy sutup station and in attempting to setup my tc3 found that the rear toe is always almost 2 degrees more on the left than on the right. I tried changing the rear arm mounts( r,r+3+2) and found it had no effect. I was wondering if this is designed into the car or if I have further problems.
I had a similar that came up after I destroyed the R block in a wreck and replaced it with a spare I had in my parts box. After that, I had more rear toe on the left than the right. I bought a new R block and the problem went away
DOTMAN is offline   Reply With Quote
Old 04-02-2004, 09:46 PM   #8193
Tech Addict
 
wolfeman09's Avatar
 
Join Date: Aug 2001
Location: Big Dance, USA
Posts: 445
Send a message via AIM to wolfeman09 Send a message via Yahoo to wolfeman09
Default

Anyone have a place to get a full kit for Ceramic Bearings for the TC3?

Thanks...
wolfeman09 is offline   Reply With Quote
Old 04-02-2004, 10:12 PM   #8194
Tech Master
 
Speedie's Avatar
 
Join Date: Feb 2003
Location: Wisconsin
Posts: 1,844
Default

dizzy-yup ask for the BMI bumper brace made with 3mm carbon fiber. You'll thank yourself.
__________________
www.victoryhobbies.com Greenbay, Wisconsin
Speedie is offline   Reply With Quote
Old 04-02-2004, 10:56 PM   #8195
Tech Addict
 
Join Date: Apr 2002
Location: Nebraska USA
Posts: 614
Default ? JohnBull.

Is that a pic of the new TC3 chassis you posted? I also saw what appeared to be a new motor mount cam? If not who makes it. I like the motor mount.
Nightbreed is offline   Reply With Quote
Old 04-02-2004, 11:25 PM   #8196
Tech Adept
 
Java1970's Avatar
 
Join Date: Mar 2004
Location: VERY Northern California
Posts: 164
Default Speaking of TC3 chassis

If it's the Hardcore Racing chassis for the electric TC3, DON'T BUY IT!!! I picked one up and it claimed to be able to easily replace the stock chassis. Bull****!!! The four chassis bracers did not match up properly and, as a result, there was such a binding that I lost speed even going from a stock to a modified motor. When I asked the company about it, they suggested using THEIR bracers (more money) irregardless of the claims of easy replacement. Look at the team guys who are racing at the top level, all their cars are box-stock, or very close to it. Spend the money elsewhere, batteries, ESC, tires, ANYTHING but the Hardcore Racing chassis!!
(*pant* pant* pant*)

My ranting is done, time for my meds again.
Java1970 is offline   Reply With Quote
Old 04-03-2004, 03:23 AM   #8197
J-P
Tech Regular
 
J-P's Avatar
 
Join Date: Mar 2004
Location: London U.K.
Posts: 291
Default

hey wolfeman09,


try www.acerracing.com i just checked it out and also ordered some, expensive but from what ive heard and read they will be worth it!!!!

hope this helps


J-P
J-P is offline   Reply With Quote
Old 04-03-2004, 09:33 AM   #8198
Regional Moderator
 
Join Date: Oct 2001
Location: Memphis, TN
Posts: 1,329
Send a message via AIM to Mike F
Default Drfting question

I search this site for the answer but I couldn't find it. I know it was posted once befoer but I can't recall by who.

My question is this.
Down the str8t, the car will drift to the side and once I recenter it, it drifts again.

Here's my set up and equipment

Front
Rear shock tower up front, middle hole on shock tower, lower outter hole on A arm, 40 weight, silver srings. Camber link upper inner hole. 1.5 degree of camber. Locked diff
no toe in

Rear
Middle hole on shock tower, lower outter hole on A arm, 40 weight, blue spring. Camber link upper inner hole. 1.5 degree of camber. Short wheel base.
2 degree toe in

Tires- take off's 27
Servo - Hitec digital
Esc gt7
monster stock motor

I've used the RPM ball cups throughout the car with the exception of the lower steering links, they have the original ass. ball cups.

any assistance would be greatly appreciated. I'm leaning towards the lower ball cups on the steering links or more camber up front
Mike F is offline   Reply With Quote
Old 04-03-2004, 09:47 AM   #8199
Tech Fanatic
 
etzkev's Avatar
 
Join Date: Jan 2004
Location: Northville, MI
Posts: 790
Send a message via AIM to etzkev
Default

One word - TWEAK!

Have that checked and set, and your problem will be fixed!
etzkev is offline   Reply With Quote
Old 04-03-2004, 09:48 AM   #8200
Regional Moderator
 
Join Date: Oct 2001
Location: Memphis, TN
Posts: 1,329
Send a message via AIM to Mike F
Default

I thought that too but the chassis isnt tweaked
Mike F is offline   Reply With Quote
Old 04-03-2004, 09:50 AM   #8201
Tech Fanatic
 
etzkev's Avatar
 
Join Date: Jan 2004
Location: Northville, MI
Posts: 790
Send a message via AIM to etzkev
Default

How do you know? Have you recently put it on a tweak board?
etzkev is offline   Reply With Quote
Old 04-03-2004, 09:50 AM   #8202
Tech Elite
 
Join Date: Nov 2003
Posts: 2,828
Send a message via AIM to True R/C Racing
Default

check droop, And Shocks. Make sure they are Working propertly. I once had that, My left shock on rear the Eclip inside the shock to hold the piston fell out. Hope this helps
True R/C Racing is offline   Reply With Quote
Old 04-03-2004, 09:53 AM   #8203
Tech Master
 
koabich's Avatar
 
Join Date: Oct 2003
Location: Detroit Area
Posts: 1,360
Send a message via Yahoo to koabich
Default Re: Drfting question

Quote:
Originally posted by Mike F
I search this site for the answer but I couldn't find it. I know it was posted once befoer but I can't recall by who.

My question is this.
Down the str8t, the car will drift to the side and once I recenter it, it drifts again.

Here's my set up and equipment

Front
Rear shock tower up front, middle hole on shock tower, lower outter hole on A arm, 40 weight, silver srings. Camber link upper inner hole. 1.5 degree of camber. Locked diff
no toe in

Rear
Middle hole on shock tower, lower outter hole on A arm, 40 weight, blue spring. Camber link upper inner hole. 1.5 degree of camber. Short wheel base.
2 degree toe in

Tires- take off's 27
Servo - Hitec digital
Esc gt7
monster stock motor

I've used the RPM ball cups throughout the car with the exception of the lower steering links, they have the original ass. ball cups.

any assistance would be greatly appreciated. I'm leaning towards the lower ball cups on the steering links or more camber up front
Make sure the screw for the servo saver on the bottom of the steering rack hasn't come loose.
koabich is offline   Reply With Quote
Old 04-03-2004, 09:53 AM   #8204
Regional Moderator
 
Join Date: Oct 2001
Location: Memphis, TN
Posts: 1,329
Send a message via AIM to Mike F
Default

I'll check that out, thanks
Mike F is offline   Reply With Quote
Old 04-03-2004, 10:23 AM   #8205
Tech Regular
 
Join Date: Aug 2003
Location: England
Posts: 257
Default

I've had this problem before, traced it down to a non full self centering servo (centered OK from right, but not from left)
TraceRacing is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
New to the forum mig rod Electric Off-Road 1 01-05-2008 04:23 PM
hi i need help and im new to the forum racer4 Rookie Zone 4 01-21-2007 01:37 PM
Why is this forum listed under the On Road Forum? sport10 Onroad Nitro Engine Zone 0 01-11-2007 07:06 AM
Forum Changes... futureal Wisconsin & Illinois Racing 3 10-28-2002 08:26 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 05:57 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net