R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 07-21-2014, 08:46 AM   #12661
Tech Champion
 
liljohn1064's Avatar
 
Join Date: Sep 2008
Location: Deerfield, WI
Posts: 5,281
Trader Rating: 16 (100%+)
Send a message via AIM to liljohn1064 Send a message via MSN to liljohn1064 Send a message via Yahoo to liljohn1064
Default Pro 1.1 V22

I'm setting up a new Reventon Pro 1.1 for the first time. I had the ESC and motor hooked up to the receiver on a bench just to get the initial setup done. All is running good and they are ready for their new home.

But,

The Reventon Pro 1.1 is not familiar to me at all, so I did some more bench work. I updated to V22. I used the PC interface to put the ESC into stock 1 mode, which unlocked Hybrid Boost. I wasn't able to make the Hybrid settings changes through the PC interface though. I had to do it through the LCD card. I still need a little more understanding on how all the items correspond to other brands. I selected the default 10.5R config and saved it. I did the radio config and ran it with the motor slave to listen for the turbo and it does kick in. I then put the motor on the Extreme MC and it was peaking at about 4.4 Amps at 15* timing, 34000 RPMs or so with no ESC input. I know I can go about double on running current if I choose to, but no need. I put the checker in cycle mode and let it run for 8 minutes and the temps were real good, under 140*. My RPM motor stand was used again for a test jig. The slave was an old Tekin Redline 7.5 and I think it was hotter than the 10.5.

Does this sound right? Car is a 10.5R 235mm Pro10.

So, What are?:

Hybrid Boost Active: a percentage of what? ESC max timing? Which is what?
Hybrid Boost Maximum: XXXK of what? RPMs? I need a little more math here.

The rest makes sense. I'm used to Starting RPM, Ending RPM, ramp rate, Turbo delay from running Tekins. A little more detail would be nice.
__________________
John Higgins
liljohn1064 is offline   Reply With Quote
Old 07-23-2014, 01:54 AM   #12662
Tech Adept
 
Join Date: Aug 2010
Posts: 181
Default

Quote:
Originally Posted by liljohn1064 View Post
I'm setting up a new Reventon Pro 1.1 for the first time. I had the ESC and motor hooked up to the receiver on a bench just to get the initial setup done. All is running good and they are ready for their new home.

But,

The Reventon Pro 1.1 is not familiar to me at all, so I did some more bench work. I updated to V22. I used the PC interface to put the ESC into stock 1 mode, which unlocked Hybrid Boost. I wasn't able to make the Hybrid settings changes through the PC interface though. I had to do it through the LCD card. I still need a little more understanding on how all the items correspond to other brands. I selected the default 10.5R config and saved it. I did the radio config and ran it with the motor slave to listen for the turbo and it does kick in. I then put the motor on the Extreme MC and it was peaking at about 4.4 Amps at 15* timing, 34000 RPMs or so with no ESC input. I know I can go about double on running current if I choose to, but no need. I put the checker in cycle mode and let it run for 8 minutes and the temps were real good, under 140*. My RPM motor stand was used again for a test jig. The slave was an old Tekin Redline 7.5 and I think it was hotter than the 10.5.

Does this sound right? Car is a 10.5R 235mm Pro10.

So, What are?:

Hybrid Boost Active: a percentage of what? ESC max timing? Which is what?
Hybrid Boost Maximum: XXXK of what? RPMs? I need a little more math here.

The rest makes sense. I'm used to Starting RPM, Ending RPM, ramp rate, Turbo delay from running Tekins. A little more detail would be nice.
From what I have found the Reventon Pro seems to add on much more timing than most ESCs. Most seem to add 64 steps of timing, from what I can gather around 28-30 degrees in total.

When running the 13.5 MMM in boosted touring car using the Reventon Pro, I used:

11* on the motor
90% Hybrid Boost Active
150K Hybrid Boost Maximum.

Top speeds were amazing and I was working to improve acceleration which wasn't quite as punchy as others.

When moving to the G-Force TS120 I found I had to add more timing on the motor to get the same top speeds with full timing on the ESC.

When going back to the Reventon with the motor on 20* and the same timing settings as before it seemed to cut out and go into sensor less mode. I assume from too much timing.

From this I can only assume the Reventon Pro can add far more than 30* in total. Maybe 30* for Hybrid Boost active and 10* for Hybrid Boost Max??

I have asked SP for figures but it seems to be a closely guarded secret They did offer very helpful advice on how I can improve acceleration however by reducing start RPM to 3000, increasing DRRS, reducing the Turbo delay and increasing the turbo slope rate.

I also wondered about the end RPM as this is not set anywhere? I assume it must be a set range depending on start RPM?

All this is just my findings with the Reventon but it may help?
dvaid852456 is offline   Reply With Quote
Old 07-23-2014, 09:12 AM   #12663
Tech Champion
 
liljohn1064's Avatar
 
Join Date: Sep 2008
Location: Deerfield, WI
Posts: 5,281
Trader Rating: 16 (100%+)
Send a message via AIM to liljohn1064 Send a message via MSN to liljohn1064 Send a message via Yahoo to liljohn1064
Default

Quote:
Originally Posted by dvaid852456 View Post
From what I have found the Reventon Pro seems to add on much more timing than most ESCs. Most seem to add 64 steps of timing, from what I can gather around 28-30 degrees in total.

When running the 13.5 MMM in boosted touring car using the Reventon Pro, I used:

11* on the motor
90% Hybrid Boost Active
150K Hybrid Boost Maximum.

Top speeds were amazing and I was working to improve acceleration which wasn't quite as punchy as others.

When moving to the G-Force TS120 I found I had to add more timing on the motor to get the same top speeds with full timing on the ESC.

When going back to the Reventon with the motor on 20* and the same timing settings as before it seemed to cut out and go into sensor less mode. I assume from too much timing.

From this I can only assume the Reventon Pro can add far more than 30* in total. Maybe 30* for Hybrid Boost active and 10* for Hybrid Boost Max??

I have asked SP for figures but it seems to be a closely guarded secret They did offer very helpful advice on how I can improve acceleration however by reducing start RPM to 3000, increasing DRRS, reducing the Turbo delay and increasing the turbo slope rate.

I also wondered about the end RPM as this is not set anywhere? I assume it must be a set range depending on start RPM?

All this is just my findings with the Reventon but it may help?
Sounds good to me. I have the red board in and motor timing at 15* for now. The car is light, so I'll have to fiddle with the start RPM and ramp rate to keep the rear tires from spinning. The rest all makes sense, but I'd sure like to understand those numbers mathematically, even if they were ballpark.
__________________
John Higgins
liljohn1064 is offline   Reply With Quote
Old 07-23-2014, 05:47 PM   #12664
Rax
Tech Adept
 
Rax's Avatar
 
Join Date: Jul 2010
Location: perth
Posts: 177
Trader Rating: 1 (100%+)
Default

z
__________________
Ausrab Industries
Xray T4 14 (the racing car)
Team C GR8LE (the fun car)
Rax is offline   Reply With Quote
Old 07-26-2014, 05:21 PM   #12665
Tech Regular
 
guinnes.s's Avatar
 
Join Date: Dec 2006
Posts: 341
Default

is a long shot but....
a old Speed Passion Cirtix Stock club race esc ....im not able to calibrate with the tx ,red light keeps blinking ,holding the small setup button on the switch does not start the calibration setup.
any ideas before i bin it?
thanx
guinnes.s is offline   Reply With Quote
Old 07-26-2014, 05:42 PM   #12666
Tech Elite
 
jlfx car audio's Avatar
 
Join Date: Nov 2007
Location: jackson,tn
Posts: 3,154
Trader Rating: 35 (100%+)
Default

Whats everyone running the revention pro in spec 17.5 punch wise .
in the bench i can tell it hits harder from a stop on #9 but...
jlfx car audio is offline   Reply With Quote
Old 07-26-2014, 07:28 PM   #12667
Tech Master
 
cwoods34's Avatar
 
Join Date: May 2008
Location: Indy-freakin'-ana
Posts: 1,152
Trader Rating: 9 (100%+)
Default

Quote:
Originally Posted by jlfx car audio View Post
Whats everyone running the revention pro in spec 17.5 punch wise .
in the bench i can tell it hits harder from a stop on #9 but...
I usually keep it at 7. Assuming you run good batteries, this seems to be the best spot for good punch without the car being hard to drive or causing heat issues
cwoods34 is offline   Reply With Quote
Old 08-04-2014, 02:42 PM   #12668
Tech Apprentice
 
coretex's Avatar
 
Join Date: Nov 2012
Location: Norway
Posts: 61
Default

My fan broke a long time ago. Now I've "upgraded" to a 6.5T motor, and suddenly the ESC seem to overheat a lot and I guess I need a fan. Can I just buy any fan out there, or does it need to be a Speed Passion fan? Oh, I have the Reventon R

UPDATE: I bought a new one. A standard 25x25mm fan. It worked fine, BUT the cheap fan did not vent enough. In the end I broke the ESC by overheating it.

Last edited by coretex; 09-05-2014 at 12:43 PM.
coretex is offline   Reply With Quote
Old 08-11-2014, 09:34 PM   #12669
Tech Addict
 
Join Date: Mar 2007
Location: colorado springs, co
Posts: 507
Trader Rating: 13 (100%+)
Default

Hello,
I have a reventon pro 1.1 EX in my 1/12 car. I have just put in a new receiver and resynced with the radio. I am using Stock0 programming and verified with my programming box that it is in use. I reset the esc to my radio throttle end points. when I turn it on and the radio, everything works fine. I got steering and seem to have full control of the throttle. The battery cutoff is disabled.
When I turn it on, I get blink-blink-pause and this repeats. It may be possible that my battery is not fully charged. Is this what it does for a non-fully charged battery when the esc is in blinky mode? Or does this code mean something else?

thanks,
tim
__________________
Colorado On-Road RC Club
www.5280raceway.com
www.facebook.com/CORtrack
Driving: Xray T4 2015, T.O.P. Rebel 12, Durango DEX8T, Durango DEX408 v2, Associated B5M, Associated B44.2

Last edited by rc_speed; 08-13-2014 at 12:47 PM.
rc_speed is offline   Reply With Quote
Old 08-13-2014, 12:47 PM   #12670
Tech Addict
 
Join Date: Mar 2007
Location: colorado springs, co
Posts: 507
Trader Rating: 13 (100%+)
Default

is this thread still in use?
__________________
Colorado On-Road RC Club
www.5280raceway.com
www.facebook.com/CORtrack
Driving: Xray T4 2015, T.O.P. Rebel 12, Durango DEX8T, Durango DEX408 v2, Associated B5M, Associated B44.2
rc_speed is offline   Reply With Quote
Old 08-14-2014, 12:12 AM   #12671
Tech Master
 
LonnyJ1950's Avatar
 
Join Date: Aug 2009
Location: Tucson, AZ. USA
Posts: 1,141
Default

Yes, but don't hold your breathe.
__________________
Lonny
LonnyJ1950 is offline   Reply With Quote
Old 08-14-2014, 02:25 AM   #12672
Tech Adept
 
Join Date: Aug 2010
Posts: 181
Default

Quote:
Originally Posted by rc_speed View Post
Hello,
I have a reventon pro 1.1 EX in my 1/12 car. I have just put in a new receiver and resynced with the radio. I am using Stock0 programming and verified with my programming box that it is in use. I reset the esc to my radio throttle end points. when I turn it on and the radio, everything works fine. I got steering and seem to have full control of the throttle. The battery cutoff is disabled.
When I turn it on, I get blink-blink-pause and this repeats. It may be possible that my battery is not fully charged. Is this what it does for a non-fully charged battery when the esc is in blinky mode? Or does this code mean something else?

thanks,
tim
According to the manual these are the various LED status indicators:

Sensored
Low battery voltage Red LED Blinking
Over-heating of ESC and motor (95℃) Orange LED Blinking
Sensored motor Red and Orange LED ON
Sensorless motor Orange LED ON
Sensorless ESC’s Indicating LED

Sensorless
Low battery voltage Red LED Blinking
Over-heating of ESC and
motor (95℃) Orange LED Blinking
Sensored / Sensorless motor Orange LED ON

What colour LED is blinking? Do you have the sensor cable attached?

Last edited by dvaid852456; 08-14-2014 at 02:39 AM.
dvaid852456 is offline   Reply With Quote
Old 08-14-2014, 01:56 PM   #12673
Tech Addict
 
Join Date: Mar 2007
Location: colorado springs, co
Posts: 507
Trader Rating: 13 (100%+)
Default

sensor wire attached. It is the red led that is going blink-blink-pause-repeat.
The low voltage is a single blink. However, I am running in blinky mode, so the single blink is also blinky mode.
no other led are on.
__________________
Colorado On-Road RC Club
www.5280raceway.com
www.facebook.com/CORtrack
Driving: Xray T4 2015, T.O.P. Rebel 12, Durango DEX8T, Durango DEX408 v2, Associated B5M, Associated B44.2
rc_speed is offline   Reply With Quote
Old 08-15-2014, 04:06 AM   #12674
Tech Adept
 
Join Date: Aug 2010
Posts: 181
Default

Quote:
Originally Posted by rc_speed View Post
sensor wire attached. It is the red led that is going blink-blink-pause-repeat.
The low voltage is a single blink. However, I am running in blinky mode, so the single blink is also blinky mode.
no other led are on.
Hmmm, not sure then. Sorry.

Hopefully someone else that runs blinky in 12th can help.

I mainly run Boosted 13.5 TC.
dvaid852456 is offline   Reply With Quote
Old 08-30-2014, 03:18 PM   #12675
Tech Regular
 
Join Date: Dec 2012
Location: Belleville Il.
Posts: 365
Trader Rating: 9 (100%+)
Default

So I hardly see anyone running speed passion stuff in off road...are the motors just not worth anything? Can they not handle the load or have enough power to clear jumps? I'm wanting to do a budget build series and am wanting to put a reventon r esc and a v3 7.5 motor in a 2wd buggy.
thercpr0 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speed Passion GT Competition Brushless ESC v2.0 Low Profile, LPF pink_sleeve Electric On-Road 13 07-08-2009 10:17 AM


Tags
gt2, lack of help, overpriced, poor customer service, reventon, reventon pro, speed passion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 12:58 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0