R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 04-06-2014, 03:06 PM   #12526
Tech Regular
 
prosport's Avatar
 
Join Date: Dec 2013
Location: Akron Ohio
Posts: 309
Trader Rating: 21 (100%+)
Default

Thanks for the answers guys.
prosport is offline   Reply With Quote
Old 04-07-2014, 05:09 PM   #12527
Tech Elite
 
hotrodchevy14's Avatar
 
Join Date: Dec 2009
Posts: 2,333
Trader Rating: 106 (100%+)
Default

Quote:
Originally Posted by dan_vector View Post
I have 2 of them. Never had a problem with either. Brilliant little esc.
How do you go about changing the drag brake setting? Do you need a program box? Referring to the reventon stock spec race esc.
__________________
...oh our lady of blessed acceleration, don't fail me now..
sponsored by:Team lint in my pockets racing...
hotrodchevy14 is offline   Reply With Quote
Old 04-07-2014, 08:00 PM   #12528
Tech Champion
 
Join Date: Nov 2002
Location: Chicago, IL
Posts: 7,473
Trader Rating: 34 (100%+)
Default

Quote:
Originally Posted by hotrodchevy14 View Post
How do you go about changing the drag brake setting? Do you need a program box? Referring to the reventon stock spec race esc.
The easiest way is to use a programming card. If you don't own one download the instructions...

http://www.speedpassion.net/uploadfi...ov28th2013.pdf

Step 11 explains programming by looking at the LEDs blinking.
__________________
Speed Passion * Fantom Racing * Windy City Raceway
Nexus is offline   Reply With Quote
Old 04-08-2014, 08:31 AM   #12529
Tech Elite
 
hotrodchevy14's Avatar
 
Join Date: Dec 2009
Posts: 2,333
Trader Rating: 106 (100%+)
Default

Quote:
Originally Posted by Nexus View Post
The easiest way is to use a programming card. If you don't own one download the instructions...

http://www.speedpassion.net/uploadfi...ov28th2013.pdf

Step 11 explains programming by looking at the LEDs blinking.
So the setting for drag brake is when the orange light blinks 6 times?
__________________
...oh our lady of blessed acceleration, don't fail me now..
sponsored by:Team lint in my pockets racing...
hotrodchevy14 is offline   Reply With Quote
Old 04-08-2014, 03:39 PM   #12530
Tech Adept
 
Join Date: Apr 2014
Posts: 126
Trader Rating: 2 (100%+)
Default

Im new to this but curious I need a combo.I am looking at the sp stock club 10.5, castle sw sct, viper vx4, or th old stanby hw and tacon. Just need some honest opinions. This will be going on a sc10 2wd.
gdudley is offline   Reply With Quote
Old 04-11-2014, 08:21 AM   #12531
Tech Regular
 
prosport's Avatar
 
Join Date: Dec 2013
Location: Akron Ohio
Posts: 309
Trader Rating: 21 (100%+)
Default

Quote:
Originally Posted by gdudley View Post
Im new to this but curious I need a combo.I am looking at the sp stock club 10.5, castle sw sct, viper vx4, or th old stanby hw and tacon. Just need some honest opinions. This will be going on a sc10 2wd.

Just so you know, the SP stock club race does not have reverse. I don't know about the others.
prosport is offline   Reply With Quote
Old 04-11-2014, 08:25 AM   #12532
Tech Regular
 
prosport's Avatar
 
Join Date: Dec 2013
Location: Akron Ohio
Posts: 309
Trader Rating: 21 (100%+)
Default

I have a Reventon-R with a SP 10.5R MMM motor.
The motor has the red plus-10 sensor board, the esc is set at 18.75 timing.
Is this a safe setup?

It's a 2 cell lipo, 1/10 off road dirt course.
prosport is offline   Reply With Quote
Old 04-11-2014, 11:40 AM   #12533
Tech Champion
 
Join Date: Nov 2002
Location: Chicago, IL
Posts: 7,473
Trader Rating: 34 (100%+)
Default

Quote:
Originally Posted by prosport View Post
I have a Reventon-R with a SP 10.5R MMM motor.
The motor has the red plus-10 sensor board, the esc is set at 18.75 timing.
Is this a safe setup?

It's a 2 cell lipo, 1/10 off road dirt course.
Timing sounds fine. Just make sure your gearing ideal for the track.
__________________
Speed Passion * Fantom Racing * Windy City Raceway
Nexus is offline   Reply With Quote
Old 04-11-2014, 12:08 PM   #12534
Tech Master
 
Join Date: Jul 2006
Location: La Mirada, CA
Posts: 1,014
Trader Rating: 31 (100%+)
Default

Quote:
Originally Posted by black blood View Post
Ok ... got sto1 v21 loaded this morning. Im getting "like" low voltage cut out after 4-5mins of use.. i have even disabled 3.4v low volt cut..no difference.. disabled over heat .... no difference.. my battery volt is 7.4volt (peak over 8.1v) and system voltage runs around 5.8v-6.2v .. im unsure what the issue is.. i run 5300mah 50-100c burst.. any idea guys...

Just a thought... im not running a capacitor that i got with the combo..should i? im not getting any interferance


Ray
Same exact thing happened to me and I always run the capacitor. I tried disabling low voltage and temp cutoff and it didn't help. After failing to complete 2 qualifiers and 2 mains on separate days, I just sent the speedo back to Speedpassion. Still waiting on it now. If it does the same thing after I get it back, I'm dumping this stuff and moving on.

- Jose
ittjv is offline   Reply With Quote
Old 04-11-2014, 04:28 PM   #12535
Tech Regular
 
prosport's Avatar
 
Join Date: Dec 2013
Location: Akron Ohio
Posts: 309
Trader Rating: 21 (100%+)
Default

Quote:
Originally Posted by Nexus View Post
Timing sounds fine. Just make sure your gearing ideal for the track.
Ok thanks! Motor runs cool, could use a little more gearing. I just didn't know how far I can safely go with timing.
prosport is offline   Reply With Quote
Old 04-12-2014, 02:38 AM   #12536
Tech Rookie
 
Join Date: Dec 2013
Posts: 17
Default

Hello,

I burned my Reventon R ESC wich is 3 month old. Maybe it was to much timing on the 13.5t v3-mmm motor? After 6 minutes running the motor stopped and it came smoke out of my Xray T4 :/ I run this combo on 2s 6000mAh turnigy lipo. The motor is «stocky» too now (it is difficult to turn the shaft). Anyway, I need help to find out of this and to get the right part to fix the problem.

Can You tell me what kind part it is on the ESC wich is shown in the pictures, and where can I get one, to solder it by myself..?

Thanks!





Last edited by Bigmic; 04-12-2014 at 07:30 AM.
Bigmic is offline   Reply With Quote
Old 04-12-2014, 11:21 AM   #12537
Tech Fanatic
 
dfiantii's Avatar
 
Join Date: Oct 2007
Location: West Scramento, Ca
Posts: 780
Trader Rating: 16 (100%+)
Send a message via AIM to dfiantii Send a message via Yahoo to dfiantii
Default

That looks like a jumper to me but someone else will chime in. You would probably do better to get a new one rather than fuss with the repair.
__________________
TT-01/Hitec MG/SP LPF V1.1/Trinity 7.5
Losi Type-R/JR Z8800S/SP Cirtix Stock/Novak 25.5
Exotek F1R/Savox 1251/Tekin RS/21.5
"ELECTRIFIED TO THE HILT"
dfiantii is offline   Reply With Quote
Old 04-12-2014, 02:56 PM   #12538
Tech Rookie
 
Join Date: Dec 2013
Posts: 17
Default

Send the same message to SP-service-center. Will se if they can help...
Bigmic is offline   Reply With Quote
Old 04-13-2014, 01:33 PM   #12539
Tech Elite
 
hotrodchevy14's Avatar
 
Join Date: Dec 2009
Posts: 2,333
Trader Rating: 106 (100%+)
Default

Will any of the reventon run a brushed motor?
__________________
...oh our lady of blessed acceleration, don't fail me now..
sponsored by:Team lint in my pockets racing...
hotrodchevy14 is offline   Reply With Quote
Old 04-16-2014, 05:54 AM   #12540
Tech Adept
 
Join Date: Aug 2010
Posts: 181
Default

Quote:
Originally Posted by Bigmic View Post
Hello,

I burned my Reventon R ESC wich is 3 month old. Maybe it was to much timing on the 13.5t v3-mmm motor? After 6 minutes running the motor stopped and it came smoke out of my Xray T4 :/ I run this combo on 2s 6000mAh turnigy lipo. The motor is «stocky» too now (it is difficult to turn the shaft). Anyway, I need help to find out of this and to get the right part to fix the problem.
I repaired a similar fault on a Novak Kinetic. It is most likely a surface mount fuse or possibly diode to prevent short circuit/reverse polarity.

If you search for a data sheet using any numbers on the chip you may find the exact part number and be able to replace it. I doubt SP will tell you, Novak were no help in my case. They just point you to warranty support.
dvaid852456 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speed Passion GT Competition Brushless ESC v2.0 Low Profile, LPF pink_sleeve Electric On-Road 13 07-08-2009 10:17 AM


Tags
gt2, lack of help, overpriced, poor customer service, reventon, reventon pro, speed passion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 12:53 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0