R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 03-29-2014, 08:19 PM   #12511
Tech Regular
 
prosport's Avatar
 
Join Date: Dec 2013
Location: Akron Ohio
Posts: 309
Trader Rating: 21 (100%+)
Default

Quote:
Originally Posted by Shane Parker View Post
Hey, I have a question about adjusting the timing in Speed Passion motors mainly the 21.5 Competition V3. I know to change timing you must buy a different sensor. If I bought the +20˚ green sensor would it be 20˚ moved to the right all the way or is the sensor itself +20˚?

Shane
I have the same question about the 10.5R motor, is the timing adjustable at all? Or do I have to buy a new sensor board? And who sells the sensor board?
prosport is offline   Reply With Quote
Old 03-30-2014, 10:03 AM   #12512
Tech Apprentice
 
Join Date: Jun 2011
Posts: 68
Default

Hello to all,
can someone help me?
Someone has parameters for ESC speedpassion GRANTURISMO PRO 2 for fast tracks? 119 FIRMWARE MOD.
Thks in advance

Pigio
Pigiolino is offline   Reply With Quote
Old 03-31-2014, 09:17 PM   #12513
Tech Apprentice
 
Join Date: Feb 2014
Posts: 67
Default

Hopefully someone can help me out here.

I purchased a Reventon Pro esc and MMM motor. I got it all wired up and everything worked just fine. I Hooked the esc up to a friends Lap top to change to firmware to Stock0 for a race I have coming up and now I lost all throttle and I cant even get the ESC to hook up to the computer? It just says connecting pc. I updated the firmware on the LCD card and no luck. I did not hook it to the computer with the battery plugged in ether. Any ideas?
NickGroves is offline   Reply With Quote
Old 04-01-2014, 02:43 AM   #12514
Tech Regular
 
Join Date: Jan 2014
Posts: 471
Default

I need help understanding the slope rate in stock 1 hybrid boost.
S.TRIPP77 is offline   Reply With Quote
Old 04-01-2014, 04:15 AM   #12515
Tech Master
 
skater-deez1's Avatar
 
Join Date: Sep 2012
Location: Mechanicsburg,Pa
Posts: 1,622
Trader Rating: 53 (100%+)
Exclamation

Quote:
Originally Posted by NickGroves View Post
Hopefully someone can help me out here.

I purchased a Reventon Pro esc and MMM motor. I got it all wired up and everything worked just fine. I Hooked the esc up to a friends Lap top to change to firmware to Stock0 for a race I have coming up and now I lost all throttle and I cant even get the ESC to hook up to the computer? It just says connecting pc. I updated the firmware on the LCD card and no luck. I did not hook it to the computer with the battery plugged in ether. Any ideas?
Had the same problem myself recently after updating the firmware. I played with changing the programming on it to just about every type/adjustment and the recalibrated the throttle positions and eventually got it to start working again. Not sure how exactly but after tinkering with it for awhile it just started working and has been fine since.
__________________
Going nowhere fast since 1973!
skater-deez1 is offline   Reply With Quote
Old 04-01-2014, 07:04 AM   #12516
Tech Apprentice
 
Join Date: Feb 2014
Posts: 67
Default

Quote:
Originally Posted by skater-deez1 View Post
Had the same problem myself recently after updating the firmware. I played with changing the programming on it to just about every type/adjustment and the recalibrated the throttle positions and eventually got it to start working again. Not sure how exactly but after tinkering with it for awhile it just started working and has been fine since.
I forgot to add that I cant get into recalibration mode. If I hold the on button to try and get into recalibration mode it just turns back off. Haha. Maybe I will give speed passion a call today and see what they say.
NickGroves is offline   Reply With Quote
Old 04-01-2014, 07:52 AM   #12517
Tech Regular
 
prosport's Avatar
 
Join Date: Dec 2013
Location: Akron Ohio
Posts: 309
Trader Rating: 21 (100%+)
Default

I have a SP 10.5R motor that runs perfect for about 45 seconds then it cogs and sputters and shuts off. I've tried it in two different 1/10 buggies with the same result, both have SP ReventonR esc's.

I'm in Akron Ohio, where can I send this motor to get checked or rebuilt?

Edit: Nevermind, I'm not gonna send it out.

Last edited by prosport; 04-02-2014 at 06:23 AM.
prosport is offline   Reply With Quote
Old 04-02-2014, 12:24 AM   #12518
Tech Adept
 
RC GB's Avatar
 
Join Date: Dec 2005
Location: Arlington Washington
Posts: 122
Default Speed Passion LCD

Anyone have Speed Passion LCD program box # specpbo1 for sale?
__________________
Gary Bennett
NW Oldest Racer
RC GB is offline   Reply With Quote
Old 04-02-2014, 06:22 AM   #12519
Tech Regular
 
prosport's Avatar
 
Join Date: Dec 2013
Location: Akron Ohio
Posts: 309
Trader Rating: 21 (100%+)
Default

Does Speed Passion sell different labels for the slide-out list on the LED program box?
I'm running Mod-0 on the Reventon-R, would like to have the correct label in there.
Thanks
prosport is offline   Reply With Quote
Old 04-04-2014, 06:15 AM   #12520
Tech Apprentice
 
Join Date: Feb 2014
Posts: 64
Default

Hi Guys. Help please.. i have brought a sp reventon pro combo.. i just cant get it loaded on my computor to reconise the lcd card to update firm wear etc.. let alone the esc.. im running windows 7.. it said missing driver?
black blood is offline   Reply With Quote
Old 04-04-2014, 04:18 PM   #12521
Tech Apprentice
 
Join Date: Feb 2014
Posts: 64
Default

Got it sorted guys.. cheers
black blood is offline   Reply With Quote
Old 04-05-2014, 12:43 PM   #12522
Tech Regular
 
prosport's Avatar
 
Join Date: Dec 2013
Location: Akron Ohio
Posts: 309
Trader Rating: 21 (100%+)
Default

Seems like it's really hard to get answers in this thread. Maybe my questions are just really dumb? I have come up with some answers through searching the thread but some I have not.
prosport is offline   Reply With Quote
Old 04-05-2014, 03:17 PM   #12523
Tech Regular
 
Pittster's Avatar
 
Join Date: Feb 2013
Location: Newcastle NSW
Posts: 365
Trader Rating: 4 (100%+)
Default

Quote:
Originally Posted by prosport View Post
I have the same question about the 10.5R motor, is the timing adjustable at all? Or do I have to buy a new sensor board? And who sells the sensor board?
Timing is a adjustablevia the endbell timing v3.0 motors have a 0-10deg adjustment MMM have 10-20deg boards.

Quote:
Originally Posted by prosport View Post
Does Speed Passion sell different labels for the slide-out list on the LED program box?
I'm running Mod-0 on the Reventon-R, would like to have the correct label in there.
Thanks
I don't know but I kind of doubt it but just Email SP about it.

Quote:
Originally Posted by black blood View Post
Hi Guys. Help please.. i have brought a sp reventon pro combo.. i just cant get it loaded on my computor to reconise the lcd card to update firm wear etc.. let alone the esc.. im running windows 7.. it said missing driver?
Drivers should install with software install, remove it and reinstall as Administrator (right click on the .exe) then follow the firmware update procedure and it will work.

I have done 4 SP Reventons and had no issues so far.

Quote:
Originally Posted by prosport View Post
Seems like it's really hard to get answers in this thread. Maybe my questions are just really dumb? I have come up with some answers through searching the thread but some I have not.
It can get a little quite in here.
__________________
Team Associated B6D, Speed Passion Reventon Pro, Tekin Gen2 8.5
Team Durango DEX410v4, Speed Passion Reventon Pro, Tekin Gen2 7.5
Team Durango DEX210v2, Tekin Rs Gen2, Orion 17.5
Pittster is offline   Reply With Quote
Old 04-06-2014, 12:00 AM   #12524
Tech Apprentice
 
Join Date: Feb 2014
Posts: 64
Default

Ok ... got sto1 v21 loaded this morning. Im getting "like" low voltage cut out after 4-5mins of use.. i have even disabled 3.4v low volt cut..no difference.. disabled over heat .... no difference.. my battery volt is 7.4volt (peak over 8.1v) and system voltage runs around 5.8v-6.2v .. im unsure what the issue is.. i run 5300mah 50-100c burst.. any idea guys...

Just a thought... im not running a capacitor that i got with the combo..should i? im not getting any interferance


Ray

Last edited by black blood; 04-06-2014 at 05:10 AM.
black blood is offline   Reply With Quote
Old 04-06-2014, 11:11 AM   #12525
Tech Champion
 
Join Date: Nov 2002
Location: Chicago, IL
Posts: 7,473
Trader Rating: 34 (100%+)
Default

Quote:
Originally Posted by prosport View Post
Does Speed Passion sell different labels for the slide-out list on the LED program box?
I'm running Mod-0 on the Reventon-R, would like to have the correct label in there.
Thanks
Sorry the labels are not really sold.

Quote:
Originally Posted by black blood View Post
Ok ... got sto1 v21 loaded this morning. Im getting "like" low voltage cut out after 4-5mins of use.. i have even disabled 3.4v low volt cut..no difference.. disabled over heat .... no difference.. my battery volt is 7.4volt (peak over 8.1v) and system voltage runs around 5.8v-6.2v .. im unsure what the issue is.. i run 5300mah 50-100c burst.. any idea guys...

Just a thought... im not running a capacitor that i got with the combo..should i? im not getting any interferance


Ray
Ray always run a cap on the ESC.
__________________
Speed Passion * Fantom Racing * Windy City Raceway
Nexus is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speed Passion GT Competition Brushless ESC v2.0 Low Profile, LPF pink_sleeve Electric On-Road 13 07-08-2009 10:17 AM


Tags
gt2, lack of help, overpriced, poor customer service, reventon, reventon pro, speed passion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 07:05 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0