R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 12-10-2013, 02:53 PM   #12256
Tech Legend
 
Cain's Avatar
 
Join Date: May 2002
Location: West Fargo, North Dakota
Posts: 26,533
Trader Rating: 206 (100%+)
Default

Quote:
Originally Posted by Dog Runner View Post
I have a GT 2.0 ESC and am having trouble stopping the wheels fast enough when I hit the brakes.

What I'm looking to do is to stop the wheels fast enough to flick the car downwards in the air over a jump. Right now, I'm at maximum brake and the wheels slow down in 2-3 tenths of a second, but they don't stop cold like my Reventon or other brands of ESCs would do. Those brakes were so hard that you can dive the nose down in the air just by hitting the brakes. My GT 2.0 doesn't work that way - the brakes are way too soft.

I've tried all types of settings in the ESC and on my radio. Any thoughts? Does anyone else have this issue?
what is your reverse setting on the ESC? I have heard that the Reverse setting affects the brake setting. I turn it up to 100% as well and then configure even when running only forward and brake mode.
__________________
< Team Associated RC10B6D>
< Durango DESC410V2, DEX410V5>
Cain is offline   Reply With Quote
Old 12-12-2013, 01:07 AM   #12257
Tech Adept
 
Stusdal's Avatar
 
Join Date: Nov 2004
Location: Norway
Posts: 100
Trader Rating: 1 (100%+)
Default

Quote:
Originally Posted by Solara View Post
Open the Reventon interface on your computer, connect with your ESC and LCD card, when the interface started, hit "S" that will go to the safe mode....then if the computer asked to connect to ESC, hit "NO"....then it should get to the back door of the ESC connection and on the left you should be able to load the software that you want...
Thank you for the reply. I tried and it was looking good, but the Upgrade fails right away. Du you have any other suggestions or is it a lost cause when this don't work?
__________________
Serpent || Futaba || Protoform || Orca || GensACE || Sorex ||
*When you are not practicing, remember, someone somewhere is practicing, and when you meet him he will win*
Stusdal is offline   Reply With Quote
Old 12-13-2013, 03:56 PM   #12258
Tech Master
 
Scrad's Avatar
 
Join Date: Feb 2003
Location: Plover, WI
Posts: 1,508
Trader Rating: 15 (100%+)
Default

Quote:
Originally Posted by Cain View Post
what is your reverse setting on the ESC? I have heard that the Reverse setting affects the brake setting. I turn it up to 100% as well and then configure even when running only forward and brake mode.
Check this. Put the reverse force as high as it will go. I have GT's in all of my vehicles off road and on road and the brakes are always good.
Scrad is offline   Reply With Quote
Old 12-13-2013, 09:49 PM   #12259
Tech Rookie
 
Join Date: Dec 2013
Posts: 3
Default Reventon Pro Reverse Problems

Hi everyone, I just picked up a Reventon Pro, put it in my HPI Sprint 2, and updated the firmware with Reventon Pro Drift with my computer and the program card. I updated the settings to add forward/brake with reverse and LiPo cutoff.

It worked for the first few runs, but now whenever i start it up, the two led lights come on, but after a couple of seconds the motor (a SP competition 3.0 5.5T) starts to make a buzzing noise and the lights go off. When i pull the throttle, the lights come back on, but I lose reverse functionality.

Can anyone help me?
70savage is offline   Reply With Quote
Old 12-14-2013, 10:00 AM   #12260
Tech Champion
 
Join Date: Nov 2002
Location: Chicago, IL
Posts: 7,472
Trader Rating: 34 (100%+)
Default

Quote:
Originally Posted by 70savage View Post
Hi everyone, I just picked up a Reventon Pro, put it in my HPI Sprint 2, and updated the firmware with Reventon Pro Drift with my computer and the program card. I updated the settings to add forward/brake with reverse and LiPo cutoff.

It worked for the first few runs, but now whenever i start it up, the two led lights come on, but after a couple of seconds the motor (a SP competition 3.0 5.5T) starts to make a buzzing noise and the lights go off. When i pull the throttle, the lights come back on, but I lose reverse functionality.

Can anyone help me?
Did you also calibrate your radio to the ESC?
Nexus is offline   Reply With Quote
Old 12-14-2013, 11:19 AM   #12261
Tech Rookie
 
Join Date: Dec 2013
Posts: 3
Default

I calibrated when I put the ESC in, but before I updated the ESC Firmware. Re-calibrating did the trick. Thanks Nexus! I didn't think I had to do it again.
70savage is offline   Reply With Quote
Old 12-14-2013, 03:01 PM   #12262
Tech Regular
 
Join Date: May 2002
Location: Sweden
Posts: 405
Default

My reventon pro failed badly today.

have been running it with 8.5t and mostly 17.5blinky. today i wanted to try mod so soldered in a 4.5t motor, geared it same as all the other 4.5 drivers was using, after 4-5min the esc stopped working. measured it and it was 95 degrees celsius! the cap and minus wire was unsoldered from the board... its dead now.. was using blinky software, drrs on 1, 20% dragbrake
one other driver is using a reventon pro 1.1 and he can drive 7min without problems with a 4.5 on the track

bought mine at rcmart, but cant seem to find where to contact speed passion on their homepage? would be nice to get a quote on what repairtcost would be or if i just has to throw it and get a new esc from another company instead
__________________
Xray T4`16 - Hobbywing - Highest - Sanwa - Gens Ace
Schumacher Cougar KF2 - Hobbywing - Highest - Sanwa - Gens Ace
Bappe is offline   Reply With Quote
Old 12-15-2013, 02:18 PM   #12263
Tech Addict
 
Dog Runner's Avatar
 
Join Date: Mar 2010
Location: Illinois
Posts: 602
Trader Rating: 17 (100%+)
Send a message via Skype™ to Dog Runner
Default

Thanks for the replies regarding my lack of brakes on my GT 2.0. A Speed Passion guy at my track reinstalled all new software and worked some magic and now it's as it should be. I'm not sure what he did, but it was a lot of tweaking here and there.
__________________
JR
Need a real estate agent? I can help.
Dog Runner is offline   Reply With Quote
Old 12-15-2013, 03:28 PM   #12264
Tech Fanatic
 
jw_rooster's Avatar
 
Join Date: Mar 2009
Location: Oregon
Posts: 887
Trader Rating: 1 (100%+)
Default

I just got the Reventon pro 1.1 and a MMM 17.5 this week and ran it for the first time yesterday at a regional series race taking 3rd place. Super smooth and fast combination. I advanced the endbell timing to maximum for the mains and was temping about 140 degrees F. After 6 minutes. I wonder how much more gear I can give it......
jw_rooster is offline   Reply With Quote
Old 12-15-2013, 10:45 PM   #12265
Tech Adept
 
askbob's Avatar
 
Join Date: Apr 2011
Posts: 213
Trader Rating: 28 (100%+)
Default

Finally got around to installing my Reventon Pro into the B4 buggy with a 10.5 motor. I am interested in using the wifi module to make changes with my iphone. Reading through the Speed Passion notes on the module it states that it will not work with the most recent iphone OS which is ios7. Is this still a problem and if so, will it be worked out to be able to use the wifi module with the iphone?
askbob is offline   Reply With Quote
Old 12-16-2013, 04:09 AM   #12266
Tech Regular
 
Join Date: Apr 2012
Posts: 259
Default stock club race esc

so i just tried to run this today for the first time in my touring car with a 10.5t motor but the brakes barely work. I'm pretty sure i calibrated the esc properly at neutral then full throttle then full reverse. i even changed he spa to maximum (120%) but it hardly made a difference.

is this how it should be? any thoughts?

cheers
jason
picko990 is offline   Reply With Quote
Old 12-17-2013, 08:28 AM   #12267
Tech Champion
 
Solara's Avatar
 
Join Date: Sep 2002
Location: Chicago Illinois USA
Posts: 9,042
Trader Rating: 16 (100%+)
Send a message via ICQ to Solara Send a message via AIM to Solara
Default

http://www.speedpassion.net/uploadfi..._v1_1_0_24.zip

Another update....latest V24 interface. Including the long waiting V21 BLINKY software just got ROAR approval. However, we are still waiting ROAR to list it on their website so you might not see it listing the V21 on the site and IF your track is concern about the ROAR approval status, please keep using the V20 software from your previous download.

EX customer............they must use the V23.5 interface or this current V24 interface. Anything before the V23.5 interface will NOT WORK.

Key feature of the EX is....aiming for 12th scale racing, but can also run with 2 cells....cannot do 3 cells like V1.1 PRO does. And yes, it is BLACK, it is faster (depends on your personal like....LOL) Also...the EX, come standard with the used to be optional SUPER CAP. Bonus.....however, it does not come with the LCD programmer card as we thought most ppl are REVENTON current customer and they might more then 1 LCD card laying around. But purchasing the EX on our direct sale site, for extra $10, we will throw in the LCD as a special....that LCD card retail is $28 USD.

Good luck racing everyone.....and please visit our new online store at SPEED POWER RC (see below link)

http://shop.speedpowerrc.com/reventon-pro-1-1-ex/



__________________
SPEED PASSION - King Golden, Speed Passion USA, Speed Power, Hirosaka Pro Products, East Coast Bodies, Schumacher Racing, Hurricane Motorsports, Serpent America, Sweep Racing USA. http://www.spautomobile.com/en/index.asp (SPEED PASSION AUTOMOTIVE)
NEW Speed Power/Speed Passion direct sale site - http://shop.speedpowerrc.com/
Solara is offline   Reply With Quote
Old 12-17-2013, 08:49 AM   #12268
Tech Addict
 
32819toon's Avatar
 
Join Date: Mar 2006
Location: North of England
Posts: 570
Trader Rating: 1 (100%+)
Default

Message for Solara - I bought a Reventon S which stopped working in its first race. I returned it to RCMart who have returned it to Speed Passion for repair / replacement. That was a month ago. How long must I wait to find out what is happening ? I've emailed Speed Passion directly, but they haven't replied.
__________________
32819toon
Yokomo BD7 RS, Modified Spec-R S1, Schumacher GT12, Tamiya M03, M05, M01, M03RWD, MF01-X, BSR M-Rage, ABC Gambado, Associated TC4.
32819toon is offline   Reply With Quote
Old 12-17-2013, 10:27 AM   #12269
Tech Champion
 
Join Date: Nov 2002
Location: Chicago, IL
Posts: 7,472
Trader Rating: 34 (100%+)
Default

Quote:
Originally Posted by Bappe View Post
My reventon pro failed badly today.

have been running it with 8.5t and mostly 17.5blinky. today i wanted to try mod so soldered in a 4.5t motor, geared it same as all the other 4.5 drivers was using, after 4-5min the esc stopped working. measured it and it was 95 degrees celsius! the cap and minus wire was unsoldered from the board... its dead now.. was using blinky software, drrs on 1, 20% dragbrake
one other driver is using a reventon pro 1.1 and he can drive 7min without problems with a 4.5 on the track

bought mine at rcmart, but cant seem to find where to contact speed passion on their homepage? would be nice to get a quote on what repairtcost would be or if i just has to throw it and get a new esc from another company instead
Did you use this page?
http://www.rcmart.com/contact_us.php




Quote:
Originally Posted by jw_rooster View Post
I just got the Reventon pro 1.1 and a MMM 17.5 this week and ran it for the first time yesterday at a regional series race taking 3rd place. Super smooth and fast combination. I advanced the endbell timing to maximum for the mains and was temping about 140 degrees F. After 6 minutes. I wonder how much more gear I can give it......
Nice. It's a fine line with timing and heat, but 140 is solid to run a 17.5. Depending on the layout higher timing isn't necessarily faster. Play with gearing and timing if you have time.

Quote:
Originally Posted by picko990 View Post
so i just tried to run this today for the first time in my touring car with a 10.5t motor but the brakes barely work. I'm pretty sure i calibrated the esc properly at neutral then full throttle then full reverse. i even changed he spa to maximum (120%) but it hardly made a difference.

is this how it should be? any thoughts?

cheers
jason
Jason,

Just to test use a new profile on your radio and then do the calibration.
Nexus is offline   Reply With Quote
Old 12-17-2013, 10:29 AM   #12270
Tech Champion
 
Join Date: Nov 2002
Location: Chicago, IL
Posts: 7,472
Trader Rating: 34 (100%+)
Default

Quote:
Originally Posted by Solara View Post

Good luck racing everyone.....and please visit our new online store at SPEED POWER RC (see below link)

http://shop.speedpowerrc.com/reventon-pro-1-1-ex/



We are also running a Christmas sale on Speed Power RC.
shop.speedpowerrc.com
Nexus is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speed Passion GT Competition Brushless ESC v2.0 Low Profile, LPF pink_sleeve Electric On-Road 13 07-08-2009 10:17 AM


Tags
gt2, lack of help, overpriced, poor customer service, reventon, reventon pro, speed passion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 01:22 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0