R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 05-06-2013, 01:08 PM   #11551
Tech Rookie
 
Join Date: Feb 2012
Location: UK
Posts: 10
Default

Hi,

I have an issue with a SP Rreventon Pro, the red and orange are blinking?? lipo is fully charged, it works, forward, brake, I have two, the other is fine, this one has been setup the same but both lights are blinking? Any idea's
deepdale11 is offline   Reply With Quote
Old 05-06-2013, 04:33 PM   #11552
Tech Regular
 
Pittster's Avatar
 
Join Date: Feb 2013
Location: Newcastle NSW
Posts: 365
Trader Rating: 4 (100%+)
Default

Quote:
Originally Posted by deepdale11 View Post
Hi,

I have an issue with a SP Rreventon Pro, the red and orange are blinking?? lipo is fully charged, it works, forward, brake, I have two, the other is fine, this one has been setup the same but both lights are blinking? Any idea's
That normally indicates that it is running Stock 0 Firmware or Blinky mode.
Pittster is offline   Reply With Quote
Old 05-06-2013, 08:13 PM   #11553
Tech Initiate
 
Join Date: Apr 2013
Posts: 46
Default

How much motor can I run on a speed Passion r speed control
wagon 1 is offline   Reply With Quote
Old 05-06-2013, 08:22 PM   #11554
Tech Apprentice
 
Join Date: Sep 2012
Posts: 72
Default

Quote:
Originally Posted by deepdale11 View Post
Hi,

I have an issue with a SP Rreventon Pro, the red and orange are blinking?? lipo is fully charged, it works, forward, brake, I have two, the other is fine, this one has been setup the same but both lights are blinking? Any idea's
It should be the sensor wire connection problem. Please change the other sensor wire.
WMGary is offline   Reply With Quote
Old 05-06-2013, 08:32 PM   #11555
Tech Apprentice
 
Join Date: Sep 2012
Posts: 72
Default

Quote:
Originally Posted by shamar View Post
hi WDGary
we did update the firmware more dan once its not coming on..... We even tried 2 pc to make sure its not the pc... help plz
I guess it should be the hardware problem. If the ESC is within warranty period, submit a RMA request. You can contact SP CS for further support. http://www.speedpassion.net/en/wheretobuy.asp
WMGary is offline   Reply With Quote
Old 05-06-2013, 08:36 PM   #11556
Tech Apprentice
 
Join Date: Sep 2012
Posts: 72
Default

Quote:
Originally Posted by wagon 1 View Post
How much motor can I run on a speed Passion r speed control
You can refer user manual. The Brushless Motor Limit on Reventon R is 5.5T or slower (no turbo software (STOCK1)).

Page1
http://www.speedpassion.net/uploadfi...un01st2012.pdf
WMGary is offline   Reply With Quote
Old 05-06-2013, 10:11 PM   #11557
Tech Master
 
burgboyz's Avatar
 
Join Date: Jan 2005
Location: Da 'Burg
Posts: 1,247
Trader Rating: 70 (100%+)
Default

Quote:
Originally Posted by sidecarphil1 View Post
Hey fellas

I am looking at getting into mod racing do i want the Revention Pro or R speedo ;-) thanks
What turn motors will you be using?

"Pro" 3.5 or slower 140amp (Hybrid Boost targeted for 4.5 to 10.5)

"R" 5.5 or slower 70amp (Hybrid Boost targeted for 7.5 to 10.5)
__________________
Got Droop???
Speed Passion....Speed Power....Serpent America/Desoto Racing.
burgboyz is offline   Reply With Quote
Old 05-07-2013, 01:23 PM   #11558
Tech Rookie
 
Join Date: Feb 2012
Location: UK
Posts: 10
Default

Quote:
Originally Posted by Pittster View Post
That normally indicates that it is running Stock 0 Firmware or Blinky mode.

I have double checked and its on modify 2, the orange light doesnt always blink but the red does?
deepdale11 is offline   Reply With Quote
Old 05-07-2013, 01:24 PM   #11559
Tech Rookie
 
Join Date: Feb 2012
Location: UK
Posts: 10
Default

Quote:
Originally Posted by WMGary View Post
It should be the sensor wire connection problem. Please change the other sensor wire.
Just tried a different one but still the same??

Thanks
deepdale11 is offline   Reply With Quote
Old 05-07-2013, 02:41 PM   #11560
Tech Initiate
 
Join Date: Jan 2007
Location: Toronto
Posts: 37
Default

Can Revention Pro switch software, (from blink to boost) without connecting to a computer? Will the Bluetooth module be updated to support Android 4.2 and above?
X men is offline   Reply With Quote
Old 05-07-2013, 08:27 PM   #11561
Tech Apprentice
 
Join Date: Sep 2012
Posts: 72
Default

Quote:
Originally Posted by deepdale11 View Post
Just tried a different one but still the same??

Thanks
If the motor is work normally with the other ESC, I think the PRO's sensor unit has some hardware problem.
WMGary is offline   Reply With Quote
Old 05-07-2013, 08:31 PM   #11562
Tech Apprentice
 
Join Date: Sep 2012
Posts: 72
Default

Quote:
Originally Posted by X men View Post
Can Revention Pro switch software, (from blink to boost) without connecting to a computer? Will the Bluetooth module be updated to support Android 4.2 and above?
You can use Bluetooth(Android) / WIFI(iOS) module to update or change the firmware. Bluetooth module can working on Nexus 7 Android Version V4.2.2.
WMGary is offline   Reply With Quote
Old 05-08-2013, 09:42 AM   #11563
Tech Regular
 
tiago890's Avatar
 
Join Date: May 2012
Location: Harrison, NJ
Posts: 269
Trader Rating: 8 (100%+)
Default

Hey guys, in the market for SP esc, going to be running in RCGT open class, would the Reventon R be good enough or would i have to get the pro for full benifits of boost and timing?
tiago890 is offline   Reply With Quote
Old 05-12-2013, 06:36 AM   #11564
Tech Master
 
Rusty Old Fart's Avatar
 
Join Date: Aug 2011
Location: Newcastle AUS
Posts: 1,749
Trader Rating: 20 (100%+)
Default

Here's a strange one for you all.

Reventon ESC works perfectly battery after battery. If the SCT rolls onto its roof (like SCT's do) the ESC will run for about 30sec then shut down. Once powered back up the esc loses all end points and has to reset and set all end points again. ESC is 6 months old and only ever been used in blinky 17.5 buggy then moved to a 10.5 blinky SCT. Even a few people at the track are left scratching their heads in bewilderment .
__________________
******************** **********************
Rusty Old Fart is offline   Reply With Quote
Old 05-13-2013, 03:05 AM   #11565
Tech Rookie
 
Join Date: May 2013
Posts: 6
Default Speed passion 5.5r motor issue

I am having an issue with a 5.5r v3 boosted with a reventon pro in a touring car.

The gear rate is 6.15:1 and it is slow and only gets to around 38 deg c, turbo comes on with a .5s delay but the car is no faster than a boosted 10.5 with my reventon r and same gear rate. If you turn turbo off on both the 5.5 is alot faster but boost both and they are the same speed but the 5.5r does not get as hot?

I can not understand this settings of 10.5t with reventon r hb 50% max boost 135 delay .5s

Reventon pro with 5.5r hb 50% max boost 120 and delay .5s

Any ideas why it is not faster or getting hot with this gear ratio?

Thanks

Last edited by 181racer; 05-13-2013 at 03:46 AM. Reason: added correct information
181racer is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speed Passion GT Competition Brushless ESC v2.0 Low Profile, LPF pink_sleeve Electric On-Road 13 07-08-2009 10:17 AM


Tags
gt2, lack of help, overpriced, poor customer service, reventon, reventon pro, speed passion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 03:22 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0