R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 04-08-2013, 08:58 AM   #11431
Tech Master
 
turd ferguson's Avatar
 
Join Date: Aug 2005
Location: tuCSoN, AZ
Posts: 1,042
Trader Rating: 3 (100%+)
Send a message via AIM to turd ferguson
Default

Quote:
Originally Posted by napoleon1981 View Post
Today I drove with my new Speedpassion reventon Pro and 4.5 MMM setup for the first time. I'm very impressed with the system.

The problem I had was that the car at the end of a run (around the 5 minute mark) suddenly slowed down to what seemed to me a protected speed. Like half the speed of a 21.5 but would still work.

The temperatures did not seem outrageous to me. Motor was 110F and the speedo around 140F. Did the speedo go in thermal protection, or does it shut itself off in that case? What else does it sound like? A lipo issue? The next heat after a charge everything seemed to work fine again for the first 5 mins, but same thing happened again.
I had the same thing happen when the Reventon R and S were released. It is in your settings that can easily be changed on your box. It is either your voltage cutoff set on your batteries or the thermal protection. I believe it is the thermal protection. I lowered both and haven't had an issue since.
__________________
TrakPower, Speed Passion USA, Pro-line, Stickit1 Racing, LiveRC.com
turd ferguson is offline   Reply With Quote
Old 04-09-2013, 02:28 AM   #11432
Tech Adept
 
Join Date: Aug 2010
Posts: 181
Default

I had my first outdoor race with my new TCXX kitted out with a Reventon Pro and 13.5 MMM motor and smashed my PB by 13.5 seconds!

I was so impressed with the smooth power delivery and rocket like speed down the straight. I seemed so much faster down the straight with great infield acceleration and the motor was coming off barely 60c.

By the end of the day I had worked up to the following:

FDR 5.9
DRRS 8
HB 90%
HB MAX 150K
HB Delay 0.3
HB START 4000
SLOPE 18/0.1
Brake 80%

Great days racing and love the new kit. Well done SpeedPassion!!

Last edited by dvaid852456; 04-09-2013 at 12:40 PM.
dvaid852456 is offline   Reply With Quote
Old 04-09-2013, 12:46 PM   #11433
Tech Apprentice
 
Join Date: Feb 2012
Location: Stillwater, MN
Posts: 65
Trader Rating: 6 (100%+)
Default

Is there a US speed passion rep on the board?
ikpthegame is offline   Reply With Quote
Old 04-09-2013, 01:15 PM   #11434
Tech Elite
 
IIGQ4U's Avatar
R/C Tech Elite Subscriber
 
Join Date: Dec 2005
Location: La Jolla, CA SoCal
Posts: 2,489
Trader Rating: 53 (100%+)
Default

Quote:
Originally Posted by dvaid852456 View Post
I had my first outdoor race with my new TCXX kitted out with a Reventon Pro and 13.5 MMM motor and smashed my PB by 13.5 seconds!

I was so impressed with the smooth power delivery and rocket like speed down the straight. I seemed so much faster down the straight with great infield acceleration and the motor was coming off barely 60c.

By the end of the day I had worked up to the following:

FDR 5.9
DRRS 8
HB 90%
HB MAX 150K
HB Delay 0.3
HB START 4000
SLOPE 18/0.1
Brake 80%

Great days racing and love the new kit. Well done SpeedPassion!!
How were you able to access these settings? I don't have most of those options available on my programming card.

Last edited by IIGQ4U; 04-09-2013 at 02:23 PM.
IIGQ4U is offline   Reply With Quote
Old 04-09-2013, 02:22 PM   #11435
Tech Regular
 
Chuggz's Avatar
 
Join Date: Oct 2011
Posts: 479
Trader Rating: 11 (100%+)
Default

He's his username is solara
Chuggz is offline   Reply With Quote
Old 04-09-2013, 02:25 PM   #11436
Tech Champion
 
Solara's Avatar
 
Join Date: Sep 2002
Location: Chicago Illinois USA
Posts: 9,042
Trader Rating: 16 (100%+)
Send a message via ICQ to Solara Send a message via AIM to Solara
Default

Quote:
Originally Posted by ikpthegame View Post
Is there a US speed passion rep on the board?
Whatsup...?

Quote:
Originally Posted by Chuggz View Post
He's his username is solara
Thank you....
__________________
SPEED PASSION - King Golden, Speed Passion USA, Speed Power, Hirosaka Pro Products, East Coast Bodies, Schumacher Racing, Hurricane Motorsports, Serpent America, Sweep Racing USA. http://www.spautomobile.com/en/index.asp (SPEED PASSION AUTOMOTIVE)
NEW Speed Power/Speed Passion direct sale site - http://shop.speedpowerrc.com/
Solara is offline   Reply With Quote
Old 04-09-2013, 03:46 PM   #11437
Tech Adept
 
Join Date: Aug 2010
Posts: 181
Default

Quote:
Originally Posted by IIGQ4U View Post
How were you able to access these settings? I don't have most of those options available on my programming card.
I am running the latest software, V20 on the ESC, 2.7 on the program card and using Stock1 Profile.
dvaid852456 is offline   Reply With Quote
Old 04-09-2013, 04:22 PM   #11438
Tech Apprentice
 
Join Date: Feb 2012
Location: Stillwater, MN
Posts: 65
Trader Rating: 6 (100%+)
Default

Quote:
Originally Posted by Solara View Post
Whatsup...?



Thank you....
sent ya a pm
ikpthegame is offline   Reply With Quote
Old 04-10-2013, 03:20 PM   #11439
Tech Adept
 
jamie ferrell's Avatar
 
Join Date: Aug 2011
Posts: 100
Trader Rating: 3 (80%+)
Default

Can a tech please help out here.....I just ran my new silver arrow2 and new Blaze 2450 sensored 1/8 motor lastnight and loved it.. I tqed the event, but my issue is this:

Everytime it hits the track its normal and running in sensored mode just fine....the minute i give it a burst of throttle hard, it flashes the green and red light and goes into sensorless mode. I have changed out the sensor cable 3 times with no fix to the issue. It does cog a little when in sensorless mode. Could i have gotten a bad sensor board in the new motor?
__________________
Jamie Ferrell
www.jamairpaint.com
JamAir, Radiopost, Kyosho, Tekin, AKA
jamie ferrell is offline   Reply With Quote
Old 04-10-2013, 11:57 PM   #11440
Tech Elite
 
IIGQ4U's Avatar
R/C Tech Elite Subscriber
 
Join Date: Dec 2005
Location: La Jolla, CA SoCal
Posts: 2,489
Trader Rating: 53 (100%+)
Default

I installed the Speed Passion software for the Reventon Pro onto one of my Macs today and really like the program. The installation was pretty simple and the user interface is easy to navigate. The Reventon Pro ESC itself is also extremely smooth.

I can't wait to get out to the track again and put the new ESC through its paces.
IIGQ4U is offline   Reply With Quote
Old 04-12-2013, 01:54 PM   #11441
Tech Rookie
 
Join Date: Aug 2011
Posts: 10
Trader Rating: 2 (100%+)
Default

[QUOTE=bvoltz;12014627]Before plugging in the USB cable, (No connection to the Speedo at this time), with the software up and running on your computer, Press and hold down the 2nd button from the left "Reset", while holding down the button down, plug in the USB cable. (yes you can start with one end of the UBS cable plugged in, I normally have it connected to the box). Once you have plug it in, you should see the "Upgrade Firmware" on the left side about 2/3 the way down from the top, appear. You can release the button. Click the "Update Firmware" button on the screen, this should take around 10mins.

See step by step direction starting on page 19 at

Thanks for that. I completely missed that in my manual.


cap
capricorn415 is offline   Reply With Quote
Old 04-12-2013, 02:42 PM   #11442
Tech Adept
 
Nicholas Muelle's Avatar
 
Join Date: Feb 2013
Location: Wisconsin
Posts: 112
Default

how do you increase the brake force on the esc? Like how do you make it when you pull the brake on your controller, it stops quiker?
__________________
~Team Tekin~JConcepts~Spark EDM Supplies~Trackside~
Nicholas Muelle is offline   Reply With Quote
Old 04-12-2013, 03:04 PM   #11443
Tech Elite
 
IIGQ4U's Avatar
R/C Tech Elite Subscriber
 
Join Date: Dec 2005
Location: La Jolla, CA SoCal
Posts: 2,489
Trader Rating: 53 (100%+)
Default

You can increase the braking on the program card. It is one of the options.
IIGQ4U is offline   Reply With Quote
Old 04-13-2013, 07:11 PM   #11444
Tech Addict
 
woozer71's Avatar
 
Join Date: Mar 2004
Posts: 556
Trader Rating: 23 (96%+)
Default

I am running the reventon pro with LRP x12 10.5 in blinky mode. I am running the v20 software. The problem I have is that when the car runs the power seems way down. The voltage in the battery is fine. I ran the motor with my HW justsock and the motor runs fine, so that not the problem. I have tried the esc with a17.5 Tekin and it does the same thing. Any suggestions would be appreciated.
__________________
---------------------------------------------------
Fraser Coast RC Car Club/FCRCCC
VBC D06 / Xray T4 2013
Yokomo BMax2 ver 2 - Tamiya F104 x1
Sanwa MT-4
woozer71 is offline   Reply With Quote
Old 04-13-2013, 10:43 PM   #11445
Tech Addict
 
Dog Runner's Avatar
 
Join Date: Mar 2010
Location: Illinois
Posts: 602
Trader Rating: 18 (100%+)
Send a message via Skype™ to Dog Runner
Default

I'm confused as to where to get the most recent software for the reventon pro. Is it via the computer or the wifi module/app or somewhere else?

What version number is the most recent software?

If its a computer program, does it work on a Mac ?

Thanks for any help.
__________________
JR
Need a real estate agent? I can help.
Dog Runner is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speed Passion GT Competition Brushless ESC v2.0 Low Profile, LPF pink_sleeve Electric On-Road 13 07-08-2009 10:17 AM


Tags
gt2, lack of help, overpriced, poor customer service, reventon, reventon pro, speed passion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 09:10 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0