R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 04-02-2013, 10:17 AM   #11401
Tech Apprentice
 
Speed Passion's Avatar
 
Join Date: Apr 2010
Posts: 62
Default

Greetings,

I had a strange question. I went to the SpeedPassion website and it says that they now have a US Warehouse. I put one $7.50 item in my cart went to checkout and the cost of shipping is 700g $44.45USD??. How can something that is that small and light cost this much??

I'm getting the impression this is not a real US Warehouse but overseas but I'm confused why they claim to have a US location?

Thanks!
Speed Passion is offline   Reply With Quote
Old 04-02-2013, 10:22 AM   #11402
Tech Elite
 
IIGQ4U's Avatar
R/C Tech Elite Subscriber
 
Join Date: Dec 2005
Location: La Jolla, CA SoCal
Posts: 2,489
Trader Rating: 53 (100%+)
Default

They do have a US location. I spoke with them yesterday and also ordered an item from them that has a domestic USPS tracking number.

Was the item you selected in stock at the US warehouse? There will either be a globe or a flag indicating where the item is in stock. You may also see two shipping options, FedEx and USPS, with FedEx being significantly higher.

Anyway, they are definitely in the US.
IIGQ4U is offline   Reply With Quote
Old 04-02-2013, 10:30 AM   #11403
Tech Master
 
slakr's Avatar
 
Join Date: Jan 2007
Location: NC
Posts: 1,631
Trader Rating: 25 (100%+)
Default

Quote:
Originally Posted by Speed Passion View Post
Greetings,

I had a strange question. I went to the SpeedPassion website and it says that they now have a US Warehouse. I put one $7.50 item in my cart went to checkout and the cost of shipping is 700g $44.45USD??. How can something that is that small and light cost this much??

I'm getting the impression this is not a real US Warehouse but overseas but I'm confused why they claim to have a US location?

Thanks!
The cart default to a high FedEx shipping rate with unknown destination. Scroll down in your cart, select the USPS option, enter your address info and then hit the refresh button. You will get a more reasonable shipping charge. The US shipping location is legit.
__________________
AE B6D,TC7|Mugen MBX7TR Eco|JQ THE Car WE,eCar WE
Tim aka "slakr" ROAR No. 3-119960
slakr is offline   Reply With Quote
Old 04-02-2013, 10:35 AM   #11404
Tech Apprentice
 
Speed Passion's Avatar
 
Join Date: Apr 2010
Posts: 62
Default

Quote:
Originally Posted by IIGQ4U View Post
They do have a US location. I spoke with them yesterday and also ordered an item from them that has a domestic USPS tracking number.

Was the item you selected in stock at the US warehouse? There will either be a globe or a flag indicating where the item is in stock. You may also see two shipping options, FedEx and USPS, with FedEx being significantly higher.

Anyway, they are definitely in the US.
The whole page says US Warehouse. At the top left says "US Warehouse" Main page says "Ship from USA Warehouse Cart List" at the top. The item is a 190mm body. It's $7.50. When adding to cart.

The cart says:

Subtotal = $7.5USD
Discounted = $7.5USD
(Total Weight) Shipping = 700g $44.45USD (*)
Final Total = $51.95USD


We wil send the e-quotation to you at next working days. And in the quotation, it will show the shipping cost(s) that you choose here:

United States-FedEx $44.45USD

This can't be correct, $44.45 for shipping?? I can order from China and pay around $20.00-$27.00 maximum.

No other options either!

Last edited by Speed Passion; 04-02-2013 at 11:04 AM.
Speed Passion is offline   Reply With Quote
Old 04-02-2013, 11:22 AM   #11405
Tech Regular
 
durtbag's Avatar
 
Join Date: Feb 2011
Location: planet X in a distant galaxy
Posts: 354
Default

Quote:
Originally Posted by Speed Passion View Post
The whole page says US Warehouse. At the top left says "US Warehouse" Main page says "Ship from USA Warehouse Cart List" at the top. The item is a 190mm body. It's $7.50. When adding to cart.

The cart says:

Subtotal = $7.5USD
Discounted = $7.5USD
(Total Weight) Shipping = 700g $44.45USD (*)
Final Total = $51.95USD


We wil send the e-quotation to you at next working days. And in the quotation, it will show the shipping cost(s) that you choose here:

United States-FedEx $44.45USD

This can't be correct, $44.45 for shipping?? I can order from China and pay around $20.00-$27.00 maximum.

No other options either!
I wanted to order a WiFi Module from the USA Warehouse (300g), got quoted $35 USPS to Canada. Contacted Speed Passion and they confirmed that it was a correct shipping cost. Bought it from a HK internet store, shipping was $6.50.

Just can't figure out why they need to charge such excessive shipping. I don't even bother looking at their Web store anymore.
__________________
AW HELL RICKEY, I WAS HIGH WHEN I SAID THAT!
durtbag is offline   Reply With Quote
Old 04-02-2013, 12:02 PM   #11406
Tech Apprentice
 
Speed Passion's Avatar
 
Join Date: Apr 2010
Posts: 62
Default

Quote:
Originally Posted by durtbag View Post
I wanted to order a WiFi Module from the USA Warehouse (300g), got quoted $35 USPS to Canada. Contacted Speed Passion and they confirmed that it was a correct shipping cost. Bought it from a HK internet store, shipping was $6.50.

Just can't figure out why they need to charge such excessive shipping. I don't even bother looking at their Web store anymore.
Right. I think they are making a profit on shipping! I entered my address and it's better on the cost but still excessive!! I agree! $15.00 for a light body that costs $7.50 is excessive!
Speed Passion is offline   Reply With Quote
Old 04-02-2013, 12:23 PM   #11407
Tech Adept
 
Join Date: Oct 2007
Location: Sch. Haven ,PA
Posts: 147
Trader Rating: 15 (100%+)
Default

i have a quesition on the bluetooth . I have a pro and an r the r works perfect with the blue tooth the pro will connect to the esc and then after a minut or so says can not connect to the esc the blue light is still solid on the bluetooth modular. I can adjust the esc with out any issues using the computer but it keeps disconnecting with the bluetooth adapter. The R works fine no problems at all any suggestions?

Last edited by siggy99x; 04-02-2013 at 12:38 PM.
siggy99x is offline   Reply With Quote
Old 04-02-2013, 02:02 PM   #11408
Tech Fanatic
 
Robertcooper88's Avatar
 
Join Date: Jun 2010
Location: Loxahatchee
Posts: 782
Trader Rating: 12 (100%+)
Default

I would try 4.2 FDR with the Green Sensor board as a start. Watch temps and change accordingly.
Quote:
Originally Posted by Pigiolino View Post
Hi Guys,
I'm Pier from Italy,
What is the best configuration for 13.5 MMM for no timing races on carpet with touring 1:10?
Which rotor with sensor unit + 40?
Thks in advance.

PIER
__________________
DischargeRC.com - Race-Opts MTS T2 - TRINITY FOR POWER
Robertcooper88 is offline   Reply With Quote
Old 04-02-2013, 02:19 PM   #11409
Tech Regular
 
durtbag's Avatar
 
Join Date: Feb 2011
Location: planet X in a distant galaxy
Posts: 354
Default

Quote:
Originally Posted by siggy99x View Post
i have a quesition on the bluetooth . I have a pro and an r the r works perfect with the blue tooth the pro will connect to the esc and then after a minut or so says can not connect to the esc the blue light is still solid on the bluetooth modular. I can adjust the esc with out any issues using the computer but it keeps disconnecting with the bluetooth adapter. The R works fine no problems at all any suggestions?
Strange one! I have (had) a WiFi Module that does the same thing with an R. Speed Passion USA hasn't been any help, I ended up having to send the Module back to Hong Kong as they don't warranty any of their products that are not purchased in the USA.

Out of curiosity, does the Pro ESC work with the Bluetooth Module still connected inline, but disconnected from the phone?
My Wifi Module did not. My R ESC works fine when connected directly to the Rx.
__________________
AW HELL RICKEY, I WAS HIGH WHEN I SAID THAT!
durtbag is offline   Reply With Quote
Old 04-02-2013, 02:29 PM   #11410
Tech Master
 
Cult Racing's Avatar
 
Join Date: Dec 2010
Location: La$ Vega$
Posts: 1,806
Trader Rating: 42 (100%+)
Default

Does anyone know when the Blaze 4x4 motor is going to back in stock?
__________________
Mugen - Airtronics - AKA - Ninja

MBX7R - Beat B5 - AKA - Airtronics
MBX7T - Beat BT7 - AKA - Airtronics
Cult Racing is offline   Reply With Quote
Old 04-02-2013, 11:11 PM   #11411
Tech Regular
 
Chuggz's Avatar
 
Join Date: Oct 2011
Posts: 479
Trader Rating: 11 (100%+)
Default

Quote:
Originally Posted by Chuggz View Post
Hi guys can you please tell me if this sounds off ,
It's the mmm 17.5r motor and I'm just not sure if this sounds right
Please have a look at the YouTube video I made
http://youtu.be/B-oS62JgMAM

After this video my motor let out a nice puff of smoke on the next track day,
I have a reedy sonic in ATM , I like it
Chuggz is offline   Reply With Quote
Old 04-02-2013, 11:37 PM   #11412
Tech Regular
 
pekow91's Avatar
 
Join Date: May 2012
Location: Bay Area, CA
Posts: 429
Trader Rating: 45 (100%+)
Default

I need to get a new 17.5 motor for my Kyosho RB6 that I race in blinky mode. I have received a lot of recommendations for the speed passion MMM and I was thinking of picking one up. I noticed a lot of people mentioning the different sensor boards and rotors and wanted to see if its a worthy upgrade for the MMM. I wasnt 100% sure if those green and blue boards were even capataible with the MMM.
__________________
Kyosho RB6 | Kyosho MP9 TKI3E | Xray XB4
pekow91 is offline   Reply With Quote
Old 04-02-2013, 11:57 PM   #11413
Tech Initiate
 
Join Date: Mar 2011
Location: Europe
Posts: 29
Send a message via Skype™ to asalk
Default

Quote:
Originally Posted by chevmaro View Post
What's the word on the reventon pro? Are we still having lots of failures or is it solid now? Been out a while. Any good?
Have two reventons pro in 1:10 buggy and TC for more than half a year, no problems at all.
asalk is offline   Reply With Quote
Old 04-03-2013, 01:31 AM   #11414
Tech Adept
 
NitroBug74's Avatar
 
Join Date: Sep 2012
Location: Bayside
Posts: 187
Trader Rating: 7 (100%+)
Questions?? Reventon Pro LEDs blinking when they shouldn't?

Hi everyone,
I have a new SP reventon Pro paired up with a V3 17.5 motor.
I have wired it up as per the installation manual
I have charged my 2 cell lipo
I have updated all the software
End points and neutral points have all been set
This has all been done about 4 times over

Now, the perceived problem is...

The ESC is loaded with the mod firmware so I can fiddle with the timing
The motor end bell is fitted with a zero to ten degree timing adjustment slot.
It looks like it set something like 3 degrees

I'll switch the ESC on and I get a solid orange led and a solid red led
I can let it sit the forever and nothing will change

As soon as I operate the throttle either a little or a lot both the leds will flash and release back to neutral then the orange led with stay on solid but the red will flash away continuously.

According to the manual and the way I'm interpreting it, this would indicate a voltage problem, but the battery is showing 8.3 / 8.2 volts.

With the timing options enabled on the ESC, I wouldn't have thought this would be indicating blinky mode.

Can anyone offer any advise on this?
The motor and speedy is only about 10 days old and hasn't been run on any surface at all yet as I was building the kit.

Any help would be very much appreciated.
Cheers.

Update, I just tried to run it on the floor, the motor just buzzes and convulses when it tries to run with any sort on weight on it... Just the car weight.
I'm thinking something is horribly wrong.

Last edited by NitroBug74; 04-03-2013 at 01:40 AM. Reason: Important update
NitroBug74 is offline   Reply With Quote
Old 04-03-2013, 06:38 AM   #11415
Tech Fanatic
 
Robertcooper88's Avatar
 
Join Date: Jun 2010
Location: Loxahatchee
Posts: 782
Trader Rating: 12 (100%+)
Default

Do you have the sensor wire connected?


Quote:
Originally Posted by NitroBug74 View Post
Hi everyone,
I have a new SP reventon Pro paired up with a V3 17.5 motor.
I have wired it up as per the installation manual
I have charged my 2 cell lipo
I have updated all the software
End points and neutral points have all been set
This has all been done about 4 times over

Now, the perceived problem is...

The ESC is loaded with the mod firmware so I can fiddle with the timing
The motor end bell is fitted with a zero to ten degree timing adjustment slot.
It looks like it set something like 3 degrees

I'll switch the ESC on and I get a solid orange led and a solid red led
I can let it sit the forever and nothing will change

As soon as I operate the throttle either a little or a lot both the leds will flash and release back to neutral then the orange led with stay on solid but the red will flash away continuously.

According to the manual and the way I'm interpreting it, this would indicate a voltage problem, but the battery is showing 8.3 / 8.2 volts.

With the timing options enabled on the ESC, I wouldn't have thought this would be indicating blinky mode.

Can anyone offer any advise on this?
The motor and speedy is only about 10 days old and hasn't been run on any surface at all yet as I was building the kit.

Any help would be very much appreciated.
Cheers.

Update, I just tried to run it on the floor, the motor just buzzes and convulses when it tries to run with any sort on weight on it... Just the car weight.
I'm thinking something is horribly wrong.
__________________
DischargeRC.com - Race-Opts MTS T2 - TRINITY FOR POWER
Robertcooper88 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speed Passion GT Competition Brushless ESC v2.0 Low Profile, LPF pink_sleeve Electric On-Road 13 07-08-2009 10:17 AM


Tags
gt2, lack of help, overpriced, poor customer service, reventon, reventon pro, speed passion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 03:15 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0