R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 03-10-2013, 11:46 PM   #11311
Tech Master
 
Join Date: Feb 2012
Posts: 1,215
Trader Rating: 20 (100%+)
Default

Quote:
Originally Posted by Snafujg View Post
I'm looking to get a Reventon Stock Club ESC to run blinky 17.5 in my 2wd SC10. I have a Savox 1258 in the truck. Anyone experience brown out issues with this combo? I know the Savox are power hungry. Just want to make sure the ESC BEC is up to the task of a Savox servo before I buy one.
I have the Reventon Stock Club ESC with a Savox 1251 and a 17.5 and didn't have any brown out issues. No guarantees as it was my first day with this combo but I have not any any brown out issues with any SP ESC with a Savox.

Great ESC too, comes ready out of the box, wires on, Dean's connector on, fan mounted, ready to rock.
__________________
www.teamgravityrc.com
Leisure Hours Raceway
Troy Carter is offline   Reply With Quote
Old 03-11-2013, 01:01 AM   #11312
Tech Apprentice
 
Join Date: Sep 2012
Posts: 72
Default

Quote:
Originally Posted by quickershifter View Post
I can't get my Rev R to on the turbo/boost. How to set it up? I'm running Yeah Racing Hackmoto 13.5T BL motor.
Update ESC firmware to "Stock1 V19-58b7 - for Reventon R" by using Reventon PC interface V1.1.0.22. Adjust setting "Hybrid Boost Power" and "Hybrid Boost Maximum". Ensure ESC and Motor have connected sensor cable.
WMGary is offline   Reply With Quote
Old 03-11-2013, 12:29 PM   #11313
Tech Addict
 
Join Date: Jun 2007
Location: Bay Area, CA
Posts: 721
Trader Rating: 15 (100%+)
Send a message via AIM to DJGonzo69
Default Reventon Pro Setup Setting

Any good settings for 17.5 Blinky? Wanted to see if anyone has a good starting setup.
Thx.
__________________
|XRAY|RCAmerica|Hobbywing|KO PROPO|Team Scream Motors|Gonzo PaintWorX|
DJGonzo69 is offline   Reply With Quote
Old 03-12-2013, 07:40 PM   #11314
Tech Initiate
 
Join Date: Sep 2012
Posts: 40
Trader Rating: 1 (100%+)
Default

Hey guys, need help with a starting setup and FDR for a Reventon Pro in 21.5T boosted. Going to try this class again, last time I blew two motors trying to get a fast setup so don't want to repeat that mistake

Thanks
ript is offline   Reply With Quote
Old 03-12-2013, 10:55 PM   #11315
Tech Master
 
Danny-b23's Avatar
 
Join Date: Feb 2009
Location: Saskatoon, SK, Canada
Posts: 1,210
Trader Rating: 3 (100%+)
Default

Quote:
Originally Posted by DJGonzo69 View Post
Any good settings for 17.5 Blinky? Wanted to see if anyone has a good starting setup.
Thx.
1-1
2-3
3-8
4-8
5-1
6-3
7-1

Start at 4.0 FDR and 30-ish degrees of timing and add teeth and timing as necessary.
__________________
RC America|EA Motorsports|ORCA
Danny Buck
WCICS Rep - Round 1, Saskatoon, SK
Danny-b23 is offline   Reply With Quote
Old 03-13-2013, 12:34 AM   #11316
Tech Apprentice
 
ScottyTC4NZ's Avatar
 
Join Date: Jan 2010
Location: Dunedin, New Zealand
Posts: 76
Send a message via MSN to ScottyTC4NZ
Default Reventon Pro Setup with Yeah Racing 21.5t Open Setup

Hi Guys

Looking for a setup for the above.

Track is Low Traction Mixed Track with 65metre main straight

Also will need FDR to run with aswell

Thanks
__________________
Jamie Scott
Onroad Race Director
O.R.C.C.C
Titan ARC R10 2013 / Blitz / Sweep / Team Titan
Titan ARC R10 Upgrade / Blitz / Sweep / Team Titan
ScottyTC4NZ is offline   Reply With Quote
Old 03-13-2013, 02:18 PM   #11317
Tech Apprentice
 
coretex's Avatar
 
Join Date: Nov 2012
Location: Norway
Posts: 61
Default

I have programmed my Reventon R to do forward/reverse. However I have a problem with it: It won't always do reverse. I pull back many times on the transmitter but nothing happens. It seems to do reverse sometimes but not always.

The strange thing is that the brake function always works fine, so there is nothing wrong with the signal...
coretex is offline   Reply With Quote
Old 03-13-2013, 03:06 PM   #11318
Tech Champion
 
Solara's Avatar
 
Join Date: Sep 2002
Location: Chicago Illinois USA
Posts: 9,037
Trader Rating: 16 (100%+)
Send a message via ICQ to Solara Send a message via AIM to Solara
Default

Quote:
Originally Posted by Andy w View Post
As I said in my post, mine DOES work with a 1s. It works with either a rx pack or booster. I am trying to figure out why when it supposedly shouldn't.
May I know what booster you use..? I would LOVE to know that...cause I have this question asked so many times and I have no solution, until now...

When was your REVENTON S or R purchased..? I want to know too...
__________________
SPEED PASSION - King Golden, Speed Passion USA, Speed Power, Hirosaka Pro Products, East Coast Bodies, Schumacher Racing, Hurricane Motorsports, Serpent America, Sweep Racing USA. http://www.spautomobile.com/en/index.asp (SPEED PASSION AUTOMOTIVE)
NEW Speed Power/Speed Passion direct sale site - http://shop.speedpowerrc.com/
Solara is offline   Reply With Quote
Old 03-13-2013, 03:14 PM   #11319
Tech Champion
 
Solara's Avatar
 
Join Date: Sep 2002
Location: Chicago Illinois USA
Posts: 9,037
Trader Rating: 16 (100%+)
Send a message via ICQ to Solara Send a message via AIM to Solara
Default

Quote:
Originally Posted by akisole View Post
Every time i load a new software i recalibrate the speed.The timing in x20 is the lowest 4dot 27.5 the other is 30, 32.5, 35 and 37.5.
I will tell you exacly what it made me.
For the first 30 seconds the speed work in full throttle.after that when i keep the trhottle in 1/4 for 1 sec(entering a corner) and give all the thortle exiting the corner the car goes with 1/4 of thorthe.I dont have full thortle.When i leave and give again full thortle gives me 3/4.I work it like a nitro with playing all the time with trhottle to work.
I play
Drag Brake Force 15%
Low Voltage Cut-Off 3,4v/cell
"DDRS" Start Mode level 3
Maximum Reverse Force 50%
Initial Brake Force 0%
Neutral Range 6%(Narrow)
Turbo Open Time 12 deg/0.1sec
Boost Start RPM 9000rpm
Turbo Open Delay 0.2 sec
acc 750
I think you are running SENSORLESS mode after the full throttle....when you are running sensorless, you no timing, no boost..that explained the slow throttle with no top speed or boost...

It is sensor problem....either your sensor cable, or the sensor board inside the motor is bad....the last thing, the sensor port of the ESC is bad. Check all 3 items...
__________________
SPEED PASSION - King Golden, Speed Passion USA, Speed Power, Hirosaka Pro Products, East Coast Bodies, Schumacher Racing, Hurricane Motorsports, Serpent America, Sweep Racing USA. http://www.spautomobile.com/en/index.asp (SPEED PASSION AUTOMOTIVE)
NEW Speed Power/Speed Passion direct sale site - http://shop.speedpowerrc.com/
Solara is offline   Reply With Quote
Old 03-13-2013, 03:19 PM   #11320
Tech Champion
 
Solara's Avatar
 
Join Date: Sep 2002
Location: Chicago Illinois USA
Posts: 9,037
Trader Rating: 16 (100%+)
Send a message via ICQ to Solara Send a message via AIM to Solara
Default

Quote:
Originally Posted by EDWARD2003 View Post
Okay.... were in Japan can I purchase the greening timing board for MMM motors?
Tresrey.....

http://www.tresrey.com/
__________________
SPEED PASSION - King Golden, Speed Passion USA, Speed Power, Hirosaka Pro Products, East Coast Bodies, Schumacher Racing, Hurricane Motorsports, Serpent America, Sweep Racing USA. http://www.spautomobile.com/en/index.asp (SPEED PASSION AUTOMOTIVE)
NEW Speed Power/Speed Passion direct sale site - http://shop.speedpowerrc.com/
Solara is offline   Reply With Quote
Old 03-13-2013, 07:27 PM   #11321
Tech Adept
 
Andy w's Avatar
 
Join Date: Jul 2011
Location: utah
Posts: 236
Trader Rating: 7 (100%+)
Default

Quote:
Originally Posted by Solara View Post
May I know what booster you use..? I would LOVE to know that...cause I have this question asked so many times and I have no solution, until now...

When was your REVENTON S or R purchased..? I want to know too...

It is a R and used a old Novak Smartboost that I got 2nd hand. I also used a LiFe rx pack with it and it worked. It was paired with a Reedy Sonic 13.5. Everything worked as any 1s has worked for me in the past.

I bought it from the SP website on Oct. 12. At the time I used the firmware that it came with and have since loaded the stock0 firmware for my TC.

I know I didn't dream this and the only reason I switched the esc is I had a LRP SXX laying around and it made my chassis cleaner without all the extra wires and battery. When I can I will switch it back and see if it still works with the new firmware.
Andy w is offline   Reply With Quote
Old 03-13-2013, 08:20 PM   #11322
Tech Apprentice
 
Join Date: Sep 2012
Posts: 72
Default

Quote:
Originally Posted by coretex View Post
I have programmed my Reventon R to do forward/reverse. However I have a problem with it: It won't always do reverse. I pull back many times on the transmitter but nothing happens. It seems to do reverse sometimes but not always.

The strange thing is that the brake function always works fine, so there is nothing wrong with the signal...
Maybe re-calibration will solve the problem.
WMGary is offline   Reply With Quote
Old 03-14-2013, 09:16 AM   #11323
Tech Champion
 
Solara's Avatar
 
Join Date: Sep 2002
Location: Chicago Illinois USA
Posts: 9,037
Trader Rating: 16 (100%+)
Send a message via ICQ to Solara Send a message via AIM to Solara
Default

Quote:
Originally Posted by Andy w View Post
It is a R and used a old Novak Smartboost that I got 2nd hand. I also used a LiFe rx pack with it and it worked. It was paired with a Reedy Sonic 13.5. Everything worked as any 1s has worked for me in the past.

I bought it from the SP website on Oct. 12. At the time I used the firmware that it came with and have since loaded the stock0 firmware for my TC.

I know I didn't dream this and the only reason I switched the esc is I had a LRP SXX laying around and it made my chassis cleaner without all the extra wires and battery. When I can I will switch it back and see if it still works with the new firmware.
I am going to try that...thank you Andy.
__________________
SPEED PASSION - King Golden, Speed Passion USA, Speed Power, Hirosaka Pro Products, East Coast Bodies, Schumacher Racing, Hurricane Motorsports, Serpent America, Sweep Racing USA. http://www.spautomobile.com/en/index.asp (SPEED PASSION AUTOMOTIVE)
NEW Speed Power/Speed Passion direct sale site - http://shop.speedpowerrc.com/
Solara is offline   Reply With Quote
Old 03-14-2013, 06:15 PM   #11324
Tech Adept
 
askbob's Avatar
 
Join Date: Apr 2011
Posts: 213
Trader Rating: 27 (100%+)
Default

Finally got the Reventon S going in my buggy last night and the Wifi module working today. Very smooth control and the Wifi module is the cats a$$! I see that there isn't a 'hybrid boost' setting with the S model. Are there any future plans to incorporate this setting into the S model?
askbob is offline   Reply With Quote
Old 03-15-2013, 02:49 AM   #11325
Tech Rookie
 
Join Date: Jan 2011
Posts: 15
Default

when new software will be released?
Stock0 has serious cogging at low throttle
guru83 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speed Passion GT Competition Brushless ESC v2.0 Low Profile, LPF pink_sleeve Electric On-Road 13 07-08-2009 10:17 AM


Tags
gt2, lack of help, overpriced, poor customer service, reventon, reventon pro, speed passion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 05:21 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0