R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 02-03-2013, 12:35 PM   #11146
Tech Adept
 
Join Date: Sep 2012
Posts: 170
Default

slater333 there is no need for reverse as its race setup and u only go round one way and is against the rules to have to stops ppl going backwards into fast cars
__________________
if you have control your not pushing hard
all or nothing
tcboy1983 is offline   Reply With Quote
Old 02-03-2013, 12:43 PM   #11147
Tech Adept
 
Join Date: Sep 2012
Posts: 170
Default

The reventon stock club race is the replacement for the certix club race so unless u can find one still in stock u will have to upgrade

Also bishop I keep every release of a esc I have incase of problems so I can bk date firmwear so pm ur email wil mail u the release in it allows if not contact speed passion see if they will send u a older release
__________________
if you have control your not pushing hard
all or nothing
tcboy1983 is offline   Reply With Quote
Old 02-03-2013, 01:34 PM   #11148
Tech Master
 
TeamSkunkwerks's Avatar
R/C Tech Elite Subscriber
 
Join Date: May 2010
Location: Tennessee
Posts: 1,378
Trader Rating: 85 (100%+)
Unhappy

Quote:
Originally Posted by TeamSkunkwerks View Post
Bought a brand new Speed Passion Cirtix Club Stock direct from the company. I'm trying to run a Novak 17.5 Ballastic motor. I have tried NiCD & NIMH batteries (don't have a 2S LIPO....yet) as the instructions say the ESC will allow them.
Problem I'm having is that the red LED on the ESC keeps blinking, but nothing is happening with the motor. In one part of the instructions, it says the problem could be low battery voltage. Yet in another part, it says the red LED will blink continuously in normal use for this model only.
1. Batteries are fully charged.
2. Changed out sensor wire.
3. Removed sensor wire.
4. Calibrated the ESC.
5. Recalibrated the ESC.
6. Changed out sensor board on motor.
7. Changed out batteries & type of batteries (NICD & NIMH).
So, what else should I do/check? The wires on the motor are correct. A to A, B to B, & C to C. Sensor wire is hooked up, as the Novak requires it. I know the motor automatically senses whether you're running a sensored or sensorless motor.
Is it because I need to be running a 2S LIPO? Is the stator shot?
Is their a certain MaH required to power the ESC using different battery types? I'm currently using anywhere from 1500MaH-3300MaH.
Any help is greatly appreciated!!
Still trying to figure the ESC out......
__________________
I am highly paid by my sponsors not to mention their names. They give me stuff so I will go away.
TeamSkunkwerks is offline   Reply With Quote
Old 02-03-2013, 02:20 PM   #11149
Tech Addict
 
Dog Runner's Avatar
 
Join Date: Mar 2010
Location: Illinois
Posts: 599
Trader Rating: 15 (100%+)
Send a message via Skype™ to Dog Runner
Default Reventon Dead Space

I have a reventon pro that I'm using with a revtech 7.5 motor. Every 2 or 3 races, the ESC will quit for just 2 or 3 seconds. Then it's back to normal. Has this happened to anyone else?

This "dead space" happens at various voltage levels. It's happened on a fully charged pack, an almost empty pack, and anywhere in between. My lipo cutoff is set to 3.2v.

I haven't come to any conclusion as to why it quits because it can happen at any time (and has).

I have the wireless adapter and it should have the latest firmware (at least as of 1/28/13).

Any other thoughts on this?
__________________
JR
Need a real estate agent? I can help.
Dog Runner is offline   Reply With Quote
Old 02-03-2013, 02:42 PM   #11150
Tech Elite
 
Pattojnr's Avatar
 
Join Date: Apr 2006
Location: Perth Australia
Posts: 4,594
Trader Rating: 19 (100%+)
Default

i think there may be an issue. one of the guys at the track yesterday running the reventon, had the same issue all day. didnt matter, happened in warm up with fresh charged pack, middle of the race, and at the end. he went to the new software, he turned off all heat and voltage protection, yet it still lost boost and even cut out. i had no issues at all, all day. but i put in my GT-2.0 Pro for our hot day yesterday. the speedy was blinking the red light when his esc shut down with voltage protection off. nothing can be done about it now, as he threw out the speedy.
__________________
Serpent - Walter RC
Serpent E Power ..... Serpent 747 Reds M3T
Serpent 966-TE Reds M7T .... S411ERYX Speedpassion 3.5T, T-Shox
Serpent 811-TE REDs R5T
Pattojnr is offline   Reply With Quote
Old 02-03-2013, 04:18 PM   #11151
Tech Adept
 
Join Date: Sep 2012
Posts: 170
Default

the cutting out maybe due to the servo some servos draw 3.2amps and most esc only give out 3amps out of the bec to the Receivers and when this happens u get a 1-2 sec glitch where everything turns off as the Receivers doesnt have any power to run, can be worse on full lock and full power/full brakes this is when the esc on high load so the volts also some times drop below 6 volts on load

it has happened on savox and maybe worth using a power cap on the Receivers and spectrum hands sets are meant to suffer bad with savox also but run both and never had any trouble mayself touch wood

i have never had this problem but seen it lots hope this helps

Also turn off lipo cut off I never run my car longer then 5-6 min so it soulh be fine with out it
__________________
if you have control your not pushing hard
all or nothing

Last edited by tcboy1983; 02-03-2013 at 04:33 PM.
tcboy1983 is offline   Reply With Quote
Old 02-04-2013, 12:03 AM   #11152
Tech Master
 
samnelso's Avatar
 
Join Date: Aug 2011
Location: Fitchburg, MA
Posts: 1,751
Trader Rating: 1 (100%+)
Default

Quote:
Originally Posted by Solara View Post
Immediately change the capacitor (you can use any brand) and check all the wire connection and make sure they are not touching...I am suspecting you might got shorted somewhere on the ESC.
Thank you sir for the advice Turns out all I needed to do was turn off the speedo's thermal protection, even though it was only coming off in the 160F range w/o boost. She runs like a champ now.
__________________
Team Associated | Reedy | Airtronics

RC Excitement: Fitchburg, MA | RC Madness: Enfield, CT | Horsham RC
samnelso is offline   Reply With Quote
Old 02-04-2013, 12:13 AM   #11153
Tech Master
 
DaveG28's Avatar
 
Join Date: Dec 2008
Posts: 1,561
Trader Rating: 54 (100%+)
Default

Quote:
Originally Posted by samnelso View Post
Thank you sir for the advice Turns out all I needed to do was turn off the speedo's thermal protection, even though it was only coming off in the 160F range w/o boost. She runs like a champ now.
Did you change the capacitor or just shutoff temp protection?
__________________
Viper ESC's ~ Xpert Servo's ~ Sanwa Radio
DaveG28 is offline   Reply With Quote
Old 02-04-2013, 04:06 AM   #11154
Tech Elite
 
Pattojnr's Avatar
 
Join Date: Apr 2006
Location: Perth Australia
Posts: 4,594
Trader Rating: 19 (100%+)
Default

Quote:
Originally Posted by tcboy1983 View Post
the cutting out maybe due to the servo some servos draw 3.2amps and most esc only give out 3amps out of the bec to the Receivers and when this happens u get a 1-2 sec glitch where everything turns off as the Receivers doesnt have any power to run, can be worse on full lock and full power/full brakes this is when the esc on high load so the volts also some times drop below 6 volts on load

it has happened on savox and maybe worth using a power cap on the Receivers and spectrum hands sets are meant to suffer bad with savox also but run both and never had any trouble mayself touch wood

i have never had this problem but seen it lots hope this helps

Also turn off lipo cut off I never run my car longer then 5-6 min so it soulh be fine with out it
heat and voltage protection were turned off. and it still happened. my self i was running a full size servo, BLS 352 and my motor fan from the reciever , with my GT-2.0 pro. the reventon im guessing he used a digital Futaba low profile servo, and we changed software also. i normally run my motor fan from the battery , but lacked time as i built a new car and had it running just in time as it was. motor used was a 4.5T SP V3.
__________________
Serpent - Walter RC
Serpent E Power ..... Serpent 747 Reds M3T
Serpent 966-TE Reds M7T .... S411ERYX Speedpassion 3.5T, T-Shox
Serpent 811-TE REDs R5T
Pattojnr is offline   Reply With Quote
Old 02-04-2013, 10:16 AM   #11155
Tech Master
 
samnelso's Avatar
 
Join Date: Aug 2011
Location: Fitchburg, MA
Posts: 1,751
Trader Rating: 1 (100%+)
Default

Quote:
Originally Posted by DaveG28 View Post
Did you change the capacitor or just shutoff temp protection?
Did not change cap, just turned off temp protection.

Here's what I did:
1. visual/DMM check of cap and wiring and all looked good
2. flashed with buddy's stock0 software with known good settings - no improvement
3. turned off low voltage protection (orange light was blinking) - no improvement
4. cut motor temp wire on sensor wire (LRP x20 motor) - no improvement
5. turned off thermal protection - works perfect

temped speedo using box with the stock0 settings (no boost) and speedo was in the 160F range after a full run. Not sure why thermal protection would be kicking it off, but it seems to be within a reasonable operating temp so I'll keep it off and run with confidence. I've ran probably 20 or so packs since then with no issue.
__________________
Team Associated | Reedy | Airtronics

RC Excitement: Fitchburg, MA | RC Madness: Enfield, CT | Horsham RC
samnelso is offline   Reply With Quote
Old 02-05-2013, 12:13 AM   #11156
Tech Rookie
 
Join Date: Jan 2013
Posts: 18
Default

sirs what is the high end esc of SP? im planning on buying the reventon pro, is it worth buying? I want to invest on a long term esc that I can use in higher classes in the future
canon is offline   Reply With Quote
Old 02-05-2013, 10:45 AM   #11157
Tech Champion
 
Solara's Avatar
 
Join Date: Sep 2002
Location: Chicago Illinois USA
Posts: 9,039
Trader Rating: 16 (100%+)
Send a message via ICQ to Solara Send a message via AIM to Solara
Default

Quote:
Originally Posted by canon View Post
sirs what is the high end esc of SP? im planning on buying the reventon pro, is it worth buying? I want to invest on a long term esc that I can use in higher classes in the future
yes, Reventon PRO is the top of the line competition ESC from Speed Passion.
__________________
SPEED PASSION - King Golden, Speed Passion USA, Speed Power, Hirosaka Pro Products, East Coast Bodies, Schumacher Racing, Hurricane Motorsports, Serpent America, Sweep Racing USA. http://www.spautomobile.com/en/index.asp (SPEED PASSION AUTOMOTIVE)
NEW Speed Power/Speed Passion direct sale site - http://shop.speedpowerrc.com/
Solara is online now   Reply With Quote
Old 02-05-2013, 03:09 PM   #11158
Tech Addict
 
Lessen's Avatar
 
Join Date: Jan 2008
Location: Aurora, OH
Posts: 594
Trader Rating: 2 (100%+)
Send a message via MSN to Lessen
Default

Quote:
Originally Posted by SP CS View Post
Please PM me your RMA #. Thank you
Is anybody ever going to respond?

I've called that 800 number several times in the past month and nobody ever picks up. I leave messages and nobody returns my calls. I've emailed with no response. I've now sent 3 PM's to two members here whom I thought were associated with Speed Passion. Aside from the one time I spoke to somebody nearly a month ago, I've been completely blown off. Was this post simply a PR move? Does the fact that I forgot to write the RMA number on the outside of tht box entitle you to keep it? Am I going to continue to be blown off for another 30 days so you can call it "abandoned"? Up until this post I've been very polite, but even being backed up doesn't warrant this level of inadequate customer service.

Response? Anything?
__________________
"Nothing in the world can take the place of persistence. Talent will not; nothing is more common than unsuccessful men with talent. "
Lessen is offline   Reply With Quote
Old 02-05-2013, 10:12 PM   #11159
Tech Regular
 
Join Date: Nov 2010
Posts: 310
Default

i think the thermal protect is too conservative, also the low volt protect might be too quick to shut down. I dont know if it can be adjusted with future software updates but might be a good idea to revise them. perhaps both these should wait longer before shutting down.

i was running last weekend in about the hottest weather you would want to be out racing, and with the protections disabled had no trouble. with reventon pro, mmm 4.5T, savox servo and spectrum rec. also had motor fan from the reciever. quite advanced timing and speed was good.
external temps were about 75c on motor and esc (cool, considering the ambient temp)

i started in the morning with the protections enabled and didnt last 2min before shutting down.
jeff_78 is offline   Reply With Quote
Old 02-05-2013, 10:26 PM   #11160
Tech Fanatic
 
muahdib4's Avatar
 
Join Date: Nov 2006
Location: Raymore
Posts: 863
Send a message via Yahoo to muahdib4
Default

Alrighty, just installed my new reventon stock club with a Novak 25.5 ballistic. Followed all the setup instructions and I'm getting a flashing red light (solid orange) which the manual says means low voltage. I'm running a brand new, freshly charged Gens 5000mah 2c Lipo so that can't actually be an issue can it? It seems to run fine. Can I turn that off the voltage cutoff without the program card?
__________________
KCRC - Kansas City Remote Crawlers
Team Chucklenuts Racing
Midwest R/C Rally Confederation
KC/RC Drift Movement
muahdib4 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speed Passion GT Competition Brushless ESC v2.0 Low Profile, LPF pink_sleeve Electric On-Road 13 07-08-2009 10:17 AM


Tags
gt2, lack of help, overpriced, poor customer service, reventon, reventon pro, speed passion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 05:33 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0