R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 01-11-2013, 10:05 AM   #10966
Tech Champion
 
Solara's Avatar
 
Join Date: Sep 2002
Location: Chicago Illinois USA
Posts: 9,039
Trader Rating: 16 (100%+)
Send a message via ICQ to Solara Send a message via AIM to Solara
Default

New firmware released....V22

http://www.speedpassion.net/files/SP..._v1_1_0_22.zip

I strongly recommend everyone on UNINSTALL the old firmware and reinstall this new one. The new firmware has the best "recovery" base design that should take care most and all of the known "update error"....please take a look at the "Safe Mode User Guide" in order to access the "backdoor" if your ESC encounter any kinda update failure problem...
__________________
SPEED PASSION - King Golden, Speed Passion USA, Speed Power, Hirosaka Pro Products, East Coast Bodies, Schumacher Racing, Hurricane Motorsports, Serpent America, Sweep Racing USA. http://www.spautomobile.com/en/index.asp (SPEED PASSION AUTOMOTIVE)
NEW Speed Power/Speed Passion direct sale site - http://shop.speedpowerrc.com/
Solara is offline   Reply With Quote
Old 01-11-2013, 10:18 AM   #10967
Tech Champion
 
Solara's Avatar
 
Join Date: Sep 2002
Location: Chicago Illinois USA
Posts: 9,039
Trader Rating: 16 (100%+)
Send a message via ICQ to Solara Send a message via AIM to Solara
Default

Quote:
Originally Posted by alloyslash View Post
I got my SP Certix in from AMain today so I need some clarification. When you say 2nd wire from left, is that on the motor or looking at the ESC?
STOP....that cutoff problem only happened on REVENTON series ESC. Your ESc is Cirtix, you DO NOT need to do that...
__________________
SPEED PASSION - King Golden, Speed Passion USA, Speed Power, Hirosaka Pro Products, East Coast Bodies, Schumacher Racing, Hurricane Motorsports, Serpent America, Sweep Racing USA. http://www.spautomobile.com/en/index.asp (SPEED PASSION AUTOMOTIVE)
NEW Speed Power/Speed Passion direct sale site - http://shop.speedpowerrc.com/
Solara is offline   Reply With Quote
Old 01-11-2013, 10:19 AM   #10968
Tech Champion
 
Solara's Avatar
 
Join Date: Sep 2002
Location: Chicago Illinois USA
Posts: 9,039
Trader Rating: 16 (100%+)
Send a message via ICQ to Solara Send a message via AIM to Solara
Default

Quote:
Originally Posted by rimracker View Post
Solara PM
Did I answered your PM...? If not...I did not receive your PM, please send again...

Quote:
Originally Posted by X men View Post
Solara, please check pm...Thanks!!
Did I answered your PM...? If not...I did not receive your PM, please send again...
__________________
SPEED PASSION - King Golden, Speed Passion USA, Speed Power, Hirosaka Pro Products, East Coast Bodies, Schumacher Racing, Hurricane Motorsports, Serpent America, Sweep Racing USA. http://www.spautomobile.com/en/index.asp (SPEED PASSION AUTOMOTIVE)
NEW Speed Power/Speed Passion direct sale site - http://shop.speedpowerrc.com/
Solara is offline   Reply With Quote
Old 01-11-2013, 11:57 AM   #10969
Tech Champion
 
Join Date: Nov 2002
Location: Chicago, IL
Posts: 7,462
Trader Rating: 34 (100%+)
Default

There is a new fan and customer driven website www.teamspeedpassion.com. There are a few pictures in the media gallery with the exact cars you guys mention.



It's a great site for finding pictures of SP products in specific cars, reviews, etc. Take a peek You can even submit pictures and your own local race results.
Nexus is offline   Reply With Quote
Old 01-11-2013, 12:06 PM   #10970
Tech Apprentice
 
Join Date: May 2009
Location: London
Posts: 83
Default

Quote:
Originally Posted by Solara View Post
New firmware released....V22

http://www.speedpassion.net/files/SP..._v1_1_0_22.zip

I strongly recommend everyone on UNINSTALL the old firmware and reinstall this new one. The new firmware has the best "recovery" base design that should take care most and all of the known "update error"....please take a look at the "Safe Mode User Guide" in order to access the "backdoor" if your ESC encounter any kinda update failure problem...
It says that it is new software for pc and usb. It doesn't say v22 firmware for reventon pro it says v20 release for stock and mod. Is this a misprint? Will this new program sort out the lack of power for 13.5's?
RSCosworth is offline   Reply With Quote
Old 01-11-2013, 12:17 PM   #10971
Tech Master
 
PitNamedGordie's Avatar
 
Join Date: Nov 2003
Location: Highwood, IL
Posts: 1,788
Trader Rating: 8 (100%+)
Send a message via AIM to PitNamedGordie Send a message via Yahoo to PitNamedGordie
Thumbs up

Quote:
Originally Posted by Nexus View Post
There is a new fan and customer driven website www.teamspeedpassion.com. There are a few pictures in the media gallery with the exact cars you guys mention.



It's a great site for finding pictures of SP products in specific cars, reviews, etc. Take a peek You can even submit pictures and your own local race results.
Nice!
__________________
☆ The Track @ Harbor Hobbies ☆ www.harbor-hobby.net ☆
PitNamedGordie is offline   Reply With Quote
Old 01-11-2013, 02:37 PM   #10972
Tech Initiate
 
Join Date: Apr 2012
Posts: 25
Default

Quote:
Originally Posted by Solara View Post
New firmware released....V22

http://www.speedpassion.net/files/SP..._v1_1_0_22.zip

I strongly recommend everyone on UNINSTALL the old firmware and reinstall this new one. The new firmware has the best "recovery" base design that should take care most and all of the known "update error"....please take a look at the "Safe Mode User Guide" in order to access the "backdoor" if your ESC encounter any kinda update failure problem...
Windows 8 ready or i have to run it in Win7 compatibility mode ?
Akita is offline   Reply With Quote
Old 01-12-2013, 06:34 AM   #10973
Tech Initiate
 
Join Date: Sep 2012
Posts: 40
Trader Rating: 1 (100%+)
Default

Quote:
Originally Posted by 76Trans Am View Post
Hi,
I received the Reventon pro and have it in the car. I raced the last 2 weekends and love the punch and braking power. However after a 5 min heat race when I stop the car. The ESC is turning itself off. I also had it shut itself off when I had crashed near the end of a heat and was waiting to be marshaled. I am running 21.5 Blinky. The lipo cut off is turned off as well as the temp cut off. I also added the fan to see if it would help but it does not.
Any ideas ? LMK Thank you.
Just tried my brand new Reventon Pro tonight at a club meet, I'm getting the EXACT same problem. Happens after a 6min race, ESC temp was 42 degrees (c) and when you turn it back on it starts repeatedly beeping with no throttle response.
I'm running the Stock0 blinky firmware that I downloaded to it from the latest software release, I'm wondering if that's something to do with it as a mate at the track has one and he didn't update and doesn't have that problem.

Lipo cutoff is off but when I change to a fresh pack the speedy operates fine so I'm confused as hell. I'm running 21.5 blinky and it doesn't use more than 3000mAh of a 6600mAh pack so I find it hard to believe it something battery related.

Couldn't find a reply to TransAm's question, is anyone else getting this problem too?

edit: i found some replies saying its incompatibility with some motors which imo is shit! I'm using a LRP x12 21.5 I'm going to order a SP 21.5 to test this theory (need a spare motor anyway).

Last edited by ript; 01-12-2013 at 06:51 AM.
ript is offline   Reply With Quote
Old 01-12-2013, 12:12 PM   #10974
Tech Initiate
 
Join Date: Aug 2008
Posts: 21
Default

Quote:
Originally Posted by ript View Post
Just tried my brand new Reventon Pro tonight at a club meet, I'm getting the EXACT same problem. Happens after a 6min race, ESC temp was 42 degrees (c) and when you turn it back on it starts repeatedly beeping with no throttle response.
I'm running the Stock0 blinky firmware that I downloaded to it from the latest software release, I'm wondering if that's something to do with it as a mate at the track has one and he didn't update and doesn't have that problem.

Lipo cutoff is off but when I change to a fresh pack the speedy operates fine so I'm confused as hell. I'm running 21.5 blinky and it doesn't use more than 3000mAh of a 6600mAh pack so I find it hard to believe it something battery related.

Couldn't find a reply to TransAm's question, is anyone else getting this problem too?

edit: i found some replies saying its incompatibility with some motors which imo is shit! I'm using a LRP x12 21.5 I'm going to order a SP 21.5 to test this theory (need a spare motor anyway).
I've got the same issue with my Reventon Pro, using a Vampire Type AB+ motor. We were just speculating that it was a motor compatibility issue, but no confirmation from the guys at Speed Passion yet. Would be nice to hear their views on the problem...
rosey1990 is offline   Reply With Quote
Old 01-12-2013, 01:21 PM   #10975
Tech Fanatic
 
roger999's Avatar
R/C Tech Elite Subscriber
 
Join Date: Aug 2010
Posts: 805
Trader Rating: 12 (100%+)
Default

Quote:
Originally Posted by ript View Post
Just tried my brand new Reventon Pro tonight at a club meet, I'm getting the EXACT same problem. Happens after a 6min race, ESC temp was 42 degrees (c) and when you turn it back on it starts repeatedly beeping with no throttle response.
I'm running the Stock0 blinky firmware that I downloaded to it from the latest software release, I'm wondering if that's something to do with it as a mate at the track has one and he didn't update and doesn't have that problem.

Lipo cutoff is off but when I change to a fresh pack the speedy operates fine so I'm confused as hell. I'm running 21.5 blinky and it doesn't use more than 3000mAh of a 6600mAh pack so I find it hard to believe it something battery related.

Couldn't find a reply to TransAm's question, is anyone else getting this problem too?

edit: i found some replies saying its incompatibility with some motors which imo is shit! I'm using a LRP x12 21.5 I'm going to order a SP 21.5 to test this theory (need a spare motor anyway).
Yeah, it doesnt work with LRP motors. Unfortunately i had to sell my LRP motors. Tested with SP 10.5 and no issue, now got new Thunder Power and wondering how that one will run.
__________________
r o g e r g r a f i x . c o m

facebook.com/rogergrafix
roger999 is offline   Reply With Quote
Old 01-12-2013, 01:36 PM   #10976
Tech Apprentice
 
Join Date: Oct 2012
Posts: 70
Default

Quote:
Originally Posted by ript View Post
Just tried my brand new Reventon Pro tonight at a club meet, I'm getting the EXACT same problem. Happens after a 6min race, ESC temp was 42 degrees (c) and when you turn it back on it starts repeatedly beeping with no throttle response.
I'm running the Stock0 blinky firmware that I downloaded to it from the latest software release, I'm wondering if that's something to do with it as a mate at the track has one and he didn't update and doesn't have that problem.

Lipo cutoff is off but when I change to a fresh pack the speedy operates fine so I'm confused as hell. I'm running 21.5 blinky and it doesn't use more than 3000mAh of a 6600mAh pack so I find it hard to believe it something battery related.

Couldn't find a reply to TransAm's question, is anyone else getting this problem too?

edit: i found some replies saying its incompatibility with some motors which imo is shit! I'm using a LRP x12 21.5 I'm going to order a SP 21.5 to test this theory (need a spare motor anyway).
I would need to verify and research, but it might be the LRP motor has internal sensors. If this is the case, disabling the 2nd wire on the sensor cable could potentially solve your problem.

You could try (carefully) removing the second wire pin from the sensor connector and run your car.
SP Tech is offline   Reply With Quote
Old 01-12-2013, 01:42 PM   #10977
Tech Addict
 
Join Date: Jun 2002
Posts: 515
Talking

Quote:
Originally Posted by SP Tech View Post
I would need to verify and research, but it might be the LRP motor has internal sensors. If this is the case, disabling the 2nd wire on the sensor cable could potentially solve your problem.

You could try (carefully) removing the second wire pin from the sensor connector and run your car.
i have verified this, from Solara, and others... the Tekin V-2 motors, my Tekin V-1 17.5 motors, and some Novack motors need to have the 2nd wire from the left (as you look at the motor) either cut or removed to work properly...

But, they do work very well..... I love my Reventon Pro
gdcopbdcop is offline   Reply With Quote
Old 01-12-2013, 06:51 PM   #10978
Tech Elite
 
Bishop's Avatar
 
Join Date: May 2004
Location: Brisbane
Posts: 2,208
Trader Rating: 5 (100%+)
Default

It's starting to look easier to list motors that do work with the Pro than what does not...

I can say my Thunder Power (10.5T) has been working just fine with mine.
__________________
QRCCRA
www.qrccra.org.au
www.facebook.com/englandparkraceway
www.myrcm.ch/main?pLa=en&hId[1]=org&dId[O]=4331
Bishop is offline   Reply With Quote
Old 01-12-2013, 09:47 PM   #10979
Tech Initiate
 
Join Date: Sep 2012
Posts: 40
Trader Rating: 1 (100%+)
Default

Yup +1 for Thunderpowers working fine, mate was running the 17.5 without any problems at all.
ript is offline   Reply With Quote
Old 01-13-2013, 02:56 AM   #10980
Tech Initiate
 
Join Date: Aug 2008
Posts: 21
Default

Yes, it would definitely seem that this motor 'compatibility' issue is more widespread than first thought. So far then, here are a list of known motors to have the problem, where the ESC will just switch itself off, when the car is stopped at/or towards the end of a race:

Viper
Vampire Type AB+
Hobbywing
LRP X12
Novak
Tekin V-1 and V-2?

Are the other speedo manufacturers having this same compatibility issue? Although it is a relatively easy fix to cut the 2nd wire on the sensor cable, it shouldn't really be necessary. Are Speed Passion looking into a more user friendly solution?
rosey1990 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speed Passion GT Competition Brushless ESC v2.0 Low Profile, LPF pink_sleeve Electric On-Road 13 07-08-2009 10:17 AM


Tags
gt2, lack of help, overpriced, poor customer service, reventon, reventon pro, speed passion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 05:33 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0