R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 11-21-2012, 12:27 AM   #10726
Tech Initiate
 
Join Date: Jul 2012
Posts: 23
Exclamation Any Reventon Pro Capacitor Issues?

Just wondering if anyone has had issues with the new style capacitor that currently ships with the Reventon Pro. I had one cook off and puff on the bench a few minutes after being connected for the first time. All wiring was correct and clean. The new style capacitor has a circuit board on the end. I just sizzled on its own. Luckily I heard it sizzle and was sitting right in front of it. I had just finished calibrating the ESC to my radio and was about to take it out for a quick test run. I immediately unplugged the battery. The sizzling stopped after about 5 seconds but not before spewing capacitor juice into my chassis. I called Speed Passion Tech support. They were great (thanks Albert!). They told me to try another capacitor and see if everything else is still ok. I cut off the puffed capacitor and spliced in a new capacitor from my Reventon R kit. It's the older production type capacitor that is just a wired capacitor (no small PCB on end). Everything seems perfect now. I babysat it for 30 minutes to make sure it was stable (no smoke, yay!). Ran the car for about 10 minutes and all seems fine. It looks like the factory may have soldered the red/black wires into the PCB in reverse or a component on the small PCB failed. Anyone know what the differences or reason between the new and old Capacitors? Anyone else have any issues with the new Capacitor? Glad I didn't walk away.....never leave your LiPo's connected!
OferS is offline   Reply With Quote
Old 11-21-2012, 02:35 AM   #10727
Tech Adept
 
Join Date: Aug 2010
Posts: 181
Default

Quote:
Originally Posted by Fuzzi0n View Post
Did you update the LCD card to v2.5?
Yep, it's on 2.5
dvaid852456 is offline   Reply With Quote
Old 11-21-2012, 12:11 PM   #10728
Tech Master
 
YoDog's Avatar
 
Join Date: Aug 2006
Location: Lompoc, Ca.
Posts: 1,590
Trader Rating: 25 (100%+)
Default

Quote:
Originally Posted by draggerdude View Post
So I just picked up a SP V1.1 used of course, and found it is missing the capacitor. Can anyone tell me which one it is.
This is the one you want but they are currently out of stock.
http://www.speedpassion.net/us/produ...8802-C01&c=OPT
YoDog is offline   Reply With Quote
Old 11-21-2012, 02:50 PM   #10729
Tech Elite
 
vr6cj's Avatar
 
Join Date: Jul 2008
Location: Modesto, CA
Posts: 4,030
Trader Rating: 124 (100%+)
Default

Quote:
Originally Posted by vr6cj View Post
Yes, mine does says its a R, wow and its a Pro

How'd u fix it?
Thanks to Solara and Penz316 we got my esc working. So mine didnt want to turn off and calibrate plus it thought it was a R.

Simple fix was that my SP reventon download didnt contain a spg file. Pm Solara if you have this issue. He'll give you the fix.
vr6cj is offline   Reply With Quote
Old 11-21-2012, 02:52 PM   #10730
Tech Initiate
 
Join Date: Mar 2008
Posts: 47
Default

Quote:
Originally Posted by dvaid852456 View Post
Yep, it's on 2.5
I have the same question is this the lastest one??
On update firmware i have:
sto1 V19-5711
modify 1 v20-dfa8
modify 0 v20-dfc7

I cant download reventon smart led/lcd program user gives me error.
So for the MMM4.5 the stock 1 v19-5711 is the lastest?
Regards,
kavajas is offline   Reply With Quote
Old 11-21-2012, 08:36 PM   #10731
Tech Regular
 
draggerdude's Avatar
 
Join Date: Aug 2011
Location: NE Dungeon
Posts: 419
Default

Quote:
Originally Posted by YoDog View Post
This is the one you want but they are currently out of stock.
http://www.speedpassion.net/us/produ...8802-C01&c=OPT
That's what I thought, thanks.
__________________
Curtis (Sponsered by Anderson Racing)
Karz-Track Crew/ Rcgears - VP /Carcar
Always willing to play!
M05/06 Mini/TC5 VTA/12th CRC Carpetknife
1/8 Z-car/XXX-SCT/B4 buggy/8-t Truggy/E-Maxx MT/Diablo Rock Crawler
draggerdude is offline   Reply With Quote
Old 11-22-2012, 03:46 AM   #10732
Tech Apprentice
 
Penz316's Avatar
 
Join Date: Nov 2011
Location: Montréal, Québec
Posts: 94
Default

Quote:
Originally Posted by vr6cj View Post
Thanks to Solara and Penz316 we got my esc working. So mine didnt want to turn off and calibrate plus it thought it was a R.

Simple fix was that my SP reventon download didnt contain a spg file. Pm Solara if you have this issue. He'll give you the fix.
I'm glad that your Reventon is back on track.
__________________
Alex Fournier
Team ORCA
Penz316 is offline   Reply With Quote
Old 11-22-2012, 11:13 AM   #10733
Tech Apprentice
 
Join Date: May 2009
Location: London
Posts: 83
Default

I'm sorry to be an a***hole but the pro just aint good enough with a 13.5 which is the most popular class in the UK. Compared to the previous model, the GT2.1, the pro isn't quick enough out of corners or down the straight. It just lacks the rawness that the Gt2.1 had. It's to flat. Is this something that the speedpassion progammers can work on?
RSCosworth is offline   Reply With Quote
Old 11-22-2012, 11:57 AM   #10734
Tech Elite
 
vr6cj's Avatar
 
Join Date: Jul 2008
Location: Modesto, CA
Posts: 4,030
Trader Rating: 124 (100%+)
Default

Quote:
Originally Posted by RSCosworth View Post
I'm sorry to be an a***hole but the pro just aint good enough with a 13.5 which is the most popular class in the UK. Compared to the previous model, the GT2.1, the pro isn't quick enough out of corners or down the straight. It just lacks the rawness that the Gt2.1 had. It's to flat. Is this something that the speedpassion progammers can work on?
Hmm, I havent tried my Pro with a 13.5 yet. Cause I do have the gt2.1 running my SCT with a 13.5 and it hauls ass period. Maybbe I'll throw the 13.5 in the pro and see.
vr6cj is offline   Reply With Quote
Old 11-22-2012, 01:08 PM   #10735
Tech Champion
 
skypilot's Avatar
 
Join Date: Mar 2007
Posts: 9,488
Trader Rating: 14 (100%+)
Default

13.5 SCT and 13.5 SEDAN to completely different animals, can't compare the two
__________________
#49, #25a, #91, #7, #12 the ones to watch.... UPDATE. #12 is your new AMA GNC #1

A Northwest Team of Positive actions
skypilot is offline   Reply With Quote
Old 11-22-2012, 09:59 PM   #10736
Tech Initiate
 
Join Date: Jul 2012
Posts: 23
Default

Quote:
Originally Posted by OferS View Post
Just wondering if anyone has had issues with the new style capacitor that currently ships with the Reventon Pro. I had one cook off and puff on the bench a few minutes after being connected for the first time. All wiring was correct and clean. The new style capacitor has a circuit board on the end. I just sizzled on its own. Luckily I heard it sizzle and was sitting right in front of it. I had just finished calibrating the ESC to my radio and was about to take it out for a quick test run. I immediately unplugged the battery. The sizzling stopped after about 5 seconds but not before spewing capacitor juice into my chassis. I called Speed Passion Tech support. They were great (thanks Albert!). They told me to try another capacitor and see if everything else is still ok. I cut off the puffed capacitor and spliced in a new capacitor from my Reventon R kit. It's the older production type capacitor that is just a wired capacitor (no small PCB on end). Everything seems perfect now. I babysat it for 30 minutes to make sure it was stable (no smoke, yay!). Ran the car for about 10 minutes and all seems fine. It looks like the factory may have soldered the red/black wires into the PCB in reverse or a component on the small PCB failed. Anyone know what the differences or reason between the new and old Capacitors? Anyone else have any issues with the new Capacitor? Glad I didn't walk away.....never leave your LiPo's connected!
Raced it yesterday and had no issues. Had very good feel compared to my other "major" brand speedo.
OferS is offline   Reply With Quote
Old 11-23-2012, 06:43 AM   #10737
Tech Initiate
 
Join Date: Aug 2008
Posts: 21
Default

Quote:
Originally Posted by RSCosworth View Post
I'm sorry to be an a***hole but the pro just aint good enough with a 13.5 which is the most popular class in the UK. Compared to the previous model, the GT2.1, the pro isn't quick enough out of corners or down the straight. It just lacks the rawness that the Gt2.1 had. It's to flat. Is this something that the speedpassion progammers can work on?
I have to agree with this. Even after playing around with the settings, it didn't seem to make an ounce of difference to performance. I also came from the GT2.1 ProStock running 13.5 boosted, and compared with that speedo, the Reventon Pro has no acceleration and no top end.
rosey1990 is offline   Reply With Quote
Old 11-23-2012, 07:12 AM   #10738
Super Moderator
 
Marcos.J's Avatar
R/C Tech Elite Subscriber
 
Join Date: Sep 2003
Location: Semper Fi
Posts: 25,177
Trader Rating: 140 (100%+)
Default

Quote:
Originally Posted by rosey1990 View Post
I have to agree with this. Even after playing around with the settings, it didn't seem to make an ounce of difference to performance. I also came from the GT2.1 ProStock running 13.5 boosted, and compared with that speedo, the Reventon Pro has no acceleration and no top end.
Really , what motor are you using ? What setings? I have going out the opposite mine has plenty of acceleration and top end
Marcos.J is offline   Reply With Quote
Old 11-23-2012, 07:38 AM   #10739
Tech Apprentice
 
Join Date: May 2009
Location: London
Posts: 83
Default

Quote:
Originally Posted by rosey1990 View Post
I have to agree with this. Even after playing around with the settings, it didn't seem to make an ounce of difference to performance. I also came from the GT2.1 ProStock running 13.5 boosted, and compared with that speedo, the Reventon Pro has no acceleration and no top end.
I'm using an mmm13.5. I tried the recommend settings and team driver settings. It was still too slow.
RSCosworth is offline   Reply With Quote
Old 11-23-2012, 07:41 AM   #10740
Tech Initiate
 
Join Date: Aug 2008
Posts: 21
Default

Quote:
Originally Posted by Marcos.J View Post
Really , what motor are you using ? What setings? I have going out the opposite mine has plenty of acceleration and top end
Using a Reedy Sonic 13.5, FDR 6.5, 24deg endbell timing, on a medium/large indoor carpet track. ESC settings:

DRRS: Level 8
Hybrid Boost Power: 90%
Hybrid Boost Max: 135K
Hybrid Boost Start RPM: 5000RPM
Hybrid Boost Delay: 0.1s
rosey1990 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speed Passion GT Competition Brushless ESC v2.0 Low Profile, LPF pink_sleeve Electric On-Road 13 07-08-2009 10:17 AM


Tags
gt2, lack of help, overpriced, poor customer service, reventon, reventon pro, speed passion


Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 12:51 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0