R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 10-20-2012, 04:45 AM   #10366
Tech Adept
 
Join Date: Sep 2012
Posts: 170
Default

i ran the r with a 13.5t and there wasnt much speed difference if any but i am still playing with it and hope the 13.5t softwear helps also
tcboy1983 is offline   Reply With Quote
Old 10-20-2012, 10:51 AM   #10367
Tech Adept
 
NewWestF1's Avatar
 
Join Date: Jul 2012
Location: Vancouver, BC
Posts: 173
Trader Rating: 5 (100%+)
Default

So beings novice driver I probably don't need hybrid or turbo boosts. Just want to make sure that the updating the esc won't fubar its performance. If you feel like ditching the Wifi let me know, it would make firmware updates easier for me as I'm a Mac guy.


Quote:
Originally Posted by Bumpy View Post
Both of you should have read the specifications on the Speed Passion website or asked on here before buying the Reventon S esc's. They do not support Hybrid boost or any turbo functions. They are more suited to blinky classes. Only the Pro and R support Hybrid boost settings. The Wifi module is a good idea but I feel its more of a gimmicky thing really. I bought one but have never used it so far. The LCD box is just as easy to plug in and change settings with. Also, the Hybrid boost profiles are in the final stages of testing for 10.5-21.5 and are due to be released very soon according to SP.
__________________
.. Sakura FGX; Novak power plant, Exotek, Lotus/Renault #9 ..
.. TB-03 Calsonic GT-R . reventon s/ultra v.3 power plant . yeah racing ..
.. M-05 Mini Cooper, Silver Can 104BK speedo, fakkin' cute!

...one of these days, life will get easier...
NewWestF1 is offline   Reply With Quote
Old 10-20-2012, 04:56 PM   #10368
Tech Addict
 
Join Date: Nov 2003
Location: Brisbane
Posts: 564
Trader Rating: 17 (100%+)
Default

Has anyone succesfully run hybrid boost with a low turn motor - around 4.5T?

It ran great with a 6.5 with motor temps and esc temps around 60 deg c. But when i ran a 4.5T and 4T it would cog and was like hitting an invisible brick wall down the back straight and boost/turbo wouldnt kick in. Motor and esc temps got very hot!

running latest available software.

help please! I have a very big race coming up and would really like to run this esc
Thanks!
poop is offline   Reply With Quote
Old 10-20-2012, 07:18 PM   #10369
Tech Fanatic
 
bigtez's Avatar
 
Join Date: Jan 2005
Location: North BrisVegas QLD
Posts: 804
Trader Rating: 6 (100%+)
Default

Would that big race be the Nats at Logan Poop?

I am in a similar situation. I have entered stock, but won't be able to race if the boosted 13.5-21.5 software isn't out in time.
bigtez is online now   Reply With Quote
Old 10-20-2012, 07:18 PM   #10370
Tech Fanatic
 
bigtez's Avatar
 
Join Date: Jan 2005
Location: North BrisVegas QLD
Posts: 804
Trader Rating: 6 (100%+)
Default

Double Post
bigtez is online now   Reply With Quote
Old 10-20-2012, 08:54 PM   #10371
Tech Addict
 
Join Date: Nov 2003
Location: Brisbane
Posts: 564
Trader Rating: 17 (100%+)
Default

yup for the nats.
i hope a firmware update will fix my problem or if no one else has an issue, maybe it's just me and my usual luck with electronics.
I was running very conservative settings too:

Dualsky Z5 4.0
Lowest end bell timing 7*
DRRS 4
Hybrid 30%
150K
start 8000rpm
0.2 delay
FDR 8.8
poop is offline   Reply With Quote
Old 10-21-2012, 01:19 AM   #10372
Tech Regular
 
Tunatsol's Avatar
 
Join Date: Apr 2009
Location: Florida
Posts: 253
Trader Rating: 2 (100%+)
Default

Ok so just got my Reventon r in. Put new software on the LED and plugged my esc in. I see that under the hybrid boost drop down there is 11.5 to 25.5 the question is are they safe to use?
__________________
Josh Youngs
Team Durango: DNX8, Dex8, 408, 210, 410v3,
Sponsored By: Dialed Hobbies
Tunatsol is offline   Reply With Quote
Old 10-21-2012, 01:55 AM   #10373
Tech Regular
 
Timbo99's Avatar
 
Join Date: Mar 2010
Location: Melbourne AUSTRALIA
Posts: 385
Trader Rating: 14 (94%+)
Send a message via ICQ to Timbo99 Send a message via AIM to Timbo99 Send a message via MSN to Timbo99 Send a message via Skype™ to Timbo99
Default

Quote:
Originally Posted by poop View Post
yup for the nats.
i hope a firmware update will fix my problem or if no one else has an issue, maybe it's just me and my usual luck with electronics.
I was running very conservative settings too:

Dualsky Z5 4.0
Lowest end bell timing 7*
DRRS 4
Hybrid 30%
150K
start 8000rpm
0.2 delay
FDR 8.8
Check post 10145 and 10157,need to lay your fan on the side,worth 20 degrees less for the esc.
See post and check the pic.
Hope this helps.
__________________
Serpent ERYX/S411 Le#189,#024,TE/Airtronics/MuchMore FLETA 4/Ryan Dezign-
"The finest RC paintwork in Australia"/LEESPEED/Ame T-Shox/THiNK Carbon.
"If at first you don't succeed,.....tell'em it's the "Beta" 1.0 version"
Timbo99 is offline   Reply With Quote
Old 10-21-2012, 02:01 AM   #10374
Tech Regular
 
Timbo99's Avatar
 
Join Date: Mar 2010
Location: Melbourne AUSTRALIA
Posts: 385
Trader Rating: 14 (94%+)
Send a message via ICQ to Timbo99 Send a message via AIM to Timbo99 Send a message via MSN to Timbo99 Send a message via Skype™ to Timbo99
Default ROAR Approval

Hey,this goes out to Howard and the SP Techs,as we have our national titles next weekend,has this Reventon Pro AND the software been approved yet?
Just wondering..........
Need to know V.Soon guys,
Thanks in advance,
Tim
__________________
Serpent ERYX/S411 Le#189,#024,TE/Airtronics/MuchMore FLETA 4/Ryan Dezign-
"The finest RC paintwork in Australia"/LEESPEED/Ame T-Shox/THiNK Carbon.
"If at first you don't succeed,.....tell'em it's the "Beta" 1.0 version"
Timbo99 is offline   Reply With Quote
Old 10-21-2012, 05:26 AM   #10375
Tech Addict
 
Join Date: Sep 2011
Location: Sydney
Posts: 611
Trader Rating: 7 (100%+)
Default

Does the MMM motor come with 12.5mm or 12.3mm rotor for stock and 21.5?

what about the V3 (non MMM)
zzztech is offline   Reply With Quote
Old 10-21-2012, 06:53 AM   #10376
Tech Adept
 
Join Date: Jan 2012
Location: concord ca.
Posts: 230
Default

Anyone using the Reventon with a Thunder Power motor?
ems
Eric Summers is offline   Reply With Quote
Old 10-21-2012, 07:25 AM   #10377
Super Moderator
 
Marcos.J's Avatar
R/C Tech Elite Subscriber
 
Join Date: Sep 2003
Location: Semper Fi
Posts: 25,177
Trader Rating: 140 (100%+)
Default

Quote:
Originally Posted by poop View Post
Has anyone succesfully run hybrid boost with a low turn motor - around 4.5T?

It ran great with a 6.5 with motor temps and esc temps around 60 deg c. But when i ran a 4.5T and 4T it would cog and was like hitting an invisible brick wall down the back straight and boost/turbo wouldnt kick in. Motor and esc temps got very hot!

running latest available software.

help please! I have a very big race coming up and would really like to run this esc
Thanks!
Yes my set up is posted a page back or so

Been testing the v19 with a sp10.5 and is ballistic feels like my 4.5 in blinky mode. Smooth power not alot of wheel spin. So far at a medium asphalt track with 100% boost fdr at 5.10. Temps after 6 minutes about 136 degrees.
Marcos.J is offline   Reply With Quote
Old 10-21-2012, 07:34 AM   #10378
Super Moderator
 
Marcos.J's Avatar
R/C Tech Elite Subscriber
 
Join Date: Sep 2003
Location: Semper Fi
Posts: 25,177
Trader Rating: 140 (100%+)
Default

Here is my 10.5 set up so far



With a 4400 mah shorty pack after 6 minutes only used about 1980 mah
Marcos.J is offline   Reply With Quote
Old 10-21-2012, 07:42 AM   #10379
Tech Rookie
 
Join Date: May 2011
Location: Finland
Posts: 3
Default

Hi,

Is there any reset or similar on Reventon R's LED-programg card? I was updating firmware again to 1.3 and sw installation froze about 18%. Now I don't have any leds on it and I can't update card's firmware with Reventon sw.

This same card might have something wrong because I have updated it several times but never managed to modify esc's settings without PC. It still works with PC, but none of leds aren't on. The card is black version which came with the first patch of Reventon R
unkka is offline   Reply With Quote
Old 10-21-2012, 07:48 AM   #10380
Tech Apprentice
 
Join Date: May 2009
Location: London
Posts: 83
Default

Quote:
Originally Posted by Marcos.J View Post
Here is my 10.5 set up so far



With a 4400 mah shorty pack after 6 minutes only used about 1980 mah
V19?
RSCosworth is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speed Passion GT Competition Brushless ESC v2.0 Low Profile, LPF pink_sleeve Electric On-Road 13 07-08-2009 10:17 AM


Tags
gt2, lack of help, overpriced, poor customer service, reventon, reventon pro, speed passion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 05:38 AM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0