R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 02-21-2011, 04:36 PM   #6601
Tech Master
 
mr crum's Avatar
 
Join Date: May 2008
Location: tampa florida 813
Posts: 1,591
Trader Rating: 5 (100%+)
Send a message via Yahoo to mr crum
Default

Quote:
Originally Posted by ChefDementia View Post
Tried a new sensor wire this weekend and the problem is still there.
then it has to be software issue does anybody local to u with the program lcd box
__________________
SPEED PASSION TEAM DRIVER
ADAB RACING FACTORY PILOT
WWW.ADRENALINERACEWAY.COM
FL INDOOR R/C COMPLEX
TEAM B.R. RACING
mr crum is offline   Reply With Quote
Old 02-21-2011, 04:56 PM   #6602
Tech Regular
 
ChefDementia's Avatar
 
Join Date: Dec 2008
Posts: 408
Trader Rating: 19 (100%+)
Default

Quote:
Originally Posted by mr crum View Post
then it has to be software issue does anybody local to u with the program lcd box
Got a hold of one today, what software should I put on the esc?
ChefDementia is offline   Reply With Quote
Old 02-21-2011, 07:52 PM   #6603
Tech Master
 
mr crum's Avatar
 
Join Date: May 2008
Location: tampa florida 813
Posts: 1,591
Trader Rating: 5 (100%+)
Send a message via Yahoo to mr crum
Default

Quote:
Originally Posted by ChefDementia View Post
Got a hold of one today, what software should I put on the esc?
what are you running car, motor, class ect.
__________________
SPEED PASSION TEAM DRIVER
ADAB RACING FACTORY PILOT
WWW.ADRENALINERACEWAY.COM
FL INDOOR R/C COMPLEX
TEAM B.R. RACING
mr crum is offline   Reply With Quote
Old 02-22-2011, 06:06 AM   #6604
Tech Regular
 
ChefDementia's Avatar
 
Join Date: Dec 2008
Posts: 408
Trader Rating: 19 (100%+)
Default

Quote:
Originally Posted by mr crum View Post
what are you running car, motor, class ect.
ATM i have it in a blitz with a 10.5 but run a 13.5 some nights too.
ChefDementia is offline   Reply With Quote
Old 02-22-2011, 01:13 PM   #6605
Tech Master
 
Join Date: Feb 2009
Posts: 1,920
Trader Rating: 1 (100%+)
Default

Hey guys

I have decided to jump ship from stock to modified this year and have bought a GT2.0 speedo and Speed Passion 6.5v3 motor ,

now as i am a complete beginner at mod class i want a nice friendly set up for my T3 so that i can learn how to handle the power .

I have been racing stock with a Tekin RS and 13.5 speed passion motors for about 2 years so the speed differance shouldnt be too much but any help is greatly appreciated

Thanks Phil
sidecarphil1 is offline   Reply With Quote
Old 02-22-2011, 05:55 PM   #6606
Tech Master
 
mr crum's Avatar
 
Join Date: May 2008
Location: tampa florida 813
Posts: 1,591
Trader Rating: 5 (100%+)
Send a message via Yahoo to mr crum
Default

Quote:
Originally Posted by ChefDementia View Post
ATM i have it in a blitz with a 10.5 but run a 13.5 some nights too.
if you are running spec you should use 508 no timing but if you can run open speedo the i suggest you run 110212 it has boost i would go with default settings at first and drop 4 teeth on the pinion and remember flash the software on esc twice
__________________
SPEED PASSION TEAM DRIVER
ADAB RACING FACTORY PILOT
WWW.ADRENALINERACEWAY.COM
FL INDOOR R/C COMPLEX
TEAM B.R. RACING
mr crum is offline   Reply With Quote
Old 02-22-2011, 07:21 PM   #6607
Tech Fanatic
 
[[john]]'s Avatar
R/C Tech Elite Subscriber
 
Join Date: Oct 2005
Location: Melbourne, Australia
Posts: 835
Trader Rating: 24 (100%+)
Default

Did anyone else have a little trouble soldering wires to the 2.1 ProStock ESC for the first time?

I was easily able to tin the tabs, but as soon as I tried to solder wire to them, the alloy heatsink/case sucked the heat right back out

I changed to a larger iron tip, and turned the temp up to max (450*C) - Still had a little trouble, but got them on there .
__________________
HyperRC

Xray XB2 DE // XB4 '16 // RACEOPT MTS Tē // CRC XTi
[[john]] is online now   Reply With Quote
Old 02-24-2011, 05:33 AM   #6608
Tech Apprentice
 
SCTom's Avatar
 
Join Date: Oct 2010
Posts: 94
Default

This thread has been alittle quiet the past few days, so I just wanted too share my thoughts about new software. I loaded 101212 stock on my GT pro stock v2.1 esc. Everything works well, almost too much power for 2wd short course on medium traction track. Running 17.5 DOU 3.
SCTom is offline   Reply With Quote
Old 02-24-2011, 05:36 AM   #6609
Tech Elite
 
kwiksi's Avatar
 
Join Date: Feb 2009
Location: Fort Wayne, IN
Posts: 2,384
Trader Rating: 101 (100%+)
Send a message via AIM to kwiksi
Default

Quote:
Originally Posted by SCTom View Post
This thread has been alittle quiet the past few days, so I just wanted too share my thoughts about new software. I loaded 101212 stock on my GT pro stock v2.1 esc. Everything works well, almost too much power for 2wd short course on medium traction track. Running 17.5 DOU 3.
What are you geared at? Settings?
__________________
David Perez
Big thanks in 2016 to
Serpent/Desoto Racing - Jconcepts - Maclan Racing - Schelle Racing Innovations - Exotek Racing - Vision Racing Products - Reilley Motorsports - 92Zero Designs
kwiksi is offline   Reply With Quote
Old 02-24-2011, 05:50 AM   #6610
Tech Addict
 
Join Date: Dec 2006
Posts: 566
Trader Rating: 12 (100%+)
Default

I just purchased a gt2.1 pro stock to use with an epic d3 21.5. Is the newest software (101212) best to use? Or should I just use whatever it has on there already. I'm completely new to lipo/brushless (Haven't raced in 4 years) so not really sure what I am doing.

Thanks
J-PaP is offline   Reply With Quote
Old 02-24-2011, 07:01 AM   #6611
Tech Regular
 
Craig W's Avatar
 
Join Date: Sep 2010
Location: stoke on trent
Posts: 488
Trader Rating: 1 (100%+)
Send a message via MSN to Craig W Send a message via Skype™ to Craig W
Default

Hi was going to replace the rotor in my 13.5t v3 and I was wondering if the change it to the super 7 rotor or stay with the original 1
Craig W is offline   Reply With Quote
Old 02-24-2011, 07:47 AM   #6612
Tech Fanatic
 
irgo's Avatar
 
Join Date: Apr 2006
Posts: 893
Default

it seem that Speed Passion not releasing the 3rd generation Firmware yet,
...
__________________
Quark Force
irgo is offline   Reply With Quote
Old 02-24-2011, 10:52 AM   #6613
Tech Apprentice
 
SCTom's Avatar
 
Join Date: Oct 2010
Posts: 94
Default

SC10 geared at 26 pin. and 75 spur.
17.5 DOU 3 Venom 5000 40C.
esc settings 101212 software.
4=6
9=8
12=6
13=2
14=1
15=4
temps. in the 150s after 5 mins.
SCTom is offline   Reply With Quote
Old 02-24-2011, 03:45 PM   #6614
Tech Champion
 
Solara's Avatar
 
Join Date: Sep 2002
Location: Chicago Illinois USA
Posts: 9,042
Trader Rating: 16 (100%+)
Send a message via ICQ to Solara Send a message via AIM to Solara
Default

Quote:
Originally Posted by sidecarphil1 View Post
Hey guys

I have decided to jump ship from stock to modified this year and have bought a GT2.0 speedo and Speed Passion 6.5v3 motor ,

now as i am a complete beginner at mod class i want a nice friendly set up for my T3 so that i can learn how to handle the power .

I have been racing stock with a Tekin RS and 13.5 speed passion motors for about 2 years so the speed differance shouldnt be too much but any help is greatly appreciated

Thanks Phil
check out these setup....since you are running a 6.5 you have to gear up a little. I have a setup with MOD motor and boost, you can adjust your setting to more aggressive them mine (I was running 4.0)...

Or the good old 205MOD software are always a winner...good luck.
__________________
SPEED PASSION - King Golden, Speed Passion USA, Speed Power, Hirosaka Pro Products, East Coast Bodies, Schumacher Racing, Hurricane Motorsports, Serpent America, Sweep Racing USA. http://www.spautomobile.com/en/index.asp (SPEED PASSION AUTOMOTIVE)
NEW Speed Power/Speed Passion direct sale site - http://shop.speedpowerrc.com/
Solara is offline   Reply With Quote
Old 02-24-2011, 07:12 PM   #6615
Tech Elite
 
defcone's Avatar
 
Join Date: Feb 2009
Location: Sydney
Posts: 2,335
Trader Rating: 15 (100%+)
Default

Quote:
Originally Posted by [[john]] View Post
Did anyone else have a little trouble soldering wires to the 2.1 ProStock ESC for the first time?

I was easily able to tin the tabs, but as soon as I tried to solder wire to them, the alloy heatsink/case sucked the heat right back out

I changed to a larger iron tip, and turned the temp up to max (450*C) - Still had a little trouble, but got them on there .
What I did was tin both the wires and the tabs a little bit, then put the remaining required amount of solder on the tip. Then hold the wire against the tab and let the solder on your tip touch the wire and should flow onto the tab.
defcone is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speed Passion GT Competition Brushless ESC v2.0 Low Profile, LPF pink_sleeve Electric On-Road 13 07-08-2009 10:17 AM


Tags
gt2, lack of help, overpriced, poor customer service, reventon, reventon pro, speed passion


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 07:21 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0