R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 12-04-2009, 01:07 PM   #1906
Tech Elite
 
TommyBlazin's Avatar
 
Join Date: Feb 2009
Location: jersey
Posts: 2,580
Trader Rating: 29 (100%+)
Default

Quote:
Originally Posted by RC MARKET View Post
around wed back in stock !
these guys are full of bs..waited for him to be" back in stock" than he emails me today its in stock,but says sold out????, wait another 3 weeks, ive been waiting over a month..thanks market...
__________________
Thinking on maybe a Tekno 1/8 Nitro Buggy?
TommyBlazin is offline   Reply With Quote
Old 12-04-2009, 01:20 PM   #1907
Tech Regular
 
Join Date: Jun 2007
Posts: 320
Default

Quote:
Originally Posted by TommyBlazin View Post
these guys are full of bs..waited for him to be" back in stock" than he emails me today its in stock,but says sold out????, wait another 3 weeks, ive been waiting over a month..thanks market...
You have to get on there as soon as possible. I got on Wednesday evening and ordered my 2.
They should be here by Monday.....

Steve Dunn
sdunnmcp is offline   Reply With Quote
Old 12-04-2009, 03:36 PM   #1908
Tech Elite
 
Join Date: Oct 2002
Location: Mclean, VA
Posts: 3,940
Trader Rating: 45 (100%+)
Default

Quote:
Originally Posted by TommyBlazin View Post
these guys are full of bs..waited for him to be" back in stock" than he emails me today its in stock,but says sold out????, wait another 3 weeks, ive been waiting over a month..thanks market...
I pre-ordered one on Nov. 11 and should have it by Monday. You need to pre-order and he'll put an order in and then send it out to you when it arrives.
Apex is offline   Reply With Quote
Old 12-04-2009, 05:34 PM   #1909
Tech Elite
 
TommyBlazin's Avatar
 
Join Date: Feb 2009
Location: jersey
Posts: 2,580
Trader Rating: 29 (100%+)
Default

ive been in touch with him before nov11, first he said , hes not using yokomo anymore, that he will have a replacement company making the parts, than 2 weeks go by, i cannot get either he told me, last week comes on here says there coming in, sends me a email today that there in, but sold out!!! IS HE SERIOUS?>>>>and as far as pre-ordered, i did thru email, thru here,,,etc..
__________________
Thinking on maybe a Tekno 1/8 Nitro Buggy?
TommyBlazin is offline   Reply With Quote
Old 12-04-2009, 10:18 PM   #1910
Tech Fanatic
 
hotdognobun's Avatar
 
Join Date: Sep 2009
Location: San Diego
Posts: 823
Trader Rating: 31 (100%+)
Default

Quote:
Originally Posted by TommyBlazin View Post
ive been in touch with him before nov11, first he said , hes not using yokomo anymore, that he will have a replacement company making the parts, than 2 weeks go by, i cannot get either he told me, last week comes on here says there coming in, sends me a email today that there in, but sold out!!! IS HE SERIOUS?>>>>and as far as pre-ordered, i did thru email, thru here,,,etc..
Darn it Tommy!!! All day I've been tearing my house apart looking for my spare Yokomo Brace!! Alll Day!!! Where the hell did I put it????? I'm so piss I feel like just selling you mine off my car...HaaaHaaa. J/k. I'll look later feel like some modern warfare 2
hotdognobun is offline   Reply With Quote
Old 12-05-2009, 09:19 AM   #1911
Tech Elite
 
TommyBlazin's Avatar
 
Join Date: Feb 2009
Location: jersey
Posts: 2,580
Trader Rating: 29 (100%+)
Default

its ok cause your playing MW2...LOL....keep it up...PS3?
__________________
Thinking on maybe a Tekno 1/8 Nitro Buggy?
TommyBlazin is offline   Reply With Quote
Old 12-05-2009, 09:57 PM   #1912
Tech Master
 
wingman2's Avatar
 
Join Date: Dec 2005
Location: Tewkesbury, UK via Plymouth, UK.
Posts: 1,259
Default

Hi guys, I am in the middle of putting a brand new 5.1 together and just wanted to share some thoughts, and hopefully get some suggestions from you. First off, I am really suprised about the quality of the kit, for the WRONG reasons! The first problem I have encountered was getting the shock caps on. It seems that the threads in the caps do not match the threads on the shock bodies. I did manage to get them to go together in the end, but it is deffinately NOT right. Secondly, one of the balls under the side links is really tight. Not just snug, but mega tight! Again, no matter what you do, it's not right. Then, I moved onto the front end, and the actually suspension movement is terrible. The kingpin is either slightly too big, or the balls that the kingpin goes through are too small. Either way, it's binding really, really badly. I am really picky with things being just right during the building process, but this is really bad. I don't know if anyone else has had similar experiences or if this particular kit is a typical 'Friday afternoon' item! I will be taking the front end apart again to make it work correctly, I am really anal when it comes to things like that you see! After having an L4, and an L3 before that (and a LW many years ago), I was hoping for a better build than I have experienced so far. Any suggestions would be appreciated!! Cheers guys, Chris.
wingman2 is offline   Reply With Quote
Old 12-05-2009, 10:05 PM   #1913
Tech Addict
 
HaraR40's Avatar
 
Join Date: Dec 2008
Location: Bunbury WA
Posts: 517
Trader Rating: 33 (100%+)
Default ...

the only problem i had with mine was the kingpins were tight in the steering knuckles. i just run a drill bit through it (cant remember the size) and then they were fine. As far as the shocks go, they do have a very fine thread but are in no way WRONG like you say.
Maybe try turning the cap the opposite way till you feel a click (the threads line up) and then screw the cap on.
If your talking about the links that hold the rear and front chassis parts together then you should undo the tiny screws that pinch the ends closed. These should only be done up tight enough to still have free movement on the links.

I know a few guys have changed to the hot bodies centre shock as its all alluminium. i dont really have a problem with the Associated one though.

If your still not happy, contact Associated direct. i have not had to deal with them, but i hear they have excellent customer support/service.....
__________________
Full alloy Micro-t, orion 10,300kv brushless
Corally RDX PHi Drifter - 8.5T Lipo
Axial AX10 Crawler, Vanquish chassis/knuckles, tekin FXR/35t, lipo, DNA dig, HB rovers...
HI Blitz ESE, 10.5T, Lipo
HaraR40 is offline   Reply With Quote
Old 12-06-2009, 01:07 AM   #1914
Tech Fanatic
 
hotdognobun's Avatar
 
Join Date: Sep 2009
Location: San Diego
Posts: 823
Trader Rating: 31 (100%+)
Default

Associated has been kinda different lately. From the new lighter blue color to switching from standard to metric screws. I had issues too with both my r5 and r5.1. Didn't Associated form with Thunder Tiger?
hotdognobun is offline   Reply With Quote
Old 12-06-2009, 01:09 AM   #1915
Tech Elite
 
TommyBlazin's Avatar
 
Join Date: Feb 2009
Location: jersey
Posts: 2,580
Trader Rating: 29 (100%+)
Default

shouldnt u be brace hunting? j/k....
__________________
Thinking on maybe a Tekno 1/8 Nitro Buggy?
TommyBlazin is offline   Reply With Quote
Old 12-06-2009, 04:51 AM   #1916
MD
Tech Elite
 
MD's Avatar
 
Join Date: Aug 2005
Location: Illinois
Posts: 4,700
Trader Rating: 106 (100%+)
Default

In talking to my local hobby shop they have had more complaints about Associated products since they were purchased by Thunder Tiger.
MD is offline   Reply With Quote
Old 12-06-2009, 07:06 AM   #1917
Tech Fanatic
 
xtrememadness's Avatar
 
Join Date: Feb 2006
Location: new jersey
Posts: 954
Trader Rating: 1 (100%+)
Send a message via AIM to xtrememadness
Default

Quote:
Originally Posted by wingman2 View Post
Hi guys, I am in the middle of putting a brand new 5.1 together and just wanted to share some thoughts, and hopefully get some suggestions from you. First off, I am really suprised about the quality of the kit, for the WRONG reasons! The first problem I have encountered was getting the shock caps on. It seems that the threads in the caps do not match the threads on the shock bodies. I did manage to get them to go together in the end, but it is deffinately NOT right. Secondly, one of the balls under the side links is really tight. Not just snug, but mega tight! Again, no matter what you do, it's not right. Then, I moved onto the front end, and the actually suspension movement is terrible. The kingpin is either slightly too big, or the balls that the kingpin goes through are too small. Either way, it's binding really, really badly. I am really picky with things being just right during the building process, but this is really bad. I don't know if anyone else has had similar experiences or if this particular kit is a typical 'Friday afternoon' item! I will be taking the front end apart again to make it work correctly, I am really anal when it comes to things like that you see! After having an L4, and an L3 before that (and a LW many years ago), I was hoping for a better build than I have experienced so far. Any suggestions would be appreciated!! Cheers guys, Chris.
i had one pivot ball on the side links machined wrong and one of the pivot ball in front end was egg shaped. the front pivot balls are the same part as the old cars so you could always switch to bmi or irs pivot balls whitch are butter smooth!! also like harar40 said the shock caps are super fine thread and there is a sweet spot but they thread on smooth and in my opinion a better shock than the hotbodies. the molding is a little less quality than older kits but thats because its softer and just needs to be finnessed a little. all in all i was very impressed with this kit!! theres always gonna be problems with something that is mas produced. my tc5 went together with no problems at all enjoy the car!
__________________
CRAIG SANTRY / TAMIYA / TEAM ASSOCIATED / BROWNIES PRO AND SPORT HOBBIES / STATEN ISLAND SPEED TEAM / FUTABA / LRP / TEKIN / PROTOFORM / JACKSON RC / HORSHAM RC / EXOTEK RACING / REEDY
xtrememadness is offline   Reply With Quote
Old 12-06-2009, 07:43 AM   #1918
Tech Fanatic
 
fire929's Avatar
 
Join Date: Feb 2005
Location: Glen Burnie, MD
Posts: 923
Trader Rating: 13 (100%+)
Default

Quote:
Originally Posted by wingman2 View Post
Hi guys, I am in the middle of putting a brand new 5.1 together and just wanted to share some thoughts, and hopefully get some suggestions from you. First off, I am really suprised about the quality of the kit, for the WRONG reasons! The first problem I have encountered was getting the shock caps on. It seems that the threads in the caps do not match the threads on the shock bodies. I did manage to get them to go together in the end, but it is deffinately NOT right. Secondly, one of the balls under the side links is really tight. Not just snug, but mega tight! Again, no matter what you do, it's not right. Then, I moved onto the front end, and the actually suspension movement is terrible. The kingpin is either slightly too big, or the balls that the kingpin goes through are too small. Either way, it's binding really, really badly. I am really picky with things being just right during the building process, but this is really bad. I don't know if anyone else has had similar experiences or if this particular kit is a typical 'Friday afternoon' item! I will be taking the front end apart again to make it work correctly, I am really anal when it comes to things like that you see! After having an L4, and an L3 before that (and a LW many years ago), I was hoping for a better build than I have experienced so far. Any suggestions would be appreciated!! Cheers guys, Chris.

I will say I had the same problems with the shock caps, side link screw holes stripped, front pivot balls molded wrong. Front arms amd links binding with susp travel. Called AE and requested new parts and got the feeling like the customer service rep was tired of the request. Overall not impressed at all should have went with the serpent s120
__________________
Trex 450
Trex 600
EFL Heli's
Futaba 8fg
Align 3gx
fire929 is offline   Reply With Quote
Old 12-06-2009, 08:21 AM   #1919
Tech Master
 
mkdut's Avatar
 
Join Date: May 2006
Location: RC Retired
Posts: 1,961
Trader Rating: 19 (100%+)
Default

Quote:
Originally Posted by wingman2 View Post
Hi guys, I am in the middle of putting a brand new 5.1 together and just wanted to share some thoughts, and hopefully get some suggestions from you. First off, I am really suprised about the quality of the kit, for the WRONG reasons! The first problem I have encountered was getting the shock caps on. It seems that the threads in the caps do not match the threads on the shock bodies. I did manage to get them to go together in the end, but it is deffinately NOT right. Secondly, one of the balls under the side links is really tight. Not just snug, but mega tight! Again, no matter what you do, it's not right. Then, I moved onto the front end, and the actually suspension movement is terrible. The kingpin is either slightly too big, or the balls that the kingpin goes through are too small. Either way, it's binding really, really badly. I am really picky with things being just right during the building process, but this is really bad. I don't know if anyone else has had similar experiences or if this particular kit is a typical 'Friday afternoon' item! I will be taking the front end apart again to make it work correctly, I am really anal when it comes to things like that you see! After having an L4, and an L3 before that (and a LW many years ago), I was hoping for a better build than I have experienced so far. Any suggestions would be appreciated!! Cheers guys, Chris.
For the shock the cap will not thread correctly if there is too much oil and the o-ring is not sitting flush with the end of the shock body. Usually I need to "burp" the o-ring to release a little oil and allow it to sit flush. Once you get the hang of that it's no big deal. Also for thread the cap on try rotating the cap backwards until you feel the thread click then thread as normal. For the front the IRS balls work just fine I did find that the kit ones are a little tight and need to be reamed out.
mkdut is offline   Reply With Quote
Old 12-06-2009, 09:37 AM   #1920
Tech Master
 
wingman2's Avatar
 
Join Date: Dec 2005
Location: Tewkesbury, UK via Plymouth, UK.
Posts: 1,259
Default

Thanks for the replies guys, don't get me wrong, I am sure that the car is a great car, so much so, that one of the UK nationals was one last weekend with a R5.1. I did notice that the parts did seem to be made from a differant type of plastic than previous AE 12th kits, maybe that's from the Thunder Tiger side of things. I understand that a little bit of sanding, filing or reaming is usually in order for most kits, but was suprised at just how much on this particular car. Once it's all done though, I am sure it'll be just fine! The only thing is though, I also ordered the AE GT10 chassis to go with this one, let's hope that things are a little better with that build haha! Thanks again, cheers, Chris.
wingman2 is offline   Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
*Team Associated RC12R5* Zdiddy R/C Items: For Sale/Trade 8 08-31-2008 12:03 PM
RC12R5 Setup Sheets Cubic$Racing Electric On-Road 2 06-20-2008 10:27 AM
Team Associated RC12R5 ammo Singapore R/C Racers 12 05-15-2008 08:37 AM
AE RC12R5 alana07 Singapore R/C Racers 3 03-27-2008 09:56 PM



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 12:58 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net