R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Thread Tools Search this Thread
Old 12-20-2007, 03:17 PM   #31
Tech Elite
wallyedmonds's Avatar
Join Date: Jul 2006
Location: Brampton ont canada
Posts: 3,662

Originally Posted by Branden Moody View Post
I have been using IB 4200 WCs in stock at 6.0 amps 3mv peak and 6 amp discharge and havent had one vent mabe if you bumped up the charge to 7.0 you can have some problems. But i have poped the temp cut off several times at 125 f. I havent had any problems.
my cells dont vent ether
they die and performance go's down in a short time
i do everything the proper way as well. when it comes to charging.
you can still run them but at a big race they are a little laking
the 4200's im talking about.and i dont think the 4600's will be any different or maybe a little better but i wont know cuz im getting the Ener-G cells.
wallyedmonds is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
RB 23 Warranty Info rlouis12 Monster Trucks 1 04-04-2006 08:33 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 02:40 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0