R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Reply
 
Thread Tools Search this Thread
Old 07-08-2005, 08:54 PM   #12076
Tech Fanatic
 
Entropy's Avatar
 
Join Date: Feb 2003
Location: Singapore
Posts: 965
Default

Quote:
Originally Posted by axel
ANYONE NOTICE THE CRAZY AMOUNT OF PEOPLE SELLING THERE PRO4's here ?!?!
it's like christmas for me....but i don't think any of them are selling just the parts.
I dunno about you guys, but I'm gonna keep my Pro4 as the stock racer (23T where I live) and get the Cyclone as my mod racer.
Entropy is offline   Reply With Quote
Old 07-09-2005, 12:00 AM   #12077
Tech Master
 
axel's Avatar
 
Join Date: Jan 2005
Location: NorCal
Posts: 1,226
Default

i'm keepeing my pro4 for one my year then get the cyclone...unless i can't take it anymore.
axel is offline   Reply With Quote
Old 07-09-2005, 12:20 AM   #12078
Tech Addict
 
josh69162's Avatar
 
Join Date: Jun 2004
Location: houston
Posts: 640
Trader Rating: 2 (100%+)
Send a message via AIM to josh69162
Default

What's so much better about the Cyclone?
-Josh
josh69162 is offline   Reply With Quote
Old 07-09-2005, 12:26 AM   #12079
Tech Master
 
axel's Avatar
 
Join Date: Jan 2005
Location: NorCal
Posts: 1,226
Default

that's the thing none of us really know cause we never drove it...but hara says it handles better at high speeds.
axel is offline   Reply With Quote
Old 07-09-2005, 01:06 AM   #12080
Tech Regular
 
nw racer's Avatar
 
Join Date: Mar 2005
Location: Federal Way, WA.
Posts: 285
Default

What parts are needed to update my pro 4 to 2005 specs? Also, where can I get the parts. Thanks.
nw racer is offline   Reply With Quote
Old 07-09-2005, 01:47 AM   #12081
Tech Regular
 
Paladin's Avatar
 
Join Date: Mar 2005
Location: Australia
Posts: 275
Default understeer

My new Pro4 seems slow to turn into corners at speed. Have replaced servo, adjusted servo saver, put brand new Take Off RP's on, and still the same problem.

Having tried numerous setup sheets on my car and none of them seem to work, I returned the car to the manual "neutral" setup. Car seemed to handle better, and seemed fairly neutral, as in grip is good, rear hangs on, but understeer id horrific. Yes a bit twitchy if throttle applied after through corner but acceptable.

I have tried ellegi 35shore fronts (26mm) and 37rear, problem the same. Local club runs on asphalt netball courts.

Son is running the foams and having no problems. The difference in our setups is just tyres and Controller. Both running Gold/silver springs, 40wt F & 30wt R oil, swaybar.

I am running JR XS3, but cannot see what may be affecting turn. Everyhting is fine at low to mid speeds.

Any help would be appreciated.
Paladin is offline   Reply With Quote
Old 07-09-2005, 02:30 AM   #12082
Tech Regular
 
Carbon_Fibre3's Avatar
 
Join Date: Dec 2002
Location: sydneysider stuck in melbourne
Posts: 406
Default

when i used to run on asphalt i used 40r all round. gave the car awesome steering (with standard setup)

you could try making the rear oil 40 aswel to slow the roll towards the rear during corners
Carbon_Fibre3 is offline   Reply With Quote
Old 07-09-2005, 06:13 AM   #12083
Tech Regular
 
Join Date: May 2004
Location: riverside, nj
Posts: 254
Default

hey guys, i just recently bought a used pro4 for the up coming hpi challenge. i've ran a tc3 for the last 2 years, so i have some electric touring background. is there any problems with the car that need to be addressed or set-up for ashpalt with rubber tires that you guys know about? any hints would be a huge help.
owens is offline   Reply With Quote
Old 07-09-2005, 06:41 AM   #12084
Moderator
 
Artificial-I's Avatar
 
Join Date: Jan 2005
Location: Rurouni Kenshin
Posts: 3,459
Trader Rating: 17 (100%+)
Send a message via AIM to Artificial-I
Default

Quote:
Originally Posted by Thor_jnb
My new Pro4 seems slow to turn into corners at speed. Have replaced servo, adjusted servo saver, put brand new Take Off RP's on, and still the same problem.

Having tried numerous setup sheets on my car and none of them seem to work, I returned the car to the manual "neutral" setup. Car seemed to handle better, and seemed fairly neutral, as in grip is good, rear hangs on, but understeer id horrific. Yes a bit twitchy if throttle applied after through corner but acceptable.

I have tried ellegi 35shore fronts (26mm) and 37rear, problem the same. Local club runs on asphalt netball courts.

Son is running the foams and having no problems. The difference in our setups is just tyres and Controller. Both running Gold/silver springs, 40wt F & 30wt R oil, swaybar.

I am running JR XS3, but cannot see what may be affecting turn. Everyhting is fine at low to mid speeds.

Any help would be appreciated.
What body?
Artificial-I is offline   Reply With Quote
Old 07-09-2005, 06:54 AM   #12085
Tech Adept
 
Join Date: Oct 2002
Location: Melbourne
Posts: 182
Trader Rating: 1 (100%+)
Default

use the no1 shock pistons 50weight oil all round, silver front copper rear sway bars the rest stock
syntex1 is offline   Reply With Quote
Old 07-09-2005, 07:05 AM   #12086
Tech Regular
 
Paladin's Avatar
 
Join Date: Mar 2005
Location: Australia
Posts: 275
Default Turning Slow

Quote:
Originally Posted by Artificial-I
What body?
Just an old GTR body.

Have a Mazda 6 with the painter (He calls himself an Artist).

Why ask the "which body" question?

Since posting have changed rear oil wt to 40.

Also noticed rebound is slow on front. Will open up and check levels etc.
Paladin is offline   Reply With Quote
Old 07-09-2005, 09:32 AM   #12087
Tech Regular
 
floodo1's Avatar
 
Join Date: Sep 2003
Location: Fresno, CA
Posts: 452
Send a message via ICQ to floodo1 Send a message via AIM to floodo1 Send a message via Yahoo to floodo1
Default

Quote:
Originally Posted by josh69162
What's so much better about the Cyclone?
-Josh
its belt drive
floodo1 is offline   Reply With Quote
Old 07-09-2005, 10:26 AM   #12088
Tech Addict
 
josh69162's Avatar
 
Join Date: Jun 2004
Location: houston
Posts: 640
Trader Rating: 2 (100%+)
Send a message via AIM to josh69162
Default

Isn't belt only a lot better for mod? I remember reading that somewhere...
-Josh
josh69162 is offline   Reply With Quote
Old 07-09-2005, 10:39 AM   #12089
Tech Addict
 
josh69162's Avatar
 
Join Date: Jun 2004
Location: houston
Posts: 640
Trader Rating: 2 (100%+)
Send a message via AIM to josh69162
Default

Quote:
Originally Posted by Thor_jnb
My new Pro4 seems slow to turn into corners at speed. Have replaced servo, adjusted servo saver, put brand new Take Off RP's on, and still the same problem.

Having tried numerous setup sheets on my car and none of them seem to work, I returned the car to the manual "neutral" setup. Car seemed to handle better, and seemed fairly neutral, as in grip is good, rear hangs on, but understeer id horrific. Yes a bit twitchy if throttle applied after through corner but acceptable.

I have tried ellegi 35shore fronts (26mm) and 37rear, problem the same. Local club runs on asphalt netball courts.

Son is running the foams and having no problems. The difference in our setups is just tyres and Controller. Both running Gold/silver springs, 40wt F & 30wt R oil, swaybar.

I am running JR XS3, but cannot see what may be affecting turn. Everyhting is fine at low to mid speeds.

Any help would be appreciated.
Are all of your settings right on your radio? You may be depriving yourself of servo travel.
-Josh
josh69162 is offline   Reply With Quote
Old 07-09-2005, 11:12 AM   #12090
Tech Master
 
axel's Avatar
 
Join Date: Jan 2005
Location: NorCal
Posts: 1,226
Default

Quote:
Originally Posted by josh69162
Isn't belt only a lot better for mod? I remember reading that somewhere...
-Josh

well belt is suppose to have more top end speed so basically ya. But shaft has beter acceleration overall. Hmmm...i race stock i wonder how my style will change if i were to switch to belt. Anybody here raced stock using both belt and shaft? What differences did you notice?
axel is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off



All times are GMT -7. It is currently 11:00 PM.


Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0