R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Thread Tools Search this Thread
Old 06-03-2007, 05:13 PM   #1
Tech Champion
MikeXray's Avatar
Join Date: Oct 2006
Location: New York
Posts: 5,747
Trader Rating: 72 (100%+)
Default Spektrum DX3.0 problem

My transmitter died today, it was working fine, then out of nowhere it showed Er r on the screen, seemed to reset itself, back to mdl1 then just shutoff completely. I am just curious if anyone else had this issue, I'll contact horizon tommorow and send it in.
Mike L. Awesomatixusa.com | TQWire.com | Islandraceway.com |JacksonRCracing.com | Horsham RC | Sweepracingusa.com
MikeXray is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with spektrum in my M8 James Tanous Radio and Electronics 6 07-19-2008 11:50 AM
yet another spektrum problem cm367700 Radio and Electronics 11 12-19-2007 09:10 PM
spektrum problem blowpopracer Radio and Electronics 2 10-20-2007 05:46 PM
spektrum problem associatedguy Radio and Electronics 5 10-20-2007 02:43 AM
Spektrum problem Greenbandit Electric On-Road 9 04-25-2006 07:31 PM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 12:28 AM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0