R/C Tech Forums

Go Back   R/C Tech Forums > General Forums > Electric On-Road

Thread Tools Search this Thread
Old 02-25-2007, 12:32 PM   #1
Tech Fanatic
AWK's Avatar
Join Date: May 2006
Location: SoCal
Posts: 981
Trader Rating: 8 (100%+)
Default Novak XXL Bad Glitching???

I have had some glitching issue lately with my car, and after some reading elsewhere think it might be this receiver. Has anyone had a lot of glitching issues with this receiver before? I have tried two different XXLs in my car to see if that was the problem, but it seems that they both (one brand new, one used) had the same problems.
AWK is offline   Reply With Quote

Similar Threads
Thread Thread Starter Forum Replies Last Post
Glitching....please help Cristian Silva Australian Racing 23 06-14-2008 03:49 AM
Glitching with a Novak brushless ??? Timox Electric On-Road 21 12-22-2005 04:54 PM
Novak Switch for M8 - glitching? Dan_E Electric On-Road 2 09-21-2004 11:50 PM
Glitching on my 3PK FUK_WRX Electric On-Road 10 08-15-2003 08:50 AM
glitching tdragon Electric On-Road 10 06-17-2003 10:03 AM

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off

All times are GMT -7. It is currently 10:57 PM.

Powered By: vBulletin v3.9.2.1
Privacy Policy | Terms of Use | Advertise Content © 2001-2011 RCTech.net

SEO by vBSEO 3.5.0